Subject: [Fecframe] Fwd: Several ways you can publish I-Ds with pre 5378 content - TODAY

From: Marshall Eubanks <[email-masked]>
Date: Mon, 23 Feb 2009 18:10:03 -0500

The ID tools are supposed to be updated soon, but in case you don't  
want to wait...

Note that this applies to text with inclusions dated prior to November  
10, 2008. Entirely new drafts do not
need to worry about any of this.

Regards
Marshall

Begin forwarded message:

> From: Cullen Jennings <[email-masked]>
> Date: February 23, 2009 5:19:13 PM EST
> To: Working Group Chairs <[email-masked]>, IETF discussion list <[email-masked] 
> >
> Subject: Several ways you can publish I-Ds with pre 5378 content -  
> TODAY
>
>
> Method 1: (Not recommended)
>
> Go read the BCP and Trust statement and edit your .txt to have the  
> right text.
>
>
>
> Method 2: (Recommended for people using word template)
>
> Go look at a draft that did work, such as
> http://tools.ietf.org/html/draft-jennings-http-srv-01
>
> And copy the Copyright Notice section into your draft
>
>
>
> Method 3: XML2RFC approach recommended for folks that run xml2rfc  
> locally
>
> Get the very hacked version at
> http://svn.resiprocate.org/rep/ietf-drafts/xml2rfc/1.34pre2-fluffy/xml2rfc.tcl
>
> This will soon be obsoleted when the real xml2rfc tool gets updated.  
> Don't worry, Julian, Bill, and Marshal are working on that. They  
> will produce something much better than my hack of xml2rfc
>
> Set the ipr attribute in the <rfc> element to  
> ipr="pre5378Trust200902" and it will produce a txt file that id  
> submission tool will accept.
>
>
>
> Method 4: XML2RFC approach for folks that run xml2rfc on the web
>
> Use the experimental version from http://xml.resource.org/experimental.html 
> . You can download the zip or tgz file on this page or use the  
> online version at this page.
>
> Make sure you have
>
> <?rfc strict="no" ?>
> somewhere above the <rfc> element.
> In the <rfc> element, set the ipr attribute to ipr="trust200811"
> Change your abstract to use a note. Do this by changing
> <abstract> <t> This draft is about ... </t> </abstract>
> To
> <note title="Abstract"><t> This draft is about ...</t> </note>
> And before this not insert a note like
> <note title=""> <t> This document may contain material from IETF  
> Documents or IETF Contributions published or made publicly available  
> before November 10, 2008. The person(s) controlling the copyright in  
> some of this material may not have granted the IETF Trust the right  
> to allow modifications of such material outside the IETF Standards  
> Process. Without obtaining an adequate license from the person(s)  
> controlling the copyright in such materials, this document may not  
> be modified outside the IETF Standards Process, and derivative works  
> of it may not be created outside the IETF Standards Process, except  
> to format it for publication as an RFC or to translate it into  
> languages other than English. </t> </note>
>
> You can seen the XML for an example I-D that does this at
> http://svn.resiprocate.org/rep/ietf-drafts/fluffy/example.xml
>
> That should work - good luck
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 23 Feb 2009 18:00:43 -0500

Regards
Marshall