Subject: [Fecframe] I-D Action:draft-ietf-fecframe-rtp-raptor-01.txt

From: [email-masked]
Date: Fri, 6 Mar 2009 11:15:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the FEC Framework Working Group of the IETF.

	Title           : RTP Payload Format for Raptor FEC
	Author(s)       : M. Watson
	Filename        : draft-ietf-fecframe-rtp-raptor-01.txt
	Pages           : 20
	Date            : 2009-03-06

This document specifies an RTP Payload Format for Forward Error
Correction repair data produced by the Raptor FEC Schemes.  Raptor
FEC Schemes are specified for use with the IETF FEC Framework which
supports transport of repair data over both UDP and RTP.  This
document specifies the Payload Format which is required for the use
of RTP to carry Raptor repair flows.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-fecframe-rtp-raptor-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Watson, Mark" <[email-masked]>
Date: Fri, 6 Mar 2009 11:20:30 -0800

All,

I submitted a -00 of this on Wednesday to meet the -00 deadline, but I had not made any changes from the initial draft.

The main change in this -01 draft is for the case when SDP is used to describe the session to require normal RTP Payload Format parameters to be used to carry the 'FEC Object Transmission information', which is FEC parameters which remain constant for the whole stream (specifically source block size and symbol size). Previously these were carried in an 'opaque container' in a new SDP attribute defined for FECFRAME. The SDP attribute is what would be used for the UDP case, but for the RTP case it is common (or possibly required) practice (and also easier to understand) to use RTP Payload Format parameters within the a=fmpt line.

This approach is based on the most commonly expressed sentiment (I can't say more than that!) on the email thread cross-posted to AVT/FECFRAME which I started as an action from the last FECFRAME meeting.

I also removed some references to my former employer that I missed in the -00.

...Mark

On 3/6/09 11:15 AM, "[email-masked]" <[email-masked]> wrote: