Subject: [Fecframe] Additive FEC flows

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 21 Apr 2009 14:52:17 -0700

This question is related to draft 4756bis, which is an MMUSIC draft but the question probably belongs to FECFRAME. Comments are welcome from both WGs.

In the new semantics we are proposing (FEC-XR), which supports describing additive repair flows in the SDP (Additivity is signaled if the repair flows are in the same group). There is a "language" question and I would like to hear your opinions.

Suppose that we have a source flow (S1) and two repair flows (R1, R2). If the repair flows are not additive with each other, we MUST have in the SDP:

     a=group:FEC-XR S1 R1
     a=group:FEC-XR S1 R2

However, if the repair flows are additive, MUST or SHOULD we write the following?

     a=group:FEC-XR S1 R1 R2

Because writing

     a=group:FEC-XR S1 R1
     a=group:FEC-XR S1 R2

would not be strictly wrong, either. In other words, we must state explicitly when the repair flows are not additive, but are we also required to state explicitly when they are additive? My personal view is that we "must" do so to avoid any confusion and fully benefit from this new semantics.

-acbegen

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 21 Apr 2009 19:12:45 -0400

I would say that this is a MUST. Of course, most repair flows will be  
additive.

Marshall

On Apr 21, 2009, at 5:52 PM, Ali C. Begen (abegen) wrote:

> This question is related to draft 4756bis, which is an MMUSIC draft  
> but the question probably belongs to FECFRAME. Comments are welcome  
> from both WGs.
>
> In the new semantics we are proposing (FEC-XR), which supports  
> describing additive repair flows in the SDP (Additivity is signaled  
> if the repair flows are in the same group). There is a "language"  
> question and I would like to hear your opinions.
>
> Suppose that we have a source flow (S1) and two repair flows (R1,  
> R2). If the repair flows are not additive with each other, we MUST  
> have in the SDP:
>
>    a=group:FEC-XR S1 R1
>    a=group:FEC-XR S1 R2
>
> would not be strictly wrong, either. In other words, we must state  
> explicitly when the repair flows are not additive, but are we also  
> required to state explicitly when they are additive? My personal  
> view is that we "must" do so to avoid any confusion and fully  
> benefit from this new semantics.
>
> -acbegen
> _______________________________________________
> Fecframe mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fecframe
>

Regards
Marshall Eubanks
CEO / AmericaFree.TV