Subject: [Fecframe] DVB AL-FEC integration in FECFRAME - proposed changes

From: "Henry Jean-Baptiste" <[email-masked]>
Date: Fri, 28 Aug 2009 10:03:30 +0200

Dear fecframe list,

I would like to provide some inputs about the DVB-IPTV AL-FEC
specification.
Several IETF drafts are currently under writing process to integrate the
DVB-IPTV AL-FEC specification into the IETF FECFRAME system, which is
very positive and goes in the direction of improved interoperability
between DVB-IPTV systems and IETF protocols.
The DVB-TM-IPI group has reviewed the current drafts relating to the
DVB-IPTV AL-FEC and thus I would like to propose some changes for your
consideration to clarify the relationship between DVB-IPTV AL-FEC,
technologies referenced, e.g. SMPTE and the IETF FECFRAME.

Please find attached two documents:
*	draft-ietf-fecframe-dvb-al-fec-01 DVB-TM-IPI.doc
*	draft-ietf-fecframe-interleaved-fec-scheme-05 DVB-TM-IPI.doc
You will find the proposed modifications in Word track change mode and
comments.
I apologize if those docs refer to old versions of the drafts, it took
some time to review them in DVB IPI meeting.

As my email will not be valid after today, please provide any comment or
question to Muriel Deschanel (in copy). Muriel is the chair of the
DVB-TM-IPI group which defined the DVB AL-FEC system.

Best Regards

Jean-Baptiste HENRY

 <<draft-ietf-fecframe-interleaved-fec-scheme-05 DVB-TM-IPI.doc>>  
<<draft-ietf-fecframe-dvb-al-fec-01 DVB-TM-IPI.doc>>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 28 Aug 2009 05:23:23 -0700

Hi JB,

Thanks for the comments. FYI, the interleaved-fec-scheme draft has completed its last call in both fecframe and AVT months ago and AFAIK, the chairs already asked for request for publication from the AD. Nevertheless, I looked at the comments. In fact, there was only one major comment, which was simply to delete the references to the ETSI spec. To tell the truth, I don't understand the reason. The goal of this draft was to develop an RTP-compliant parity FEC payload format (as close as possible to the base layer) and list the exceptions to make it compatible with the DVB implementation.

As for the informational dvb-al-fec draft: I can make some of the changes for clarification but I must say I cannot agree with most of the comments, text changes and deletions. We cannot refer to SMPTE 2022-1 spec as it is broken from our viewpoint. In fact, this is the reason why we had to write the other draft in the first place.

If you still feel strong about these comments, I suggest you (or someone else) present the reasoning in the list (not on a word doc) and we all can comment on/discuss/finalize the text. As a reminder, we are in the WGLC process for this draft.

Cheers,
-acbegen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Henry
> Jean-Baptiste
> Sent: Friday, August 28, 2009 11:04 AM
> To: [email-masked]
> Cc: Muriel Deschanel
> Subject: [Fecframe] DVB AL-FEC integration in FECFRAME - proposed changes
> 
> Dear fecframe list,
> 
> I would like to provide some inputs about the DVB-IPTV AL-FEC specification.
> 
> Several IETF drafts are currently under writing process to integrate the DVB-IPTV AL-FEC
> specification into the IETF FECFRAME system, which is very positive and goes in the
> direction of improved interoperability between DVB-IPTV systems and IETF protocols.
> 
> The DVB-TM-IPI group has reviewed the current drafts relating to the DVB-IPTV AL-FEC and
> thus I would like to propose some changes for your consideration to clarify the
> relationship between DVB-IPTV AL-FEC, technologies referenced, e.g. SMPTE and the IETF
> FECFRAME.
> 
> •       draft-ietf-fecframe-dvb-al-fec-01 DVB-TM-IPI.doc
> 
> •       draft-ietf-fecframe-interleaved-fec-scheme-05 DVB-TM-IPI.doc
> 
> You will find the proposed modifications in Word track change mode and comments.
> 
> I apologize if those docs refer to old versions of the drafts, it took some time to review
> them in DVB IPI meeting.
> 
> As my email will not be valid after today, please provide any comment or question to
> Muriel Deschanel (in copy). Muriel is the chair of the DVB-TM-IPI group which defined the
> DVB AL-FEC system.
> 
> Best Regards
> 
> Jean-Baptiste HENRY
> 
> <<draft-ietf-fecframe-interleaved-fec-scheme-05 DVB-TM-IPI.doc>> <<draft-ietf-fecframe-
> dvb-al-fec-01 DVB-TM-IPI.doc>>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 31 Aug 2009 14:12:23 -0700

Hi Muriel,

Inline.

> From: Muriel Deschanel [mailto:[email-masked]]
> Sent: Monday, August 31, 2009 11:29 PM
> To: Ali C. Begen (abegen); [email-masked]
> Cc: Jeff Goldberg (jgoldber); Henry Jean-Baptiste
> Subject: RE: [Fecframe] DVB AL-FEC integration in FECFRAME - proposed changes
> 
> Dear Ali, all,
> 
> I will try and explain some of the rationale behind the comments and modifications that
> Jean-Baptiste sent earlier.
> DVB has published a specification for AL-FEC, as annex E of the DVB-IPTV specification
> from revision 1.3 and later.
> The base layer of the DVB AL-FEC specification references SMPTE 2022. We understand that
> RTP compatibility issues have been identified in the SMPTE 2022 specification and we hope
> that SMPTE will be able to address them in a future revision of their specification.

I sure hope so, too.
 
> We believe that it is useful to define a new fec scheme where the compatibilities issues
> with RTP are resolved but it should be clear that this is no longer the DVB AL-FEC
> specification. The proposed changes have been submitted by Jean-Baptiste to clarify this

Of course. The 1-d draft is not claiming that it is the exact FEC method as adopted by DVB al-fec. Rather, it explains all the differences in detail. If there is a difference I missed, I will be more than happy to correct it. 

OTOH, the DVB al-fec informational draft explains how one can use the 1-d and raptor drafts and produce dvb-compatible fec stream(s) by following certain rules. Nothing more.

> point and avoid any confusion between the scheme defined in interleaved-fec-scheme and the
> DVB-IPTV AL-FEC specification. This is essential because the DVB-IPTV AL-FEC specification
> is referenced by other organizations, e.g. Rec. H.701 of the ITU-T. So it will create
> confusion and potentially interoperability issues if changes (to address the RTP issues)
> are introduced in an internet draft that references the DVB-IPTV AL-FEC though these
> changes do not reflect the actual DVB-IPTV AL-FEC specification.
> 
> 
> Could you please give some information on the proposed changes which you feel are not
> acceptable and I will try and address your points.

Based on the feedback we received so far, I will try to submit a revision soon. I'll then ask you to make your comments on that revision. 

> For information, the latest DVB-IPTV specification is revision 1.4 and was published in
> August 2009.

Thanks, will update this in the revision as well.

Cheers,
-acbegen
 
> Best regards,
> 
> Muriel Deschanel
> Chair of DVB TM-IPI group
> 
> +33 6 64 40 44 11
> 
> -----Message d'origine-----
> De : Ali C. Begen (abegen) [mailto:[email-masked]]
> Envoyé : vendredi 28 août 2009 14:23
> À : Henry Jean-Baptiste; [email-masked]
> Cc : Muriel Deschanel
> Objet : RE: [Fecframe] DVB AL-FEC integration in FECFRAME - proposed changes
> 
> Hi JB,
> 
> Thanks for the comments. FYI, the interleaved-fec-scheme draft has completed its last call
> in both fecframe and AVT months ago and AFAIK, the chairs already asked for request for
> publication from the AD. Nevertheless, I looked at the comments. In fact, there was only
> one major comment, which was simply to delete the references to the ETSI spec. To tell the
> truth, I don't understand the reason. The goal of this draft was to develop an RTP-
> compliant parity FEC payload format (as close as possible to the base layer) and list the
> exceptions to make it compatible with the DVB implementation.
> 
> As for the informational dvb-al-fec draft: I can make some of the changes for
> clarification but I must say I cannot agree with most of the comments, text changes and
> deletions. We cannot refer to SMPTE 2022-1 spec as it is broken from our viewpoint. In
> fact, this is the reason why we had to write the other draft in the first place.
> 
> If you still feel strong about these comments, I suggest you (or someone else) present the
> reasoning in the list (not on a word doc) and we all can comment on/discuss/finalize the
> text. As a reminder, we are in the WGLC process for this draft.
> 
> Cheers,
> -acbegen
> 
> 
> 
> > .       draft-ietf-fecframe-dvb-al-fec-01 DVB-TM-IPI.doc
> >
> > .       draft-ietf-fecframe-interleaved-fec-scheme-05 DVB-TM-IPI.doc
> >

---

From: Muriel Deschanel <[email-masked]>
Date: Mon, 31 Aug 2009 21:29:17 +0100

Dear Ali, all,

I will try and explain some of the rationale behind the comments and modifications that Jean-Baptiste sent earlier.
DVB has published a specification for AL-FEC, as annex E of the DVB-IPTV specification from revision 1.3 and later. 
The base layer of the DVB AL-FEC specification references SMPTE 2022. We understand that RTP compatibility issues have been identified in the SMPTE 2022 specification and we hope that SMPTE will be able to address them in a future revision of their specification.

We believe that it is useful to define a new fec scheme where the compatibilities issues with RTP are resolved but it should be clear that this is no longer the DVB AL-FEC specification. The proposed changes have been submitted by Jean-Baptiste to clarify this point and avoid any confusion between the scheme defined in interleaved-fec-scheme and the DVB-IPTV AL-FEC specification. This is essential because the DVB-IPTV AL-FEC specification is referenced by other organizations, e.g. Rec. H.701 of the ITU-T. So it will create confusion and potentially interoperability issues if changes (to address the RTP issues) are introduced in an internet draft that references the DVB-IPTV AL-FEC though these changes do not reflect the actual DVB-IPTV AL-FEC specification.

Could you please give some information on the proposed changes which you feel are not acceptable and I will try and address your points.

For information, the latest DVB-IPTV specification is revision 1.4 and was published in August 2009.

Best regards,

Muriel Deschanel

+33 6 64 40 44 11

-----Message d'origine-----

Hi JB,

Cheers,
-acbegen