Subject: [Fecframe] comments on draft-ietf-fecframe-dvb-al-fec-02.txt

From: zouzixuan <[email-masked]>
Date: Sun, 30 Aug 2009 13:20:04 +0800

Hi, All
	The followings are my comments on
draft-ietf-fecframe-dvb-al-fec-02.txt:
	Page 6, in SSRC item: " It is RECOMMENDED that the DVB AL-FEC
protocol uses this mechanism for explicit SSRC signaling"
			Doe it make sense to use the keyword "RECOMMEDED"
within the scope of IETF to guide the way of using SSRC for AL-FEC protocol
specified in DVB? 

			".....the sender does not have to select a random
initial sequence number for the FEC stream as suggested by [RFC3550]."
					Using a static sequence number
certainly had no problem and is merely a implementation issue. So why not
just let it be random to be fully compatible with RFC3550 . These words
seems to be redundant.
	
	Page 9   "... Due to the lack of the format parameters, it is not
possible to learn the FEC parameters from the SDP description. This severely
limits the ability of using multiple FEC streams that are generated with
different settings. "
				Agree with this argument. This might be
taken into account for more flexible usage if a new RTP profile for AL-FEC
were brought up.

Best,
Zou ZiXuan, Senior Research Staff
Media & Communication Lab
HUAWEI TECHNOLOGIES CO.,LTD. 

Address: Huawei Industrial Base
Bantian Longgang
Shenzhen 518129, P.R.China
Tel: +86 0755 28789364
Fax: +86 0755 28788317
E-mail: [email-masked]
www.huawei.com
----------------------------------------------------------------------------
---------------------------------------------------------
This e-mail and its attachments contain confidential information from
HUAWEI, which 
is intended only for the person or entity whose address is listed above. Any
use of the 
information contained herein in any way (including, but not limited to,
total or partial 
disclosure, reproduction, or dissemination) by persons other than the
intended 
recipient(s) is prohibited. If you receive this e-mail in error, please
notify the sender by 
phone or email immediately and delete it!

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sat, 29 Aug 2009 22:44:15 -0700

Thanks for the review.

My comments are inline.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of zouzixuan
> Sent: Sunday, August 30, 2009 8:20 AM
> To: [email-masked]
> Cc: 'Ali C. Begen'; 'Thomas Stockhammer'
> Subject: [Fecframe] comments on draft-ietf-fecframe-dvb-al-fec-02.txt
> 
> 
> Hi, All

Using a deterministic SSRC=0 value is a special case, and is only acceptable by RTP if it is signaled explicitly. 

Do you think we should say "MUST" or "SHOULD"? 

> just let it be random to be fully compatible with RFC3550 . These words

Yes, RFC 3550 recommends using random initial seqnums, as does [I-D.ietf-fecframe-interleaved-fec-scheme]. But, in AL-FEC, this behavior is not really specified. This sentence emphasizes this point. We do not want to specify anything that is not defined in the AL-FEC protocol.

> taken into account for more flexible usage if a new RTP profile for AL-FEC

Right. A new RTP profile would resolve most of the outstanding issues.

-acbegen

> Fecframe mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fecframe

---

From: zouzixuan <[email-masked]>
Date: Sun, 30 Aug 2009 15:38:12 +0800

Hi, Ali
	Inline.

-----Original Message-----
From: Ali C. Begen (abegen) [mailto:[email-masked]] 
Sent: Sunday, August 30, 2009 1:44 PM
To: zouzixuan; [email-masked]
Cc: Thomas Stockhammer
Subject: RE: [Fecframe] comments on draft-ietf-fecframe-dvb-al-fec-02.txt

Thanks for the review.

My comments are inline.

> within the scope of IETF to guide the way of using SSRC for AL-FEC
protocol

Using a deterministic SSRC=0 value is a special case, and is only acceptable
by RTP if it is signaled explicitly. 

[zou] It seems that I lead to a misunderstanding. Sorry. I'm asking whether
it makes sense to stipulate in IETF the manner of a DVB standard by using
the IETF keywords "RECOMMENDED" or "MUST" whatever. Maybe a lowercase form
would be more proper. 

> just let it be random to be fully compatible with RFC3550 . These words

Yes, RFC 3550 recommends using random initial seqnums, as does
[I-D.ietf-fecframe-interleaved-fec-scheme]. But, in AL-FEC, this behavior is
not really specified. This sentence emphasizes this point. We do not want to
specify anything that is not defined in the AL-FEC protocol.

-acbegen

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 31 Aug 2009 00:15:44 -0700

> the IETF keywords "RECOMMENDED" or "MUST" whatever. Maybe a lowercase form

That keyword applies to the ones who will use an IETF spec (interleaved-fec draft) to implement the al-fec protocol. So, I believe the use of the keyword(s) is appropriate.

-acbegen

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 31 Aug 2009 11:46:55 -0400

Hi,

This may be a bit out of context, and if so, I apologize.

Am I right that this I-D attempts to circumscribe an existing ETSI spec in
IETF lingo?  What's the purpose of this exercise?

Unrelated to the technical aspects here, it seems odd to me that an IETF
informational RFC-to-be would attempt to use any RFC 2119 normative language
to describe what is already specified elsewhere (using non-RFC2119 lingo).
First, arguably, an informational RFC should not use RFC2119 language at
all---as it is informational.  Second, there may be subtle differences
between the interpretation of the normative languages of the two
organization which could be lost in the "translation" process.  That, in
turn, could lead to incompatible implementations stemming from the different
specs.  

On a more general note, the abstract should be more concise, and (especially
in cases like this) focus on the obvious question of the purpose of the
document, rather than the technical details.

Regards,
Stephan

On 8/31/09 3:15 AM, "Ali C. Begen (abegen)" <[email-masked]> wrote:

> That keyword applies to the ones who will use an IETF spec (interleaved-fec
> draft) to implement the al-fec protocol. So, I believe the use of the
> keyword(s) is appropriate.
> 
> -acbegen

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 31 Aug 2009 14:04:56 -0700

Hi Stephan,

Inline.

> From: Stephan Wenger [mailto:[email-masked]]
> Sent: Monday, August 31, 2009 6:47 PM
> To: Ali C. Begen (abegen); zouzixuan; [email-masked]
> Cc: Thomas Stockhammer
> Subject: Re: [Fecframe] comments on draft-ietf-fecframe-dvb-al-fec-02.txt
> 
> Hi,
> 

The goal is to describe the AL-FEC protocol by using the IETF-approved specs. I believe this is a pretty good reason to have an informational rfc (The WG agreed on this when we submitted the first version).

> all---as it is informational.  Second, there may be subtle differences

We attempted to use 2119 language for the implementers of the 1-d draft to become compatible with the al-fec protocol. Is this incorrect use of the 2119 language?

If it is, then we can certainly lower-case those words. 

> turn, could lead to incompatible implementations stemming from the different

I suppose lower-case words will help with this, too.
 
> document, rather than the technical details.

OK. An updated abstract will be included in the next revision.

BR,
-acbegen

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 31 Aug 2009 17:36:08 -0400

Hi Ali,

On 8/31/09 5:04 PM, "Ali C. Begen (abegen)" <[email-masked]> wrote:

> [...]
> We attempted to use 2119 language for the implementers of the 1-d draft to
> become compatible with the al-fec protocol. Is this incorrect use of the 2119
> language?
> 

RFC 2119 language is common in informational RFCs, so let me row back a bit
on my first point.

> I suppose lower-case words will help with this, too.

Indeed it would, and it would make me feel more comfortable.

Stephan

---

From: zouzixuan <[email-masked]>
Date: Tue, 01 Sep 2009 08:40:58 +0800

Hi, All
	I attend to agree with Stephan that lowercase is more appropriate in
this case. 

Best

-----Original Message-----
From: Stephan Wenger [mailto:[email-masked]] 
Sent: Tuesday, September 01, 2009 5:36 AM
To: Ali C. Begen (abegen); zouzixuan; [email-masked]
Cc: Thomas Stockhammer
Subject: Re: [Fecframe] comments on draft-ietf-fecframe-dvb-al-fec-02.txt

Hi Ali,

Stephan