Subject: Re: [Fecframe] WG Last-call: draft-ietf-fecframe-framework-07

From: "Watson, Mark" <[email-masked]>
Date: Tue, 1 Jun 2010 09:33:32 -0700

Greg, All,

I have submitted a new version -08, which addresses the Last Call comments from Vincent and which uses the latest copyright boilerplate.

The draft is at: http://www.ietf.org/id/draft-ietf-fecframe-framework-08.txt

and the diffs from the -07 at http://bit.ly/apYW5x.

Aside from the editorial changes suggested by Vincent there are a couple of improvements to the Security section.

...Mark

On May 25, 2010, at 8:28 AM, Greg Shepherd wrote:

Thanks for jumping in here! Okay, I think we have enough feedback now
to proceed. I'll post the shepherding doc this week.

Greg

On Tue, May 25, 2010 at 8:23 AM, Thomas Stockhammer
<[email-masked]<mailto:[email-masked]>> wrote:
Mark, Greg, all

I support this version to move forward ...

Thomas

On May 25, 2010, at 5:21 PM, Watson, Mark wrote:

Well, in case it's not obvious - though I guess it is - I agree that this should go forward.

...Mark

On May 18, 2010, at 10:10 AM, Greg Shepherd wrote:

Thanks Vincent!

Okay, that's two respondents. I can't move this forward without a few
more of you responding. Please read and send your notes and/or
approval to the list so we can move this to Pub Req ASAP!

Thanks,
Greg

On Mon, May 17, 2010 at 8:55 AM, Vincent Roca <[email-masked]<mailto:[email-masked]>> wrote:
Mark, all,

Since I already provided extensive comments on the previous version,
I only gave a quick look to version 07.
I'm happy with the new definitions (section 2) which are IMHO of utmost
importance to harmonize the vocabulary used in all the FECFRAME I-Ds
and to clarify the architectural concepts.

Therefore I support this version.

** A few easy to fix typos for draft-ietf-fecframe-framework-07:

* in section 2 (Definitions):

- in definition of "Application protocol", the sentence mentions
"protocols" with a final "s", but only provides a single example.
Using singular is probably sufficient, otherwise use "protocol(s)".

- in definition of "FEC Scheme", I suggest (parenthesis misplacement):
"(or in the context of RMT, with the RMT FEC Building Block)."

- the 'Encoding symbol' definition appears twice (in the
"source symbol" definition the 1st time).

- there's an orphan "s" in 'Source Block' definition. BTW, the
notion of source block is already defined above. I'd remove it
from the general subsection to keep it in the RFC5052 specific
part.

** a few additional comments for section 10 (security considerations)

- Nothing is said about the possibility of forging the FEC Scheme
Specific Information, another way of launching a DoS.

- This section refers to "source transport payloads", which is no
longer one of the official terms defined in section 2.

- If integrity protection is required, I don't think it makes
sense to apply it within the "Source Protocol" (application).
As you explain, integrity MUST be verified by the receiver ASAP,
before launching FEC decoding. Even if the FECFRAME instance is
able to check the integrity of source symbols before launching
decoding, it will not cover the explicit Source FEC Payload ID
(if used) which is a big issue.
To summarize: if integrity is a MUST, this MUST be done in lower
layers, within the  transport or IPsec (or similar) layers.

- this section could be improved (it's a little bit light IMHO)
but we can also wait for the secdir review.

Regards,

 Vincent

_______________________________________________
Fecframe mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/fecframe

_______________________________________________
Fecframe mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/fecframe

_______________________________________________
Fecframe mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/fecframe

---
Dr. Thomas Stockhammer (CEO) || [email-masked]<mailto:[email-masked]> || phone +49 89 978980 02 || cell +491725702667 || http://www.nomor-research.com
Nomor Research GmbH  -  Sitz der Gesellschaft: München - Registergericht: München, HRB 165856 – Umsatzsteuer-ID: DE238047637 - Geschäftsführer: Dr. Thomas Stockhammer, Dr. Ingo Viering.

---

From: Greg Shepherd <[email-masked]>
Date: Tue, 1 Jun 2010 09:40:15 -0700

Thanks! I'll finish up the Shepherd doc today and move it along.

Greg

On Tue, Jun 1, 2010 at 9:33 AM, Watson, Mark <[email-masked]> wrote:
> Greg, All,
> I have submitted a new version -08, which addresses the Last Call comments
> from Vincent and which uses the latest copyright boilerplate.
> <[email-masked]> wrote:
>
> Mark, Greg, all
>
> On Mon, May 17, 2010 at 8:55 AM, Vincent Roca <[email-masked]>
> wrote:
>
> Mark, all,
>
>
> [email-masked]
> [email-masked]
> [email-masked]
> Dr. Thomas Stockhammer (CEO) || [email-masked] || phone +49 89 978980
> 02 || cell +491725702667 || http://www.nomor-research.com
>
> Nomor Research GmbH  -  Sitz der Gesellschaft: München - Registergericht:
> München, HRB 165856 – Umsatzsteuer-ID: DE238047637 - Geschäftsführer: Dr.
> Thomas Stockhammer, Dr. Ingo Viering.
>
>
>
>
>
>
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Tue, 1 Jun 2010 12:02:02 -0500

Hi Greg,

The latest config-signaling draft has incorporated all the outstanding comments as well. Should that be moved along as well?

Cheers,
Rajiv

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Greg Shepherd
> Sent: Tuesday, June 01, 2010 12:40 PM
> To: Watson, Mark
> Cc: [email-masked]
> Subject: Re: [Fecframe] WG Last-call: draft-ietf-fecframe-framework-07
> 
> > Aside from the editorial changes suggested by Vincent there are a
> couple of
> > improvements to the Security section.
> > ...Mark
> >
> >
> > Well, in case it's not obvious - though I guess it is - I agree that
> this
> > should go forward.
> >
> > ...Mark
> >
> > München, HRB 165856 - Umsatzsteuer-ID: DE238047637 - Geschäftsführer:
> Dr.

---

From: Greg Shepherd <[email-masked]>
Date: Tue, 1 Jun 2010 10:15:16 -0700

We need to take it to WG Last Call first. I'll send a dedicated email
to start the feedback thread.

Greg

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Tue, 1 Jun 2010 12:55:08 -0500

You mean, the 2nd WG LC?

Cheers,
Rajiv

> From: Greg Shepherd [mailto:[email-masked]]
> Sent: Tuesday, June 01, 2010 1:15 PM
> To: Rajiv Asati (rajiva)
> Cc: Watson, Mark; [email-masked]
> > The latest config-signaling draft has incorporated all the
> outstanding comments as well. Should that be moved along as well?
> >
> >
> > Cheers,
> > Rajiv
> >
> >> > Dr. Thomas Stockhammer (CEO) || [email-masked] || phone +49
> 89
> >> 978980