Subject: [Forces-protocol] RE: ForCES Protocol Analysis Design Team Administrivia

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Wed, 3 Mar 2004 22:54:34 -0800

Hi Jamal

Your list below looks good to me, we can start more detailed discussion
on this soon. (We have already discussed some of the items below) I sent
out a list of more high level ideas that I think we agree on. Let me
know what you think about it.

Thanks
Hormuzd

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Tuesday, March 02, 2004 7:16 PM
To: Khosravi, Hormuzd M
Cc: Putzolu, David; [email-masked]; [email-masked];
[email-masked]; Steve Blake; Robert Haas;
[email-masked]; [email-masked]; Wang,Weiming; Patrick Droz;
jeff pickering; [email-masked]; Deleganes, Ellen M; [email-masked];
[email-masked]; [email-masked]
Subject: RE: ForCES Protocol Analysis Design Team Administrivia

Hormuzd,

On Tue, 2004-03-02 at 19:54, Khosravi, Hormuzd M wrote:
> Hi Jamal, All
> 
> I briefly chatted with David, Patrick regarding our deliverables by
> March 20th and I got a feeling that they are looking for whether we
can
> merge the protocols and what are the high level design features that
we
> all agree on.
> I think most of us already agree that we can achieve a merge if we
work
> towards it. I would suggest that we first try to get all the high
level
> features list out and agree on it, then proceed to the details.
> 
> So in that spirit I would suggest to postpone getting into details
such
> as length of bits in the header, what the format is, etc for now and
> quickly come up with a list of common ideas. Some of the items below
> that we all seem to agree on may be a good start.
> 

We could make the encoding discussion the last thing but it needs
to be discussed as we are discussing the mechanisms.

The main discussion points as i see it (to extend what David posted)
are:

1) Encoding
2) Multiple channels/connections
3) Transport: unicast/multicast/broadcast 
{ TCP, UDP, SCTP, DCCP, Direct over L2 or proprietary backplanes, TIPC} 
4) Congestion control
5) Reliability
6) Security
7) High availability

Its almost like 2-5 are very closely related.

I am doing this off the top of my head so i probably missed something.

cheers,
jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 04 Mar 2004 16:32:46 -0500

Hormuzd,
Based on your other posting i would like to suggest we start the
following:

1) start with discussing the value of the ID to the app. 
2) Lets then follow with a little bit time on the encoding. 
I am sure there will be changes on the header down the road as we keep
discussing; but lets have a start on it. 
3) lets move to the transport discussion on the dual approach.

For 1) & 2) above i will repost some of the ideas i posted 
earlier and lets take it from there.

cheers,
jamal