Subject: RE: [Forces-protocol] Issue 3:Transport/Unicast/Multicast/Broadcast

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 15 Mar 2004 12:42:18 -0800

Jamal

There are a few things which I would like to get clarified from you...

Are you opposed to having a differentiation on IP basis, rather than
'close proximity' ? The Ads seemed to be suggesting a differentiation on
IP basis which is different from what you have stated below. 

Are you suggesting that Only Multicast must be used in certain cases ?
or is it Unicast + Multicast if interconnect support both else only
Unicast ?
From what I have read in your emails, for netlink2 you have used both
Unicast and Multicast, not just multicast but I just want to confirm
this.

I have some text on this issue, but I would like to get this clarified
before I post it so that we are on the same page.

regards
Hormuzd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Jamal Hadi Salim

Alex,
Sorry I slowed down a little there.   

On Thu, 2004-03-11 at 16:43, Alex Audu wrote:
> Issue 3: 
> 
> We can start by agreeing that Unicast is a MUST implement, and MCAST,
> BCAST a 
> SHOULD.
> 
> Any comments?

Well I like the AD suggestions, which to quote David:

---
"dual mandatory" approach.  I.e.:

If your underlying interconnect supports multicast,
then you MUST implement the following (multicast)
method of communication.

If your underlying interconnect supports unicast, then
you MUST implement the following (unicast) method
of communication.

This will guarantee interop, although at a potential
extra cost (cost being having to potentially support
both when both are present).  While this isn't optimal,
it does at least give some flexibility.
-------

In my opinion multicast should be used only within a 
"close proximity" only.

cheers,
jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 15 Mar 2004 16:41:39 -0500

Hormuzd,

> IP basis which is different from what you have stated below. 

I actually dont want to restrict to just IP.
Ethernet, TIPC over X, etc. It makes sense to use multicast on
]close proximity to avoid a lot of complexities that are 
seen when you need to maintain state on routers across 
a large network.

> or is it Unicast + Multicast if interconnect support both else only

More of "if available" MUST be used. So if multicast is available,
use it. I would think Unicast is always available.
This is very similar to what OSPF does.

> Unicast and Multicast, not just multicast but I just want to confirm

Yes we used both.
TCP on one connection and multicast UDP on another.
CE transmitted on udp/multicast and retransmitted on TCP.
Our metric was COST in both bandwidth and CPU.
You send one message onto all FEs if you use Multicast; saving on both 
CPU and b/width and then you retransmit only on unicast (TCP) because
there is no point for other FEs which have ACKed to see the message
again and ACK it again

> before I post it so that we are on the same page.

Hope above helps/clarifies.

cheers,
jamal