Subject: RE: [Forces-protocol] RE: Summary for issues 0-5

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 22 Mar 2004 11:24:49 -0800

Thanks Jamal, appreciate your comments!

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 

On Mon, 2004-03-22 at 12:09, Khosravi, Hormuzd M wrote:
> Incorporating Weiming's, Jamal's comments...
> 
> Issue# 0 IDs in the header:-
> There was a lot of discussion on this topic regarding the naming,
> semantics, length of these IDs.
> The result was as follows...
> Naming: CE ID, FE ID
> Semantics: Used to address a single, group or all CEs/FEs respectively
> Length: 16-32 bits...TBD
> 
> Another issue we reached agreement on was using LFB Type ID, LFB
> Instance ID in combination of FE ID for addressing LFBs on the FE. The
> LFB IDs will be part of the payload.

Did you mean LFB instance ID?
[HK] I meant both LFB Type ID and LFB instance ID mentioned in the
previous sentence.
I will clarify this explicitly in the text.

> 
> Issue# 1 Header/Encoding:-
> Here are the fields in the common header that there was consensus
around
> IDs: as summarized in issue 0
> Version/sub-ver: 4 bits
> Sequence No. : 32 bits
> Length : 16 bits
> Command Type : 8 bits (semantics - TBD)
> Flags: 16 bits, including 1-3 bits for Priority. (The semantics/length
> of Flags and Priority fields is TBD)
> 
> TypeID: TBD, no consensus on whether it is needed or not

In issue 0 you talk about LFB typeID. This is the same thing, no?
[HK] I am not sure, this is something that you had mentioned but we did
not reach any agreement around whether it is needed or not, what are the
semantics, etc. That's why I have left it as TBD, I assume will be
revisiting this in the future.

Issues 2-5: I think that TML should be introduced first then you should
talk about TML satisfying those issues.
Infact i feel there is no point in mentioning any protocols by name
since its the TML thats responsible for delivering 2-5. Granted it may
want to use TCP - but thats just an example.

[HK] Alright I will introduce some text on TML before describing these
issues(2-5). BTW, I have not mentioned only TCP at any place, I have put
both TCP/SCTP as you, others had suggested.

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 22 Mar 2004 14:42:35 -0500

> I will clarify this explicitly in the text.

The LFBID is not something we agreed on as to be on the payload or the
header. The reasoning was that based on some threshold it may make sense
to put it in the header. At least i raised this in some emails.
so It is to be discussed as to where it belongs.
The Instance id is definetely in the body.

> revisiting this in the future.

It is definetly the same one. So have both as TBD.

> both TCP/SCTP as you, others had suggested.

I would think the generic view should be that of the TML.
Infact i started writting the HA text with explicit mention of the role
of the TML. I think this is the way we should proceed from now on.

cheers,
jamal