Subject: RE: [Forces-protocol] Issue 2: Multiple channels/connections

From: "Putzolu, David" <[email-masked]>
Date: Mon, 15 Mar 2004 11:05:54 -0800

Weiming Wang wrote> 
> I think another solution for this issue is to leave the 
> remained (actually only a little) disagreement for 
> further discussion, so that at that time we may have 
> more time to deal with it and based on more understanding of 
> the problem we may reach an agreement.

I think this is the best path forward.

This seems like one of the more subtle issues and might
be better dealt with later.  I think someone else (Avri?
Jamal?) also mentioned leaving this as an open topic and
looking at some of the later issues.

Unless someone strongly objects, I suggest we take Weiming's
proposed solution and mark this as "needs further discussion"
and focus on the remaining issues, coming back to this later.

-David

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 15 Mar 2004 14:52:12 -0500

On Mon, 2004-03-15 at 14:05, Putzolu, David wrote:
[..]
> and focus on the remaining issues, coming back to this later.

Agreed. Lets close it for now.
I think the issue is resolvable; we just need to beat more on it.
Lets defer that for later.
Shall we close this?

cheers,
jamal

---

From: Alex Audu <[email-masked]>
Date: Mon, 15 Mar 2004 14:16:31 -0600

I gave further thoughts to the dual channel proposal and how that 
impacts the
ForCES protocol specification.  It became clear to me that there are really
two parts to the protocol itself: 
  1) the Core protocol that is independent of the transport
   2) the Adaptation layer that resolves issues with specific trasnport 
mothodology.

The debate we have been having, I think has been due to the thought that 
the we need
to specify the core protocol to aslo adapt to one/two-channel transport 
links.

The is the model I see going forward:

|------------------|
|    ForCES Core |
|        (CE)           |
|------------------|
|       Adaptation   |
|         Layer         |
|------------------|
           |
           |  transport link
           |
|-----------------|
|      Adaptation   |
|        Layer         |
|-----------------|
|   ForCES Core |
|     ( FE )           |
|-----------------|        

The ForCES Core is generic and independent of the transport mode. The 
Adaptation
layer is a thin layer that mostly does mapping to/from trasport. This is 
where dual/single
channel issue is resolved.  We can also do tunneling here if we want .  
This allows us to
decouple the transport issue from the core protocol.

Any comments?

Regards,
Alex.

---

From: [email-masked]
Date: Tue, 16 Mar 2004 07:33:25 +0800

This definitely agrees with my thoughts.

The issue of multiple connections is a transport issue and can safely 
be deferred.

a.

On 16 mar 2004, at 04.16, Alex Audu wrote:

>  layer is a thin layer that mostly does mapping to/from trasport. This 
> is where dual/single
>  channel issue is resolved.  We can also do tunneling here if we want 
> .  This allows us to

---

From: [email-masked]
Date: Tue, 16 Mar 2004 08:24:29 +0800

Hi Avri, Alex,

That's exactly the point. It also definitely agrees with our thoughts. 

I believe this issue can be solved quite well later when we have more time and 
gain more mutual technically understanding with each other. 

I agree to close it.

Cheers,
Weiming

> >  decouple the transport issue from the core protocol.

-------------------------------------------------
This mail sent through HUCNIC Webmail system.

---

From: Jon Maloy <[email-masked]>
Date: Mon, 15 Mar 2004 21:04:33 -0500

Sounds like an excellent idea. 
Following the previous discussion would summarize the properties of 
such a layer:

1- It would hide the specific aspects of, and if necessary compensate
the 
    missing functionality of transport protocol actually used, whether
it is 
    TCP,UDP, raw Ethernet or something else.

2: It adds negligible or very little overhead to the carrying protocol.

3: It takes the decision whether to use physical multiast or sequenctial
    unicast for CE-FE control messages, based on which transport is
available,
    and its knowledge about the network (number of and distance to 
    recipients.)

4: It provides different connection types with different priorities and
properties 
   (reliable/unreliable) to the ForCES base protocol, so that
    handling of data messages and control messages can be
differentiated.

5: It supervises the channels so that communication failure will be
quickly
    detected.

I am sure we will find more to add here as we move along.

/Jon

[email-masked] <mailto:[email-masked]>  wrote:

Hi Avri, Alex,

I believe this issue can be solved quite well later when we have more
time and 

I agree to close it.

Cheers,

Weiming

Quoting  [email-masked]: <mailto:[email-masked]:> 

be deferred.

a.

    

Adaptation

is where dual/single

.  This allows us to

 Any comments?

[email-masked] <mailto:[email-masked]> 

https://www1.ietf.org/mailman/listinfo/forces-protocol
<https://www1.ietf.org/mailman/listinfo/forces-protocol> 

[email-masked] <mailto:[email-masked]> 

https://www1.ietf.org/mailman/listinfo/forces-protocol
<https://www1.ietf.org/mailman/listinfo/forces-protocol> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: Jamal Hadi Salim <[email-masked]>
Date: 16 Mar 2004 08:05:45 -0500

Like they say theres always a first time; in this case a first time I
have not disagreed with something in a message from Alex ;-> 

cheers,
jamal