Subject: RE: [Forces-protocol] Issue 0: Application addressing

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Wed, 10 Mar 2004 10:26:34 -0800

Weiming, Jamal,
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Wang,Weiming

As Jamal asked, I'll first clarify what the tree
FEID:FETypeID:FEInstanceID
means.
Firstly, I should say, there are two possible descriptions for such a
tree
structure:
The first is to have it as a whole ID and put it at the ForCES message
header,
and at the receiver side to resolve it from the head to the tail. I'l
call this
as an explicit description. I think Jamal actually means this
description.
The second is to have it implicitly described in the ForCES messages.
That is,
for instance, to have FEID put in the message header and may have put
LFBTypeID
and LFBInstanceID in the message body if needed.

I would say the second method is more flexible and reasonable, and what
I mean
is actually the second one.

[HK] I definitely agree with Weiming on this addressing scheme and how
to place it in the protocol. This is same as the FE Model and I don't
see any issues with this scheme.

Regards
Hormuzd

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 10 Mar 2004 16:33:26 -0500

> see any issues with this scheme.

Hormuzd,
What is it that you are agreeing to? is it the
FEID:FETypeID:FEInstanceID or FEID:LFBTypeID:LFBInstanceID scheme
he described?

cheers,
jamal