Subject: [Forces-protocol] Summary of Protocol Messages (Command Types)

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Tue, 18 May 2004 10:08:04 -0700

Hi All,

Here is the summary of the Protocol Messages (Command Types)

1.  Association Setup msg/ Setup Resp/ 
    Association Teardown (using a flag or just msg type? - Weiming pls
confirm)
    
2. Query / Query resp msg
    - includes FE capability query, LFB Topology as well as Inter-FE
Topology query

3. Config / Config resp msg

4. State Maintenance msg/ State Maintenance Resp
    - includes Activate FE, Deactivate FE, Move Primary CE

5. Event msg / Event Resp
    - includes Subscribe, Unsubscribe, Report/Notification

6. Packet Redirect msg
    - includes FE->CE redirect packet as well as CE->FE forward packet

7. Heart Beat msg

Regards
Hormuzd

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Robert Haas <[email-masked]>
Date: Tue, 18 May 2004 20:33:50 +0200

Hormuzd,
Thanks for the summary. Some comments below:

>    - includes Activate FE, Deactivate FE, Move Primary CE
I'd rather avoid creating new messages for each State Maintenance action 
(especially since we don't know all of them yet). Instead, one could 
make use of an FE LFB with attributes sfor each of these actions, and 
use the standard Config messages to act on these attributes. Adding new 
actions will simply translate into new versions of the FE LFB, instead 
of new protocol message types.

>    - includes FE->CE redirect packet as well as CE->FE forward packet

I want to make sure that we all understand the implications of choosing 
such message types:

For instance, this means that it is not possible to mix in the same PL 
message a Config action as well as an Event Subscribe action for the 
same LFB instance. I find this annoying especially becauseI don't 
understand why we need to differentiate at the Common-Header level 
between a Config and an Event Subscribe, as both are destined to an LFB 
anyway, as opposed to Association Setup or HB messages.

Regards,
-Robert

-- 
Robert Haas
IBM Zurich Research Laboratory
Säumerstrasse 4
CH-8803 Rüschlikon/Switzerland
phone +41-1-724-8698  fax +41-1-724-8578  http://www.zurich.ibm.com/~rha

---

From: "Wang,Weiming" <[email-masked]>
Date: Wed, 19 May 2004 16:54:21 +0800

Hi Hormuzd,

----- Original Message -----
From: "Khosravi, Hormuzd M" <[email-masked]>

Hi All,

1.  Association Setup msg/ Setup Resp/
    Association Teardown (using a flag or just msg type? - Weiming pls
confirm)
[Weimig] I still prefer the flag method : - ) .

Thank you.
Weiming

6. Packet Redirect msg

7. Heart Beat msg

Regards
Hormuzd