Subject: RE: [Forces-protocol] T in TLV, another thought

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Wed, 19 May 2004 18:52:34 -0700

Weiming,
 
Thanks for your comments.

-----Original Message-----

p.s. To further clarify, it would make sense to have Operation (Add,
Del, etc) part of T if we would define different TLV or PDU for
different Operations. I don't think that is the case, but do you think
the PDU will be different for each Operation ??
[Weiming]Yes, the PDU for different ops will be quite different. E.g.,
to add a route, we need to tell the route value, to update a route, we
need to know the old route value and to tell the new value. For event
msgs, the PDU for different event ops are also quite different, e.g.,
sub/unsub differ event notification format.
 
[HK] I see where the confusion is, since the actual route information is
a variable length field which is kind of opaque to the rest of the TLV.
Anyways i will go with your suggestion for now although i believe we
might want to revisit later. 
 
BTW, what did you think about Avri's suggestion of TfLV ? It looks like
a neat idea to me if we decide to have some common flags,
 
regards
Hormuzd

---

From: "Wang,Weiming" <[email-masked]>
Date: Thu, 20 May 2004 11:14:16 +0800

MessageHi Hormuzd,

  ----- Original Message ----- 
  From: Khosravi, Hormuzd M 
  To: Weiming Wang ; [email-masked] 
  Sent: Thursday, May 20, 2004 9:52 AM
  Subject: RE: [Forces-protocol] T in TLV, another thought

  Weiming,

    -----Original Message-----

          p.s. To further clarify, it would make sense to have Operation (Add, Del, etc) part of T if we would define different TLV or PDU for different Operations. I don't think that is the case, but do you think the PDU will be different for each Operation ??
          [Weiming]Yes, the PDU for different ops will be quite different. E.g., to add a route, we need to tell the route value, to update a route, we need to know the old route value and to tell the new value. For event msgs, the PDU for different event ops are also quite different, e.g., sub/unsub differ event notification format.

          [HK] I see where the confusion is, since the actual route information is a variable length field which is kind of opaque to the rest of the TLV. Anyways i will go with your suggestion for now although i believe we might want to revisit later. 
          [Weiming]I'm also thinking of this, that is, how to represent an attribute value described by FE model. I'l send you any thoughts when I have some view on it. 

          BTW, what did you think about Avri's suggestion of TfLV ? It looks like a neat idea to me if we decide to have some common flags,

          [Weiming] That's a good suggestion. Maybe the flag for 'FE attr/LFB attri' can be as a common flag, because 3 msgs(query, config, event) may all use it. Besides this, currently I have not yet found more, but we may keep an eye on it.
           
          regards
          Hormuzd

          Cheers,
          Weiming