Subject: [Forces-protocol] T in TLV, another thought

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 17 May 2004 18:20:25 -0700

Hi Team
 
Thanks for the comments on the Global vs local scope for T in TLV.
 
Another design principle that I would like to share and get your
thoughts on is...
How do we choose semantics for T ? The basic principle is that a
different T should mean a different V, essentially T defines V.
To give you an example... in the Config message format that I had sent
out, I used T to mean either FE or LFB attributes.
This is cause I see the V in case of T=LAB attributes having fields such
as LAB Type, LAB Instance ID. In case T=FE attributes, we probably wont
have these 2 fields. Does that help understand the logic for defining T
?
 
Do you guys think this is a good design principle ?
 
Let me know,
 
Thanks
Hormuzd

---

From: "Weiming Wang" <[email-masked]>
Date: Tue, 18 May 2004 10:05:39 +0800

MessageHi Hormuzd,

----- Original Message ----- 
  From: Khosravi, Hormuzd M 
  To: [email-masked] 
  Sent: Tuesday, May 18, 2004 9:20 AM
  Subject: [Forces-protocol] T in TLV, another thought

  Hi Team

  Another design principle that I would like to share and get your thoughts on is...
  How do we choose semantics for T ? The basic principle is that a different T should mean a different V, essentially T defines V.
  To give you an example... in the Config message format that I had sent out, I used T to mean either FE or LFB attributes.
  This is cause I see the V in case of T=LAB attributes having fields such as LAB Type, LAB Instance ID. In case T=FE attributes, we probably wont have these 2 fields. Does that help understand the logic for defining T ?
  [Weiming] I think I (Jamal as well) have already presented the idea on the Value format difference of LFB attribute/event and FE attribute/event (in my emal on event msg format and also in the reply to your emal). I just think only mentioning the FE or LFB in T is not enough to have global meaning, e.g., LFB query and LFB config may have quite different PDU format. We should include operation code in the T (as I and Jamal proposed).  Hope we can be more synchronous on this issue : -). 

  Let me know,

  Thanks
  Hormuzd

  Cheers,
  Weiming

---

From: [email-masked]
Date: Tue, 18 May 2004 10:13:00 +0200

In general I agree with the principle that the type (T) defines the 
value (V).  The only exception I might favor is that we  talk about 
TfLV, where the f is a standard small set of flags that indicates some 
general properties about how the tlv is handled.  this is not to say 
the the TLV cannot also have an specific set of flags inside the V.

a.

On 18 maj 2004, at 03.20, Khosravi, Hormuzd M wrote:

> This is cause I see the V in case of T=LAB attributes having fields 
> such as LAB Type, LAB Instance ID. In case T=FE attributes, we 
> probably wont have these 2 fields. Does that help understand the logic 
> for defining T ?
>  

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol