Subject: RE: [Forces-protocol] topic 4c: Common Header: batching

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 10 May 2004 13:13:18 -0700

Weiming,

Thanks for posting this summary. It sounds very reasonable to me.
I think you guys are pretty close to closing this one now.

regards
Hormuzd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Weiming Wang

I'v just thought of one thing. I think if it may be better to consider
the batch
and the atomicity as two separate issues. Based on your summary, I
describe my
thought as follows,

1. Batching
PL appearance: msg chains.
Flag used: BatchFlag
BatchFlag = 1 - used by first msg and all middle msgs in the batch
          = 0 - used by last of the batch msg, indicating the end of the
batch
When in non-batch mode, msg is always set to BatchFlag = 0.

Default fail mode: to do whatever it can and fail those it cannot.

ACK mode: according to ACK flag in individual msg headers.

The BatchFlag is actually used as a signal for TML pinepining
implementation.
TML is responsible for things like MTU check and fragment. I think TML
should be
also responsible for the check of PL msg boundaries, because it seems in
our
current msg chain mode for batch, TML is inevitable to check the msg
headers.
But hornestly, I'm not sure if this is out of the scope of TML or not.

2. Atomicity
PL appearance: msg chains.
Flag used: AtomicFlag
AtomicFlag = 1 - used by first msg and all middle msgs in the atomic
           = 0 - used by last msg in the atomic, indicating the end of
the
atomic and also as a signal for a receiver to excecute the atomic.
When in non-atomic mode, msg is always set to AtomicFlag = 0

Default fail mode: all or nothing

ACK mode: according to ACK flag in individual msg headers.

3. Atomicity in batching
Just operate separately in the same way as described above except that
the fail
mode for atomicity has previlege over that of batching, that is, if in
an
atomic, fail mode must be all or nothing.
A batch may contain more than one atomic.

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: "Wang,Weiming" <[email-masked]>
Date: Tue, 11 May 2004 08:48:27 +0800

Jamal, Hormuzd,

I'v  just suggested to use 2 bits flag for the ACK purpose as:

00 - No any response
01 - only with negative response, no response if successful
10 - only with positive response, no response if unsuccessful
11 - response in any cases

Thank you.

Weiming