Subject: RE: [Forces-protocol] T in TLV, another thought

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Tue, 18 May 2004 12:00:57 -0700

Avri,

I like this idea of common flags for TLV. I think this can be part of the Type, 8 bits for the actual Type and 8 bits for Flags. How does that sound ? This might also accommodate any flags such as the ones that Jamal, Weiming were suggesting in todays call.

Regards
Hormuzd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]

In general I agree with the principle that the type (T) defines the 
value (V).  The only exception I might favor is that we  talk about 
TfLV, where the f is a standard small set of flags that indicates some 
general properties about how the tlv is handled.  this is not to say 
the the TLV cannot also have an specific set of flags inside the V.

a.

On 18 maj 2004, at 03.20, Khosravi, Hormuzd M wrote:

>  
> Thanks for the comments on the Global vs local scope for T in TLV.
>  
> Another design principle that I would like to share and get your 
> thoughts on is...
> How do we choose semantics for T ? The basic principle is that a 
> different T should mean a different V, essentially T defines V.
> To give you an example... in the Config message format that I had sent 
> out, I used T to mean either FE or LFB attributes.
> This is cause I see the V in case of T=LAB attributes having fields 
> such as LAB Type, LAB Instance ID. In case T=FE attributes, we 
> probably wont have these 2 fields. Does that help understand the logic 
> for defining T ?
>  
> Do you guys think this is a good design principle ?
>  

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Thu, 20 May 2004 11:33:51 -0700

Hi Weiming,

-----Original Message-----
From: Wang,Weiming [mailto:[email-masked]] 

BTW, what did you think about Avri's suggestion of TfLV ? It looks like
a neat idea to me if we decide to have some common flags,
 
[Weiming] That's a good suggestion. Maybe the flag for 'FE attr/LFB
attri' can be as a common flag, because 3 msgs(query, config, event) may
all use it. Besides this, currently I have not yet found more, but we
may keep an eye on it.
 
[HK] I wouldnt consider FE attr/LFB attr as flags. I was thinking more
along the lines of an Atomic flag for TLVs that you guys were discussing
on the call. (If that makes sense to have)
 
regards
Hormuzd