Subject: [Forces-protocol] T in TLV ?

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Fri, 14 May 2004 19:09:50 -0700

Hi Team,
 
One question that Jamal raised, do we want to have global scope for T in
the TLV across all messages ?
i.e. Type 0x1 means something for Association Setup msg and Type 0x32
means something for Config msg.
 
The other option is local scope i.e. Type 0x1 means something for
Association Setup msg and 
Type 0x1 means something else in Config msg.
 
I agree with Jamal that uniform semantics and global scope would be
cleaner, 
however let us know what you all think ??

Thanks
Hormuzd

---

From: "Weiming Wang" <[email-masked]>
Date: Sat, 15 May 2004 17:25:48 +0800

MessageHi all,

I'm ok to have T with global meaning, though I think it actually make little sense, because the msg type has quite limited the global use of the TLVs. Actually till now, I still have not noticed one TLV that can be used across different msgs. One advantage for local T is that it may supply more space, but actually I think currently we are not short of the space. 

As a summary,  my opinion is both are ok to me.

Cheers,
Weiming

----- Original Message ----- 
  From: Khosravi, Hormuzd M 
  To: [email-masked] 
  Sent: Saturday, May 15, 2004 10:09 AM
  Subject: [Forces-protocol] T in TLV ?

  Hi Team,

  One question that Jamal raised, do we want to have global scope for T in the TLV across all messages ?
  i.e. Type 0x1 means something for Association Setup msg and Type 0x32 means something for Config msg.

  The other option is local scope i.e. Type 0x1 means something for Association Setup msg and 
  Type 0x1 means something else in Config msg.

  I agree with Jamal that uniform semantics and global scope would be cleaner, 
  however let us know what you all think ??

  Thanks
  Hormuzd

---

From: [email-masked]
Date: Sat, 15 May 2004 13:49:40 +0200

>  however let us know what you all think ??

I agree that having a single global T space of TLVs is preferable.

I am not sure what you mean by uniform semantics.  I think each TLV 
should allowed to vary according to type, but would expect the the TL 
and fields, and possible a status and flags field to be uniform.

a.

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol