Subject: RE: peering WAS(Re: [Forces-protocol] Summary : Protocol Messages:topic 3 & 4a

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Wed, 5 May 2004 19:06:41 -0700

Jamal,

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
> 
> Subscribe/Unsubscribe msg
> [Weiming] This is a little ridiculous msg. Do you mean 'event
sub/unsub' ? I
> don't think Jamal agrees this also.  A config or a Event msg can do
this well.

I think we need config messages going from FE to CE informing it of
events as well. Not all events fit under this message, but a subset
does.
Is this what you are refering to Weiming? Just remember that not all
events fit in that model. Also the subscription is needed otherwise the
default should be you get no events.

[HK] Just to clarify again, you are saying that we need a Subscribe msg,
right ?
Just want to clear this one,

Thanks
Hormuzd

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 05 May 2004 22:30:43 -0400

> Just want to clear this one,

I think a subscribe message is important to have. In our implementation
we didnt have a subscribe message and the default was to send all config
events. This sometimes resulted in a lot of annoying unneeded messages.

cheers,
jamal

---

From: "Weiming Wang" <[email-masked]>
Date: Fri, 7 May 2004 13:19:27 +0800

Jamal,
----- Original Message -----
From: "Jamal Hadi Salim" <[email-masked]>

> events. This sometimes resulted in a lot of annoying unneeded messages.
[Weiming]Jamal, I think we all have no doubt that to subscribe/unsubscribe
events is definitely necessary. The difference between Hormuzd and me is if we
need to have specific msgs to do this or not. My idea is it can be very easily
done by config msg, therefore we don't need a specific msg (according to Hormuzd
idea, 4 msgs, sub and resp, unsub and resp) to do this. In this way, we actually
treat the sub/unsub as an FE attribute, behind which is actually an event
sub/unsub table. My idea is we have just used a quite synthisized msg mode, why
should we spend so many msgs in this very tiny task then.

We'd like to hear your thoughs on this.

Thank you.
Weiming