Subject: RE: [Forces-protocol] topic 4c: Common Header

From: [email-masked]
Date: Wed, 5 May 2004 04:41:46 -0400

Hello Jamal,Hormuzd and others,

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ext Jamal 
> Hadi Salim
> Sent: Tuesday, May 04, 2004 11:15 PM
> To: Khosravi, Hormuzd M
> Cc: Weiming Wang; [email-masked]
> Subject: RE: [Forces-protocol] topic 4c: Common Header
> 
> 
> On Tue, 2004-05-04 at 23:05, Khosravi, Hormuzd M wrote:
> 
> > There will also be times when i wont be interested in
> > the response (and this is not just in the case of events).  
> > 
> > [HK] Most of the Control Plane Apps such as 
> routing/switching protocols
> > that I have worked with need responses for any commands 
> such as Config
> > or Query msgs. Could you give some examples of what msgs 
> you don't need
> > responses for ? Also, how do we satisfy the timeliness 
> requirement which
> > without protocol level responses or acks ?
> 
> I dont wanna speculate about others - i think the possibility is
> certainly there, but a simple example is a PL heartbeat scheme where i
> can occasionaly request for an ACK. We have used this and found it
> useful.
> 
<RamG>
Purpose of heart beat is to check whether other endpoint is alive, there are several ways to go for HB.
One could be clients can periodically send their liveness to servers (and considered as ACK).
- OR server can request and client respond in this case ACK is a must.
- OR if there are a periodic or (Semi-periodic) message exchange that can also be considered to reset the 
HB intiation.

IMHO, many configuration messages that happens between CE to FE (on FE) requires confirmation to assure that it
has really been communicated and acted upon.
<RamG>

regards
ramg

> cheers,
> jamal
> 
> 
> _______________________________________________
> Forces-protocol mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/forces-protocol
> 

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 05 May 2004 11:36:27 -0400

Hi Ram,

On Wed, 2004-05-05 at 04:41, [email-masked] wrote:

> <RamG>
> Purpose of heart beat is to check whether other endpoint is alive, 

Right. Caveat: Remember most livelines in protocols unidirectional.

> there are several ways to go for HB.

So unidirectional livelines request.

> - OR server can request and client respond in this case ACK is a must.

So purely bidirectional liveliness.

A little salt to the above - server can _sometimes_ ask for response;
not always. It reduces amount of traffic.
This is the feature i was requesting for.

cheers,
jamal