Subject: RE: [Forces-protocol] HB msgs ?

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Sun, 16 May 2004 19:40:47 -0700

Avri,

This is helpful. So what would your preference be, have HBs are separate
msgs or part of Event msgs ??

Thanks
Hormuzd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Saturday, May 15, 2004 3:02 AM
To: [email-masked]
Subject: Re: [Forces-protocol] HB msgs ?

Hi,

I have seen both situations, where people want to force acknowledgment 
of Event messages and where they don't and thus have resorted to use a 
config message options and flags that indicated whether, and which, 
event messages required acks. the messages themselves can also contains 
flags indicating whether an ack was required.

I tend to think of the behavior of event messages as being special 
enough to require their own semantics and configuration options.

Not sure this helps.

a.

On 15 maj 2004, at 03.34, Khosravi, Hormuzd M wrote:

> Jamal,
>
> I agree with you. However, Weiming (Robert ?) have different views on
> this.
> How do we resolve this ? I don't want us to be stuck on this.
>
> I guess the key question that I would ask is if we want Event msg to
> symbolize asynchronous events or we want to mix the semantics with
> synchronous msgs as well ? I think keeping the 2 separate is cleaner,
> but I am open to other views as well.
>
> Avri, could you share your opinion on this ?
>
>
> Thanks
> Hormuzd
>

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: [email-masked]
Date: Mon, 17 May 2004 14:07:45 +0200

> msgs or part of Event msgs ??

I think my inclination is to keep them separate and minimalist - just 
the header with the heartbeat message number should do.  They certainly 
don't need to be acked and the only configuration option might be the 
interval/frequency.

a.