Subject: [Forces-protocol] RE: Resend: Feedback: Section 6.2

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Fri, 29 Oct 2004 10:47:13 -0700

Jamal,

I thought we discussed this on the call and the resolution was to change
the Operation name from SHOW to ADVERTISE. I am not sure why you are
bringing this up again, pls look at the grammar once...

      PL level PDU :=   MAINHDR<LFBselect>+
      LFBselect    :=   LFBCLASSID LFBInstance <OPER>+
      OPER         :=   <OPERATION [<path-data>]*>+

I think this fits quite well into it, and the Operation name Advertise
is more general and can be reused as opposed to what your suggestions
are.

Hormuzd

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Friday, October 29, 2004 6:05 AM
To: [email-masked]
Cc: Robert Haas; [email-masked]; Ligang Dong;
[email-masked]; Khosravi, Hormuzd M; Weiming Wang
Subject: Resend: Feedback: Section 6.2

Folks,

I am gonna start queueing (inot a queue that holds only one message)
issues i think are unresolved (we either didnt get to completion on call
or havent discussed them to satisfaction to close them).

- Section 6.2.1

             +--- T = Operation = SHOW
                      |
                      +-- FE NAME

Is it an operation at all given its position in the hierachy?
PENAME may have been a better name.

I didnt explain this well on the call.
Where operation is showing up is the wrong spot for the grammar which
says operation comes after LFBSelection.
It is therefore not an operation. Hence the suggestion to call it
PENAME.

In the diagram: 
+ LFB Instance ID  and LFB Class ID 
should those just be set to 0x1? We already know thats where they are
going.
+ Type = operation, using the word "type" is confusing since it is also
used in the main header. I dont think we can avoid using the word type
in TLVs; my suggestion is we consider changing the main header type to 
"command". Thoughts? It is a command after all.
+ comment on SHOW applies here as well

+ "HBI will be exchanged with the CE using this LFB" ???

-6.2.2  Association Setup Response Message

In the diagram: 
+ LFB Instance ID  and LFB Class ID 
should those just be set to 0x1? We already know thats where they are
going.
+         
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|        Type = operation Show  |               Length          |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
~                   FE Object LFB (optional)                    ~
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

What is that?

+ "HBI will be exchanged with the CE using this LFB" ???

+ Type = T.reason  ?

This brings up that we need the following speacial TLVs.

FORCES_REASON, FORCES_RESULT, FORCES_NAME.

cheers,
jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 29 Oct 2004 14:09:21 -0400

On Fri, 2004-10-29 at 13:47, Khosravi, Hormuzd M wrote:
> the Operation name from SHOW to ADVERTISE. 

The issue has nothing to do with the name but where things fit in
in the grammar.

> I am not sure why you are

Because it was not resolved. 

> is more general and can be reused as opposed to what your suggestions

Look again please:

--------
   	main hdr (eg type =  Association setup)
   	     |
   	     |
   	     +--- T = LFBselect
   	     |        |
   	     |        +-- LFBCLASSID = FE object
   	     |        |
   	     |        |
   	     |        +-- LFBInstance = 0x1
   	     |
   	     +--- T = Operation = SHOW
   		      |
   		      +-- FE NAME

---------------

The operation is Not part of the LFBSelect.

It should be:

--------
   	main hdr (eg type =  Association setup)
   	     |
   	     |
   	     +--- T = LFBselect
   	             |
   	             +-- LFBCLASSID = FE object
   	             |
   	             |
   	             +-- LFBInstance = 0x1
   	             |
   	             +--- T = Operation = ADVERTISE
   		           |
   		           +-- FE NAME
---------------

If you want to leave it there call it PENAME as i suggested.

cheers,
jamal