Subject: [Forces-protocol] RE: Feedback on section 6.3

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Sat, 23 Oct 2004 14:21:26 -0700

Jamal,

I'll respond to your comments by end of today (within next 12 hrs)
Avri, pls don't make any changes before that,

Thanks
Hormuzd

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Saturday, October 23, 2004 1:37 PM
To: [email-masked]
Cc: Khosravi, Hormuzd M; [email-masked]; Ligang Dong;
[email-masked]; Weiming Wang; Robert Haas
Subject: Feedback on section 6.3

section 6.3

And in general i hope those are seen as sample layouts of the message;
i.e hopefully, nobody sees that layout as the way they must build the
message with an ADD and a DEL etc.

- 6.3.1  Config Message

+ "Config data"   should be "Config data and path"

+ Type is bad to describe operations. That should be operations

+ UPDATE/REPLACE, DEL ALL are really flag extensions which will become
clear once we have path-data noise cleared. Suggest you remove.

+ What is PACKET SUBSCRIBE/UNSUBSCRIBE?

- 6.3.2  Config Response Message

Why do we have " Operation Result "
As far as i can see it is sufficient to look at the Main header type,
a operation, path and its associated data.
Unless this is meant to be a less verbose result?

+ BTW, what is the point of mentioning "single or Array LFB
       specific result entries" or result might be TLV. Just say the 
presentation of the data is stuill under discussion.

cheers,
jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 23 Oct 2004 18:03:44 -0400

Avri,
Should probably have said it in my emails. These feedbacks on section 6
are not meant as changes to be made; rather as discussion points
hopefully to be resolved before release of draft.

cheers,
jamal

---

From: [email-masked]
Date: Sat, 23 Oct 2004 18:04:41 -0400

> Avri, pls don't make any changes before that,

ok.  though i did already make some based on Jamal's 6.1 comments.

i can unwind them.  for now i am putting out 01-6 and will stop working 
on this until tomorrow (have other stuff i should be doing anyway).

http://psg.com/~avri/forces/draft/draft-ietf-forces-protocol-01-6.txt

Specifically:

> Jamal's comments:
>
> - section 6.1 should have title "Core ForCES LFBs"

ok

>
> - 6.1.1  FE Protocol LFB
> "Protocol LFB have pre-defined default values that are specified here."
>
> What? Where?
>
> - 6.1.2  FE LFB
>
> MIID table : Have we decided this is the mode we are using?
> Should this be under editorial note?
>
> Other things:
> + FELFBInstancelist missing

added

> + FENeighborList missing

added

> + FEStatusChange should probably be just "FEStatus"

changed

>
> What is
> FE Behavior Exp.  Timer ?
> Also we probably need some things like
> + FEPrivateData which will contain things like name, vendor,
> model and other proprietary info

added