Subject: RE: [Forces-protocol] effect of new BNF, changes etc etc onprotocol

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Thu, 14 Oct 2004 12:32:10 -0700

Jamal,

Not sure what you mean by the basics, but we need to move faster...next
Friday is 22nd.
I hope we start updating sections sooner than that, hopefully we would
be done with discussions in a few days...I know it will be difficult, I
am keeping my fingers crossed :)

Regards
Hormuzd 

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Thursday, October 14, 2004 11:56 AM
To: Khosravi, Hormuzd M
Cc: [email-masked]
Subject: RE: [Forces-protocol] effect of new BNF, changes etc etc
onprotocol

Hormuzd,

I will put a little note together and post in the next 30 minutes or so.
In regards to your draft target, I agree we should shoot to beat the
25th deadline (will depend on how we move forward on basics first).
So lets shoot for next Friday to be done with basics?

cheers,
jamal

On Wed, 2004-10-13 at 10:25, Khosravi, Hormuzd M wrote:
> Jamal,
> 
> Thanks for posting this, I am most fine with what you propose.
> Pls see my comments below...
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Jamal Hadi
Salim
> 
> 1) BNF changes.
> Major issue being the query and query response appear to be gone.
> Instead we now have a CONFIG/GET and CONFIG-resp/GET
> [HK] We could still keep the Query and Config separate, I don't think
we
> have to remove Config...it would actually be cleaner that way. But I
am
> fine if most of you would like to remove it.
> 
>
> Unfortunately unless the data-path is well defined this is going to be
> tricky to move forward on. So i will put some effort in getting the
> path-data definition going. Please chip in the discussion with the
other
> folks from the model team.
> 
> 2) The fact that its now a world of "everything is an LFB" and
> introduction of FE protocol and FEObject LFBs implies that same
messages
> may have to go. Specifically, it seem state maintanance and event
> messages would need redefining.
> [HK] Yes we need to decide about State Maintenance msgs, I am fine
> either ways. I don't think Event msgs are affected by this.
> 
> It is my belief that draft 1 needs to address these issues to look
> progressive. It shouldnt matter if we publish it in time or not.
> [HK] I think this is important in order to make a presentation and
show
> progress.
> Regards
> Hormuzd

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 14 Oct 2004 16:10:04 -0400

Hormuzd,

> Not sure what you mean by the basics, but we need to move faster...next

By basics i mean we agree on the basic things. 
I posted some doc about 30 minutes ago of how i saw the messages
changing. I think thats part of basics.
I also would say we should not have any challenges in ensuring the text
is consistent with concept of FE object and protocol LFBs.

> am keeping my fingers crossed :)

I am hoping we should be done or very close done with the sections then.
Look at the doc i posted and lests start running then ;->

cheers,
jamal