Subject: [Forces-protocol] RE: Instance Select

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Thu, 21 Oct 2004 12:58:43 -0700

Weiming,

I haven't seen any compelling example (real NE) to need this kind of
functionality in the protocol.
Therefore, I don't think this complexity needs to be added...at most we
need a Broadcast Instance ID definition (Send msgs to all LFBs of a
particular Type). But I will be happy to hear what Jamal, others have to
say on this ? I am not religious either way...

regards
Hormuzd 

-----Original Message-----
From: Wang,Weiming [mailto:[email-masked]] 
Sent: Wednesday, October 20, 2004 9:48 PM
To: [email-masked]
Cc: Khosravi, Hormuzd M; [email-masked]; Joel M. Halpern;
[email-masked]; Yang, Lily L; Alan DeKok; [email-masked]; Steven
Blake (petri-meat); Deleganes, Ellen M
Subject: Instance Select

Hi Jamal, Hormuzd, etc,

To summarize the discussions on multiple instances, I try to propose
following
scheme for instance selection, which follows Robert's idea and Jamal's
format,
as:

PL level PDU : = MAINHDR<LFBselect>+
LFBselect := LFBCLASSID InsSelect <OPER>+
InsSelect := InstanceID <RangeMark | Instance ID >+
RangeMark := '0xFFFFFFFF'; the value is the same as Broadcast Instance
address,
no worry of ambiguity here.

The InsSelect is a TLV, whose structure is shown as:

main hdr (eg type = config)
     |
     |
     +-- T = LFBselect
     |        |
     |        +- LFBCLASSID = target LFB class
     |        |
     |        |
     |        +- T = InsSelect
     |        |   |
     |        |   V = InstanceID <RangeMark | Instance ID >+
     |        |
     |        +- T = operation { ADD, DEL, GET, etc}
     ...

Best Regards,
Weiming

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 21 Oct 2004 16:18:59 -0400

My opinion is this issue should be defered for this release of the
protocol draft. 

If Weiming can be given a slot to present on the topic (I will also
provide him with my data) then lets discuss at the meeting.
If not a presentation then maybe over a meal and some good caffeine.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Fri, 22 Oct 2004 10:48:11 +0800

Hormuzd,

----- Original Message -----
From: "Khosravi, Hormuzd M" <[email-masked]>
Subject: RE: Instance Select

Weiming,

I haven't seen any compelling example (real NE) to need this kind of
functionality in the protocol.
[Weiming]I think i'v repeated this necessity several times . Sorry you can not
feel it, but I'm sure if you'v got a test platform to practically do something,
you'l have more strong feel on the desire for this :)
Therefore, I don't think this complexity needs to be added...
[Weiming] I don't agree it adds much complexity.
at most we
need a Broadcast Instance ID definition (Send msgs to all LFBs of a
particular Type).
[Weiming]That's not enough. I'v shown some examples to state this.

But I will be happy to hear what Jamal, others have to
say on this ? I am not religious either way...

regards
Hormuzd

-----Original Message-----
From: Wang,Weiming [mailto:[email-masked]]
Sent: Wednesday, October 20, 2004 9:48 PM
To: [email-masked]
Cc: Khosravi, Hormuzd M; [email-masked]; Joel M. Halpern;

Hi Jamal, Hormuzd, etc,

Best Regards,
Weiming