Subject: [Forces-protocol] RE: Resend: Feedback: Section 6.2

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Fri, 29 Oct 2004 13:33:21 -0700

Ok, I see where the confusion is, the bitwise message representation is
in the correct format but the other format which you have drawn below is
not. This is a copy/paste error, I'll send out a fix to Avri.

Thanks
Hormuzd

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Friday, October 29, 2004 11:09 AM
To: Khosravi, Hormuzd M
Cc: [email-masked]; Robert Haas; [email-masked]; Ligang Dong;
[email-masked]; Weiming Wang
Subject: RE: Resend: Feedback: Section 6.2

On Fri, 2004-10-29 at 13:47, Khosravi, Hormuzd M wrote:
> Jamal,
> 
> I thought we discussed this on the call and the resolution was to
change
> the Operation name from SHOW to ADVERTISE. 

The issue has nothing to do with the name but where things fit in
in the grammar.

> I am not sure why you are
> bringing this up again, pls look at the grammar once...
> 

Because it was not resolved. 

>       PL level PDU :=   MAINHDR<LFBselect>+
>       LFBselect    :=   LFBCLASSID LFBInstance <OPER>+
>       OPER         :=   <OPERATION [<path-data>]*>+
> 
> 
> I think this fits quite well into it, and the Operation name Advertise
> is more general and can be reused as opposed to what your suggestions
> are.

Look again please:

--------
   	main hdr (eg type =  Association setup)
   	     |
   	     |
   	     +--- T = LFBselect
   	     |        |
   	     |        +-- LFBCLASSID = FE object
   	     |        |
   	     |        |
   	     |        +-- LFBInstance = 0x1
   	     |
   	     +--- T = Operation = SHOW
   		      |
   		      +-- FE NAME

---------------

The operation is Not part of the LFBSelect.

It should be:

--------
   	main hdr (eg type =  Association setup)
   	     |
   	     |
   	     +--- T = LFBselect
   	             |
   	             +-- LFBCLASSID = FE object
   	             |
   	             |
   	             +-- LFBInstance = 0x1
   	             |
   	             +--- T = Operation = ADVERTISE
   		           |
   		           +-- FE NAME
---------------

If you want to leave it there call it PENAME as i suggested.

cheers,
jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 29 Oct 2004 19:41:41 -0400

> not. This is a copy/paste error, I'll send out a fix to Avri.

ok, yes i see it to now ;-> I guess you were on one piece and i was on
the other ;->

Theres still that other cruft still there:

+ LFB Instance ID  and LFB Class ID 
should those just be set to 0x1? We already know thats where they are
going.
+ Generaly, Type = operation, using the word "type" is confusing since
it is also used in the main header. I dont think we can avoid using the
word type in TLVs; my suggestion is we consider changing the main header
type to  "command". Thoughts? It is a command after all.
+ comment on SHOW applies here as well

+ "HBI will be exchanged with the CE using this LFB" ???

-6.2.2  Association Setup Response Message

In the diagram, repeat of above:
 
+ LFB Instance ID  and LFB Class ID 
should those just be set to 0x1? We already know thats where they are
going.
+         
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|        Type = operation Show  |               Length          |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
~                   FE Object LFB (optional)                    ~
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

What is that?

+ "HBI will be exchanged with the CE using this LFB" ???
Robert said something in the concal on this, cant remember.

+ Type = T.reason  ?

This brings up that we need the following speacial TLVs.

FORCES_REASON, FORCES_RESULT, FORCES_NAME.

cheers,
jamal