Subject: RE: [Forces-protocol] Re: protocol draft editing?

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Thu, 21 Oct 2004 11:26:06 -0700

Robert,

Weiming and myself are already working on this section...I will send out what I have shortly.

Some of the changes are pretty straightforward, e.g. remove section 6.6 :-)

Anyways we could definitely use help in the draft, there is lots of stuff that needs to be done

I will send out a list of other todo items shortly..

regards

Hormuzd

________________________________

From: Robert Haas [mailto:[email-masked]] 
Sent: Thursday, October 21, 2004 7:04 AM
To: Khosravi, Hormuzd M
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Ligang Dong; Weiming Wang
Subject: Re: [Forces-protocol] Re: protocol draft editing?

Hormuzd,
Section 6 is heavily impacted by the shift to "everything is an LFB". Many sections and figures require complete re-editing. To ensure consistency, we need one person to do one editing pass on the entire section first. But your list says "everybody". 

What if I do this first pass before tomorrow ? Or has anyone started already ?

It also means that our description of the FE Protocol LFB must be enhanced, possibly including the multicast table that Zsolt started specifying.

Regards,
-Robert

Khosravi, Hormuzd M wrote:

Here is the distribution list...
 
Abstract - Avri
1. Introduction - Avri
2. Definitions - Weiming
3. Protocol Overview - Jamal
4. TML Requirements - Jamal
5. Common Header - Weiming, Ligang (Jamal/Robert)
6. Protocol Messages - Hormuzd, Weiming (I expect everyone to be
involved with this one)
7. Protocol Scenarios - Hormuzd, Ram
8. High Availability - Hormuzd
9. Security Considerations - Ram
10. References - Avri
11. Acknowledgments - All
Appendix
A. Implementation Notes - All?
 
I will directly modify the text for my particular section and send it
out to the team/Avri on a per section or per-subsection basis. That was
we can all work in parallel.
 
regards
Hormuzd 
 
-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Wednesday, October 20, 2004 5:35 AM
To: [email-masked]
Cc: [email-masked]; Khosravi, Hormuzd M; [email-masked]; Ligang Dong;
Weiming Wang; Robert Haas
Subject: Re: [Forces-protocol] Re: protocol draft editing?
 
Avri must be on travel or tied up somewhere around the globe.
The latest i could find is:
http://psg.com/~avri/forces/draft/Archive-Forces-Protocol-02.zip
 
Does anyone know if theres something newer or should we start here?
Hormuzd can you post that todo distribution?
 
cheers,
jamal
 
On Tue, 2004-10-19 at 19:23, Jamal Hadi Salim wrote:

	On Tue, 2004-10-19 at 11:07, Jamal Hadi Salim wrote:

		Now that we seem to have made progress on the basics..
		Avri,
		Could you post a URL to the xml docs that we could start editing?
		We could start with the TODO action items as posted by Hormuzd.
		 
		cheers,
		jamal

	_______________________________________________
	Forces-protocol mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/forces-protocol

  

-- 
Robert Haas
IBM Zurich Research Laboratory
Säumerstrasse 4
CH-8803 Rüschlikon/Switzerland
phone +41-1-724-8698  fax +41-1-724-8578  http://www.zurich.ibm.com/~rha
_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 21 Oct 2004 16:15:49 -0400

Avri,

Are you compiling all the changes?
For this iteration of the draft I will leave the TML section alone.
The only change i am making on the overview is attached as a diff.
Avri, if you cant handle diffs i will send you the xml.
Robert,Weiming, Ligang: Are you taking care of the common header section
or should i jump into that next? Not that i think there are any useful
changes tomake for this version of draft.

BTW, folks I would like to volunteer to present on the protocol this
time if people are OK with it.

cheers,
jamal
--- overview.xml	2004/10/21 20:02:55	1.1
+++ overview.xml	2004/10/21 20:12:39
@@ -442,6 +442,8 @@
     </t>
 <t>  Some TML capability description(s)</t>
 </list>
+</section>
+<section title="FE Object" anchor="FE_Object">
 <t> FE Protocol attributes:</t>
 <list>
 <t>  current version of the ForCES protocol </t>
@@ -519,7 +521,15 @@
 <!-- x.3.2.2.1 Batching -->
 <section title="Batching">
 <t>
-TBD
+
+There are several batching levels at different protocol hierachies. 
+<list>
+<t> multiple PL PDUs can be aggregated under one TML message</t>
+<t> multiple LFB classes and instances can be addressed within
+one PL PDU</t>
+<t>Multiple operations can be addressed to a single LFB class and
+instance</t>
+</list>
 </t>
 </section>
 <!-- x.3.2.2.1 command Pipelining -->
_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Robert Haas <[email-masked]>
Date: Thu, 21 Oct 2004 22:23:00 +0200

Khosravi, Hormuzd M wrote:

> Some of the changes are pretty straightforward, e.g. remove section 6.6 J
>
>  
>
You bet. I suppose I can help as a co-author of this draft ;-)

> I will send out a list of other todo items shortly..
I'll start from your input tomorrow morning Europe time. Please take a 
look at my previous note and review the pending issues I listed. This 
way we avoid changing the text back and forth.

Thanks,
-Robert

> regards
>
> Hormuzd
>
>  
>
> ------------------------------------------------------------------------
>
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; Ligang Dong; Weiming Wang
> Section 6 is heavily impacted by the shift to "everything is an LFB". 
> Many sections and figures require complete re-editing. To ensure 
> consistency, we need one person to do one editing pass on the entire 
> section first. But your list says "everybody".
>
> It also means that our description of the FE Protocol LFB must be 
> enhanced, possibly including the multicast table that Zsolt started 
> specifying.
>
> Regards,
> -Robert
>
>To: [email-masked] <mailto:[email-masked]>
>
>Cc: [email-masked] <mailto:[email-masked]>; Khosravi, Hormuzd M; [email-masked] <mailto:[email-masked]>; Ligang Dong;
>
>http://psg.com/~avri/forces/draft/Archive-Forces-Protocol-02.zip <http://psg.com/%7Eavri/forces/draft/Archive-Forces-Protocol-02.zip>
>
> 
>
>>[email-masked] <mailto:[email-masked]>
>>
>phone +41-1-724-8698  fax +41-1-724-8578  http://www.zurich.ibm.com/~rha <http://www.zurich.ibm.com/%7Erha>
>

---

From: [email-masked]
Date: Thu, 21 Oct 2004 20:06:54 -0400

> Are you compiling all the changes?

i can.  i have not started yet.

> Avri, if you cant handle diffs i will send you the xml.

i can handle the diffs.  although monday, the deadline is real soon.

> time if people are OK with it.

fine with me.

a.