Subject: RE: [Forces-protocol] Re: protocol draft editing?

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Wed, 20 Oct 2004 12:19:11 -0700

Here is the distribution list...

Abstract - Avri
1. Introduction - Avri
2. Definitions - Weiming
3. Protocol Overview - Jamal
4. TML Requirements - Jamal
5. Common Header - Weiming, Ligang (Jamal/Robert)
6. Protocol Messages - Hormuzd, Weiming (I expect everyone to be
involved with this one)
7. Protocol Scenarios - Hormuzd, Ram
8. High Availability - Hormuzd
9. Security Considerations - Ram
10. References - Avri
11. Acknowledgments - All
Appendix
A. Implementation Notes - All?

I will directly modify the text for my particular section and send it
out to the team/Avri on a per section or per-subsection basis. That was
we can all work in parallel.

regards
Hormuzd 

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Wednesday, October 20, 2004 5:35 AM
To: [email-masked]
Cc: [email-masked]; Khosravi, Hormuzd M; [email-masked]; Ligang Dong;
Weiming Wang; Robert Haas
Subject: Re: [Forces-protocol] Re: protocol draft editing?

Avri must be on travel or tied up somewhere around the globe.
The latest i could find is:
http://psg.com/~avri/forces/draft/Archive-Forces-Protocol-02.zip

Does anyone know if theres something newer or should we start here?
Hormuzd can you post that todo distribution?

cheers,
jamal

On Tue, 2004-10-19 at 19:23, Jamal Hadi Salim wrote:
> On Tue, 2004-10-19 at 11:07, Jamal Hadi Salim wrote:
> > Now that we seem to have made progress on the basics..
> > Avri,
> > Could you post a URL to the xml docs that we could start editing?
> > We could start with the TODO action items as posted by Hormuzd.
> > 
> > cheers,
> > jamal
> 
> 
> _______________________________________________
> Forces-protocol mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/forces-protocol

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Robert Haas <[email-masked]>
Date: Thu, 21 Oct 2004 16:04:18 +0200

Hormuzd,
Section 6 is heavily impacted by the shift to "everything is an LFB". 
Many sections and figures require complete re-editing. To ensure 
consistency, we need one person to do one editing pass on the entire 
section first. But your list says "everybody".

What if I do this first pass before tomorrow ? Or has anyone started 
already ?

It also means that our description of the FE Protocol LFB must be 
enhanced, possibly including the multicast table that Zsolt started 
specifying.

Regards,
-Robert

-- 
Robert Haas
IBM Zurich Research Laboratory
Säumerstrasse 4
CH-8803 Rüschlikon/Switzerland
phone +41-1-724-8698  fax +41-1-724-8578  http://www.zurich.ibm.com/~rha

---

From: "Ligang Dong" <[email-masked]>
Date: Thu, 21 Oct 2004 22:16:58 +0800

hi,
Yes. I think ONE person writes one section first, so that the writing content and style are consistent throughout the section. Others give the comments and help the main editor improve it. 
Now let's volunteer to become the main editor of each section.
Best regards
Ligang
  ----- Original Message ----- 
  From: Robert Haas 
  To: Khosravi, Hormuzd M 
  Cc: [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; Ligang Dong ; Weiming Wang 
  Sent: Thursday, October 21, 2004 10:04 PM
  Subject: Re: [Forces-protocol] Re: protocol draft editing?

  Hormuzd,
  Section 6 is heavily impacted by the shift to "everything is an LFB". Many sections and figures require complete re-editing. To ensure consistency, we need one person to do one editing pass on the entire section first. But your list says "everybody". 

  What if I do this first pass before tomorrow ? Or has anyone started already ?

  It also means that our description of the FE Protocol LFB must be enhanced, possibly including the multicast table that Zsolt started specifying.

  Regards,
  -Robert

Abstract - Avri
1. Introduction - Avri
2. Definitions - Weiming

regards
Hormuzd 

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 
Sent: Wednesday, October 20, 2004 5:35 AM
To: [email-masked]
Cc: [email-masked]; Khosravi, Hormuzd M; [email-masked]; Ligang Dong;

cheers,
jamal

cheers,
jamal

---

From: Robert Haas <[email-masked]>
Date: Thu, 21 Oct 2004 19:35:59 +0200

Jamal: could you please send your potential-protocol-changes.txt file 
again ? I can take care of transfering the changes into section 6 unless 
someone else wants to do it.

All: below is a rough list of changes and pending issues regarding 
section 6. Please review.

 6.1.1 Association: The CE could obtain the HBI with a 
Query-SGT-FEProtocolLFP-HeartbeatInterval. Given the new Assoc msg 
strcutrue, we have to remove HBI from the Assoc Setup msg.

 6.1.2 How has the srcID=0 case been handled in the interop tests ? Is 
this really feasible ?

 6.2 Query: coarse FE info (inter/intra-FE topology, etc) goes into the 
FEProtocolLFB.

 6.4: Events: coarse CE and FE events go into CE/FEProtocolLFB. Note 
that for the sake of symmetry, we should introduce a CEProtocolLFB.

 6.6 State Maintenance: FE Activate/Deactivate/Shutdown become settable 
attributes in the FEProtocolLFB.

 6.7 HB remains as is.

In summary, we have the following operations defined for each message 
type ( I broke the table into 3 parts):

OPERATION       APPLICABLE MESSAGE TYPES

                Assoc-Setup  Assoc-Setup-Resp Assoc-Teardown Heartbeat

no operations
defined

                Query  Query-Resp  Config  Config-Resp
SET, DEL, UPDATE                     x          x
GET               x         x
EV_S, EV_U                           x          x

(for event subscribe/unsubscribe)

                Packet-Redir

PAYLOAD            x

                Event-Notif  Event-Notif-Resp
EVENT              x                x

Note that for Query(-Resp), Packet-Redir, and Event-Notif(-Resp), we 
have each time only one operation. Looks a bit redundant. Ideas ?

Regards,
-Robert

Ligang Dong wrote:

> hi,
> Yes. I think ONE person writes one section first, so that the writing 
> content and style are consistent throughout the section. Others give 
> the comments and help the main editor improve it. 
>     From: Robert Haas <mailto:[email-masked]>
>     To: Khosravi, Hormuzd M <mailto:[email-masked]>
>     Cc: [email-masked] <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]> ; Ligang Dong
>     <mailto:[email-masked]> ; Weiming Wang
>     <mailto:[email-masked]>
>     Section 6 is heavily impacted by the shift to "everything is an
>     LFB". Many sections and figures require complete re-editing. To
>     ensure consistency, we need one person to do one editing pass on
>     the entire section first. But your list says "everybody".
>
>     enhanced, possibly including the multicast table that Zsolt
>     started specifying.
>
>     Regards,
>     -Robert
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: 21 Oct 2004 14:10:35 -0400

On Thu, 2004-10-21 at 13:35, Robert Haas wrote:
> again ? I can take care of transfering the changes into section 6
> unless someone else wants to do it.
> 

Sorry I am tied up for the next few hours hence my lack of immediate
response. Attached:

cheers,
jamal