Subject: Re: [GGIE] MOPS - Media Ops BoF request

From: "Holland, Jake" <[email-masked]>
Date: Wed, 5 Jun 2019 15:16:22 +0000

Hi Glenn,

Thanks for posting this.  The charter mostly looks good to me, I have a
few comments inline with [JH] (text pasted from the google docs link).

Cheers,
Jake

Media OPS WG

Internet- and Internet-protocol-delivered video/media is popular,
leading to significant technology development across industries not
traditionally thought of as Internet technology developers or operators,
as well as considerable quantities of traffic on local and transit
networks.  Continued development of Internet-using technologies should
be properly coordinated in order to ensure that the existing
technologies are well-utilized, and new ones are developed in sympathy
with the Internet’s core protocols and design.

MOPS will solicit input on operational issues and practices, existing
and proposed technologies related to the deployment, engineering, and
operation of media streaming and manipulation protocols and procedures
in the global Internet, inter-domain and single domain.  In this case,
media is considered to include the transport of video, audio, objects
and any combination thereof, possibly non-sequentially.  The scope is
media and media protocols’ interactions with the network, but not the
technologies of control protocols or media formats.

The goals of mops are:
1. Solicit input from network operators and users to identify
   operational issues with media delivery in and across networks, and
   determine solutions or workarounds to those issues.

2. Solicit discussion and documentation of the issues and opportunities
   media acquisition and delivery and of the resulting innovations.

[JH] I'm confused on this one.  I think at very least it's missing "in"
     between "opportunities" and "media".  But there might be a better
     way to phrase this overall, I'll propose one if I think of a
     suggestion.
[JH] I think "media acquisition" needs a definition.  Web search of
     this term seems to refer to obtaining intellectual property
     rights for particular properties; I'm not quite sure what the
     intent is here, but I suspect not that.

3. Operational solutions for identified issues should be developed in
   mops and documented in informational or BCP drafts.

4. Document operational requirements for media acquisition and delivery

5. Develop mechanisms and procedures for sharing operational information
   to aid in operation of media technologies in the global Internet

6. Develop tools, extend protocols and provide operational and
   implementation advice that assists in media technology administration,
   diagnostics, troubleshooting and deployment between/within native and
   non-native environments.

These documents should document media operational experience, including
global Internet, inter-domain and within-domain operations.
[JH] Maybe "should address" or "should cover", instead of "these documents
     should document"?

Media operational and deployment issues with specific protocols or
technologies (such as Applications, Transport Protocols, Routing
Protocols, DNS or Sub-IP Protocols) are the primary responsibility of
the groups or areas responsible for those protocols or technologies.
However, the mops Working Group may provide input to those areas/groups,
as needed, and cooperate with those areas/groups in reviewing solutions
to mops operational and deployment problems.
[JH] Should we use something strong than "may" here?  "should"?  "is
     expected to"?

Future work items within this scope will be adopted by the Working Group
only if there is a substantial expression of interest from the community
and if the work clearly does not fit elsewhere in the IETF.

There must be a continuous expression of interest for the Working Group
to work on a particular work item. If there is no longer sufficient
interest in the Working Group in a work item, the item may be removed
from the list of Working Group items.

[JH] I thought there's a similar expectation already for WGs in general,
     is there a sense which this WG needs special handling?
[JH] Should there be a provision for criteria that would justify closing
     the WG?  (If sufficient consideration of media delivery concerns
     becomes routine in protocol specs, or if interest or attendance
     drops below some threshold?)  Not sure what's normal for ops
     groups, but some of the RFC 2418 text seems to suggest the normal
     WG goal is about defining protocols, and like other ops groups,
     this is a little different.

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: 2019-06-03 at 09:50
To: "[email-masked]" <[email-masked]>
Cc: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Subject: [GGIE] MOPS - Media Ops BoF request

Hi everyone,
 
IETF105 BoF requests are due this Friday, so now would be good time to send your comments on the MOPS BoF draft

https://docs.google.com/document/d/1S4soR8QVjbCa1k1CXS8bCXox_h8-zK6kEsS8_IU4yXI/
 
The current draft is an amalgam of the discussions we had at IETF104 and feedback from a few ADs, but the more the better so please don’t be shy.  
 
This is a chance to bring forward, officially the topic of creating an group with video expertise at the IETF that can help video problems across the great diversity of technical areas that are the IETF.  So I encourage you to please take a couple of minutes when you get this email, look at the draft and comment back the list your thoughts.
 
Even – “it looks good to me”  – is helpful to hear.
 
regards
Glenn

---

From: Matthew Stock <[email-masked]>
Date: Wed, 5 Jun 2019 15:37:37 -0400

Glenn,

At the moment, I don't think I have any new comments to add beyond what has
already been said.  Tightening up the purpose/goals would be good, and I
like the interoperability and efficient use of infrastructure as key
themes.  I'd be interested in participating in the BoF.

Matt

On Wed, Jun 5, 2019 at 11:16 AM Holland, Jake <[email-masked]> wrote:

> The current draft is an amalgam of the discussions we had at IETF104 and
> feedback from a few ADs, but the more the better so please don’t be shy.
>
> This is a chance to bring forward, officially the topic of creating an
> group with video expertise at the IETF that can help video problems across
> the great diversity of technical areas that are the IETF.  So I encourage
> you to please take a couple of minutes when you get this email, look at the
> draft and comment back the list your thoughts.
>
> _______________________________________________
> GGIE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ggie
>

---

From: "DRUTA, DAN" <[email-masked]>
Date: Wed, 5 Jun 2019 19:49:00 +0000

Hi Glenn,

I think this is a great idea and I will definitely participate in the BoF as well as support the creation of a working group focused on video related issues.

Regards,
Dan

From: GGIE [mailto:[email-masked]] On Behalf Of Matthew Stock
Sent: Wednesday, June 05, 2019 12:38 PM
To: Deen, Glenn (NBCUniversal) <[email-masked]>
Cc: [email-masked]
Subject: Re: [GGIE] MOPS - Media Ops BoF request

Glenn,

At the moment, I don't think I have any new comments to add beyond what has already been said.  Tightening up the purpose/goals would be good, and I like the interoperability and efficient use of infrastructure as key themes.  I'd be interested in participating in the BoF.

Matt

On Wed, Jun 5, 2019 at 11:16 AM Holland, Jake <[email-masked]<mailto:[email-masked]>> wrote:
Hi Glenn,

Cheers,
Jake

Media OPS WG

The goals of mops are:

     between "opportunities" and "media"..  But there might be a better

From: "Deen, Glenn (NBCUniversal)" <[email-masked]<mailto:[email-masked]>>
Date: 2019-06-03 at 09:50
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Deen, Glenn (NBCUniversal)" <[email-masked]<mailto:[email-masked]>>
Subject: [GGIE] MOPS - Media Ops BoF request

Hi everyone,

https://docs.google.com/document/d/1S4soR8QVjbCa1k1CXS8bCXox_h8-zK6kEsS8_IU4yXI/<https://urldefense.proofpoint.com/v2/url?u=https-3A__docs.google.com_document_d_1S4soR8QVjbCa1k1CXS8bCXox-5Fh8-2DzK6kEsS8-5FIU4yXI_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=fULjfSb5Ues9lckOxWDJSg&m=OFJXj_LVTsi5BW2jL-tLTQJIXkD9wqbUMo99r1yOYYI&s=PjBsyvJ4iocpqsg8JVM5Wljq-ejg7uJUuy7nzmboL0U&e=>

regards
Glenn

_______________________________________________
GGIE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ggie<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ggie&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=fULjfSb5Ues9lckOxWDJSg&m=OFJXj_LVTsi5BW2jL-tLTQJIXkD9wqbUMo99r1yOYYI&s=V7cWwRhfb2ksH5xoZHUx4IHqeNZEdfO1gogwk2LFExo&e=>

---

From: <[email-masked]>
Date: Thu, 6 Jun 2019 08:08:57 +0000

Hi Glenn and Leslie

I support the BoF.
It may decide if more interop is needed on the ingest side. AFAIK, it is not in the CDNi WG charter yet.
Wrt to the delivery, IMO, more interactions with the network is required (e.g. at least to allow back pressure during peak of traffic).

Regards
Emile

-----Message d'origine-----
De : GGIE [mailto:[email-masked]] De la part de Holland, Jake
Envoyé : mercredi 5 juin 2019 17:16
À : Deen, Glenn (NBCUniversal); [email-masked]
Objet : Re: [GGIE] MOPS - Media Ops BoF request

Hi Glenn,

Cheers,
Jake

Media OPS WG

The goals of mops are:

Hi everyone,

 

 
regards
Glenn

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Thu, 6 Jun 2019 08:22:43 +0000

Support and interested.

I'm wondering whether studio video transport is also in the scope?

BR,
Rachel

> -----Original Message-----
> From: GGIE [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, June 06, 2019 4:09 PM
> To: Deen, Glenn (NBCUniversal) <[email-masked]>; Leslie Daigle
> <[email-masked]>
> Cc: [email-masked]
> Wrt to the delivery, IMO, more interactions with the network is required (e.g.
> at least to allow back pressure during peak of traffic).
> 
> Regards
> Emile
> 
> De : GGIE [mailto:[email-masked]] De la part de Holland, Jake Envoyé :
> mercredi 5 juin 2019 17:16 À : Deen, Glenn (NBCUniversal); [email-masked]
> Thanks for posting this.  The charter mostly looks good to me, I have a few
> comments inline with [JH] (text pasted from the google docs link).
> 
> Cheers,
> Jake
> 
> 
> Media OPS WG
> 
> Internet- and Internet-protocol-delivered video/media is popular, leading to
> significant technology development across industries not traditionally thought
> of as Internet technology developers or operators, as well as considerable
> quantities of traffic on local and transit networks.  Continued development of
> Internet-using technologies should be properly coordinated in order to ensure
> that the existing technologies are well-utilized, and new ones are developed in
> sympathy with the Internet’s core protocols and design.
> 
> MOPS will solicit input on operational issues and practices, existing and
> proposed technologies related to the deployment, engineering, and operation
> of media streaming and manipulation protocols and procedures in the global
> Internet, inter-domain and single domain.  In this case, media is considered to
> include the transport of video, audio, objects and any combination thereof,
> possibly non-sequentially.  The scope is media and media protocols’
> interactions with the network, but not the technologies of control protocols or
> media formats.
> 
> The goals of mops are:
> technologies (such as Applications, Transport Protocols, Routing Protocols, DNS
> or Sub-IP Protocols) are the primary responsibility of the groups or areas
> responsible for those protocols or technologies.
> as needed, and cooperate with those areas/groups in reviewing solutions to
> mops operational and deployment problems.
> Future work items within this scope will be adopted by the Working Group only
> if there is a substantial expression of interest from the community and if the
> work clearly does not fit elsewhere in the IETF.
> 
> There must be a continuous expression of interest for the Working Group to
> work on a particular work item. If there is no longer sufficient interest in the
> Working Group in a work item, the item may be removed from the list of
> Working Group items.
> 
> This is a chance to bring forward, officially the topic of creating an group with
> video expertise at the IETF that can help video problems across the great
> diversity of technical areas that are the IETF.  So I encourage you to please
> take a couple of minutes when you get this email, look at the draft and
> comment back the list your thoughts.
> 
> ________________________________________________________________
> _________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed, used
> or copied without authorisation.

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Thu, 6 Jun 2019 12:37:53 +0000

Hi Rachel,

I believe it would be since professional video groups like SMPTE and it’s SMPTE 2110 Suite of. Specs for Professional Media over Managed IP Networks is entirely dependent on IETF RFCs

https://www.smpte.org/st-2110

Glenn

On Jun 6, 2019, at 1:22 AM, Huangyihong (Rachel) <[email-masked]<mailto:[email-masked]>> wrote:

Support and interested.

BR,
Rachel

-----Original Message-----
From: GGIE [mailto:[email-masked]] On Behalf Of
[email-masked]<mailto:[email-masked]>
Sent: Thursday, June 06, 2019 4:09 PM
To: Deen, Glenn (NBCUniversal) <[email-masked]<mailto:[email-masked]>>; Leslie Daigle
<[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [GGIE] MOPS - Media Ops BoF request

Hi Glenn and Leslie

I support the BoF.
It may decide if more interop is needed on the ingest side. AFAIK, it is not in the
CDNi WG charter yet.
Wrt to the delivery, IMO, more interactions with the network is required (e.g.
at least to allow back pressure during peak of traffic).

Regards
Emile

-----Message d'origine-----
De : GGIE [mailto:[email-masked]] De la part de Holland, Jake Envoyé :
mercredi 5 juin 2019 17:16 À : Deen, Glenn (NBCUniversal); [email-masked]<mailto:[email-masked]>
Objet : Re: [GGIE] MOPS - Media Ops BoF request

Hi Glenn,

Cheers,
Jake

Media OPS WG

The goals of mops are:

Hi everyone,

IETF105 BoF requests are due this Friday, so now would be good time to send
your comments on the MOPS BoF draft

https://docs.google.com/document/d/1S4soR8QVjbCa1k1CXS8bCXox_h8-zK6k
EsS8_IU4yXI/

regards
Glenn

This message and its attachments may contain confidential or privileged
information that may be protected by law; they should not be distributed, used
or copied without authorisation.
If you have received this email in error, please notify the sender and delete this
message and its attachments.
As emails may be altered, Orange is not liable for messages that have been
modified, changed or falsified.
Thank you.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 10 Jun 2019 01:01:33 +0000

Thanks, Glenn. Good to know that.

BR,
Rachel

From: Deen, Glenn (NBCUniversal) [mailto:[email-masked]]
Sent: Thursday, June 06, 2019 8:38 PM
To: Huangyihong (Rachel) <[email-masked]>
Cc: [email-masked]; Leslie Daigle <[email-masked]>; [email-masked]
Subject: Re: [EXTERNAL] RE: [GGIE] MOPS - Media Ops BoF request

Hi Rachel,

I believe it would be since professional video groups like SMPTE and it's SMPTE 2110 Suite of. Specs for Professional Media over Managed IP Networks is entirely dependent on IETF RFCs

Glenn

BR,
Rachel

-----Original Message-----

Hi Glenn and Leslie

I support the BoF.

Regards
Emile

-----Message d'origine-----

Hi Glenn,

Cheers,
Jake

Media OPS WG

sympathy with the Internet's core protocols and design.

possibly non-sequentially.  The scope is media and media protocols'

The goals of mops are:

Hi everyone,

The current draft is an amalgam of the discussions we had at IETF104 and
feedback from a few ADs, but the more the better so please don't be shy.

Even - "it looks good to me"  - is helpful to hear.

regards
Glenn