Subject: Re: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

From: "Holland, Jake" <[email-masked]>
Date: Tue, 4 Jun 2019 17:25:47 +0000

Hi guys,

Sorry for the delayed response.

I’ve been attending these and I wanted to take a moment to express support for creating a mops working group.  I’ve found the meeting so far valuable, and I hope they’ll be more valuable going forward, if the group becomes a normal working group.

I presented at a couple of these meetings, most recently a presentation about the scale of media delivery titled “Multicast Video: Motivating Observations”:
https://yana.techark.org/wp-content/uploads/2019/04/ietf104-vig-multicast-video.pdf

I’m working on reframing some of the observations presented there into an I-D as a problem statement of the scalability issues in today’s video delivery landscape.

I hadn’t thought of it as having great archival value since the numbers I’ve got in that first presentation are just sort of a snapshot, but I think there’s a useful point in there that’s a little more timeless or that can capture an important trend, and I’m thinking about how to express it, and tentatively aiming to submit something for the first proposed slot in the agenda (about scope of video).  (Co-authors would be most welcome, if you’ve got some insights or good numbers on this topic :) )

Another thing I’d love to get out of this group at some point is a roadmap document about the various video-related and video-delivery-related standards, ideally with some pointers about implementation status, and maybe a bit of history and the motivating factors for the tradeoffs made in the different designs.  I get confused every time I try to figure that stuff out, and I’m hoping someone who knows it better will take the time to write it up and give a good overview as it relates to media delivery.  (Additionally, I’ve found the presentations so far very helpful for staying informed about the networking aspects of the various approaches people are trying, as they struggle to handle the deluge of video data.)

I wish the presentations so far had been recorded and archived, as I think there has been some good stuff covered.  On a couple of occasions I’ve gone and looked back at the presentations that were so graciously and helpfully posted at yana.techark.org, and asked the authors or presenters some follow-up questions later, but I sometimes wished I could review the presentations, as I’ve been able to do with the regular working group meetings on youtube.

It’s my opinion that the networking-related issues driven by media delivery (particularly the scaling issues and the real-time requirements, where those are a factor) are really worthwhile to examine in detail, and to consider various proposed solutions in a context like IETF, with access to and comments from networking experts and network operators.

Sorry I’ve been unresponsive on this, and I know there’s deadlines coming up.  It’s not quite my top priority and I’ve had several other fairly urgent things going, but I consider this group to be filling an important role at the IETF, at least for my purposes there, and I’d like to see it normalized.

I also have some comments on the draft charter that was recently sent out, I’ll send those in a follow-up.

Best regards,
Jake

From: Leslie Daigle <[email-masked]>
Date: 2019-05-29 at 11:01
To: "[email-masked]" <[email-masked]>
Subject: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi,

We’ve been working with Éric to see about having a “Media OPS” bof in Montreal, and I’ve copied a draft agenda/proposal framework, below. Comments welcome.

As the BoF request deadline is approaching, I’d like to get some firm commits on concrete contributions (I-Ds are ideal; presentations are possible). If you have a contribution you’d like to share in the agenda, please let me know; if you’ve already heard from me with a request, I’ll be following up :^) .

Media OPerationS (MOPS) BoF
Area: OPS
Chairs: Leslie Daigle ([email-masked]<mailto:[email-masked]>), Glenn Deen ([email-masked]<mailto:[email-masked]>)

Agenda

0/ Agenda bash

1/ Scope of video on the Internet
<contributions solicited>

2/ Video using IETF technologies
<contributions solicited; I was thinking that LURK and OpenCache might fit well here, again>

3/ Open questions for IETF and video

AOB

Full description of BoF:

Internet- and Internet-protocol-delivered video/media is popular, leading to significant technology development across industries not traditionally thought of as Internet technology developers or operators, as well as considerable quantities of traffic on local and transit networks. Continued development of Internet-using technologies should be properly coordinated in order to ensure that the existing technologies are well-utilized, and new ones are developed in sympathy with the Internet’s core protocols and design.

The purpose of this BoF is to highlight the many existing video activities that are leveraging IETF protocol work, identify gaps in IETF work and/or areas of incompatibility with video technology development efforts being carried out elsewhere, and identify a core group of IETF participants working on video activities across the IETF’s technology areas.

Conflicts to avoid: ???

Expected attendance: 40

Length of session: 90min

Leslie.

--

________________________________

Leslie Daigle
Principal, ThinkingCat Enterprises

[email-masked]<mailto:[email-masked]>

---

From: [email-masked]
Date: Tue, 4 Jun 2019 22:48:42 +0000

Hi Leslie – Thank you for putting the agenda for BOF at Montreal. I fully support this effort and hope this leads to a home for much of “operational” issues relating with delivery of video that otherwise, don’t seem to have a home.

The open caching working group within the Streaming Video Alliance relied on CDNI RFCs and extended those RFCs to account for use case extension however, there are areas such as interoperability, for example, HLS client browser sessions maintaining a sticky session with the final redirected source. This issue has been brought up previously with the HTTP WG without resolution.  When it comes to CDN delegation, the IETF publications do not provide detailed guidance or clarify issues associated with HTTP redirections and how they should be handled by HAS video players.

These “operational” issues would have a better chance of being examined in MOPS and specifications can be developed.

I will send comments to the agenda separately but I wanted to call out my support for the BOF.

Thanks
Sanjay

From: GGIE [mailto:[email-masked]] On Behalf Of Leslie Daigle
Sent: Wednesday, May 29, 2019 2:01 PM
To: [email-masked]
Subject: [E] [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi,

Agenda

0/ Agenda bash

AOB

Full description of BoF:

Conflicts to avoid: ???

Expected attendance: 40

Length of session: 90min

Leslie.

--

Leslie Daigle

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Wed, 5 Jun 2019 12:00:58 +0000

Hi all,

I do fully support this initiative. Nowadays media traffic supported in telco networks is the most relevant component, but not all the media content is characterized in the same way, is not delivered in the same manner, and the users have not the same expectations for different media services. Then having a formal group working on this topic is relevant and needed for better (and sustainable) design of the networks.

Best regards

Luis

De: GGIE <[email-masked]> En nombre de Leslie Daigle
Enviado el: miércoles, 29 de mayo de 2019 20:01
Para: [email-masked]
Asunto: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi,

Agenda

0/ Agenda bash

AOB

Full description of BoF:

Conflicts to avoid: ???

Expected attendance: 40

Length of session: 90min

Leslie.

--

Leslie Daigle

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição