Subject: [hackathon] What is the IPR policy for Hackathon? RE: [94all] IETF 94 - Hackathon Information

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Tue, 8 Sep 2015 06:41:50 +0000

Does the IETF IPR policy apply to Hackathon, including both patent/application and copyright? 

My personal understanding is:
1, For the code generated during Hackathon, the code (copyright) belongs to IETF/Hackathon. For any patent or patent application that may relevant to the code, the IETF IPR disclosure rule applies. 
2, For the base code, such as OpenDaylight, its IPR belongs to the community/foundation that own/sponsor the projects. The IPR rules is defined in that community/foundation, rather than binding by IETF IPR rule. This seems obvious. 
3, How about code generated by IETF WG participants, such as a I2RS or Homenet? That may not relevant to an external open source community, foundation or project.

Your thoughts?

- Miao

> -----Original Message-----
> From: 94all [mailto:[email-masked]] On Behalf Of IETF Secretariat
> Sent: Tuesday, September 01, 2015 5:38 AM
> To: IETF Announcement List
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [94all] IETF 94 - Hackathon Information
> 
> IETF 94 Hackathon
> 
> The Internet Engineering Task Force (IETF) is holding a Hackathon at IETF 94
> to encourage developers to discuss, collaborate and develop utilities, ideas,
> sample code and solutions that show practical implementations of IETF
> standards.
> 
> When: Saturday October 31 and Sunday November 1
> Where: Pacifico Yokohama, Room TBD
> Sponsored By: Cisco DevNet
> Signup for the Hackathon:
> https://www.ietf.org/registration/ietf94/hackathonregistration.py
> More information can be found here:
> http://ietf.org/hackathon/94-hackathon.html
> Keep up to date by subscribing to:
> https://www.ietf.org/mailman/listinfo/hackathon
> 
> The Hackathon is free to attend and open to all. Extend the invitation to
> colleagues outside the IETF!
> 
> Here’s what happened at the Hackathon in Prague at IETF 93:
> Blog:
> https://communities.cisco.com/community/developer/opensource/blog/20
> 15/08/03
> Video:
> https://www.youtube.com/watch?v=emZ-pIJLDlg&feature=youtu.be
> 
> Currently the technologies that will be focused on at the IETF 94 Hackathon
> include:
> * DHCP 4o6
> * I2RS
> * ICE
> * NETVC
> * SFC
> 
> Descriptions and information regarding the technologies for the hackathon
> are located on the IETF 94 Meeting Wiki:
> https://www.ietf.org/registration/MeetingWiki/wiki/94hackathon
> 
> Don’t see anything that interests you? Feel free to add your preferred
> technology to the list, sign up as its Champion and show up to work on it.
> Note: you must login to the wiki to add content. If you do add a new
> technology, we strongly suggest that you send an email to
> [email-masked] to let others know. You may generate interest in your
> technology, and find other people who want to contribute to it.
> 
> Be a Champion!  See:  http://ietf.org/hackathon/94-hackathon.html
> 
> To request a wiki account, please click on the “login” button on the bottom
> right corner of the page, and choose “register.” If you need a new password
> please click on the “login” button on the bottom right corner of the page
> and choose “Send new password.”
> 
> The IETF is seeking Hackathon sponsors for IETF 95 and beyond. If you are
> interested in more information, please contact Drew Dvorshak at
> [email-masked]
> 
> _______________________________________________
> 94all mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/94all

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 9 Sep 2015 16:16:32 +0000

Good question, Miao. Hackathon registration and participation is
independent of the IETF meeting; however, we do make it clear in the
registration and at the event that participation in the Hackathon is
subject to the IETF Note Well. In addition to this, open source projects
have their own governance and rules for contributing to them. These must
be adhered to as well when code developed at the Hackathon is contributed
into these projects.

Cheers,
Charles 

On 9/7/15, 11:41 PM, "ietf on behalf of Miaofuyou (Miao Fuyou)"
<[email-masked] on behalf of [email-masked]> wrote:

>1, For the code generated during Hackathon, the code (copyright) belongs
>to IETF/Hackathon. For any patent or patent application that may relevant
>to the code, the IETF IPR disclosure rule applies.
>2, For the base code, such as OpenDaylight, its IPR belongs to the
>community/foundation that own/sponsor the projects. The IPR rules is
>defined in that community/foundation, rather than binding by IETF IPR
>rule. This seems obvious.
>3, How about code generated by IETF WG participants, such as a I2RS or
>Homenet? That may not relevant to an external open source community,
>foundation or project.
>
>Your thoughts?
>
>- Miao
>
>> Here¹s what happened at the Hackathon in Prague at IETF 93:
>> Blog:
>> Don¹t see anything that interests you? Feel free to add your preferred
>> To request a wiki account, please click on the ³login² button on the
>>bottom
>> right corner of the page, and choose ³register.² If you need a new
>>password
>> please click on the ³login² button on the bottom right corner of the
>>page
>> and choose ³Send new password.²
>>

---

From: Sam Hartman <[email-masked]>
Date: Wed, 09 Sep 2015 13:07:59 -0400

>>>>> "Charles" == Charles Eckel (eckelcu) <[email-masked]> writes:

    Charles> Good question, Miao. Hackathon registration and
    Charles> participation is independent of the IETF meeting; however,
    Charles> we do make it clear in the registration and at the event
    Charles> that participation in the Hackathon is subject to the IETF
    Charles> Note Well. In addition to this, open source projects have
    Charles> their own governance and rules for contributing to
    Charles> them. These must be adhered to as well when code developed
    Charles> at the Hackathon is contributed into these projects.

My understanding of copyright and the IETF note well is inconsistent
with  Mr. Fuyou's description though.
In particular, typically ownership of the IETF contribution remains with
the contributor, although the IETF is granted a rather broad
non-exclusive license to
the contribution.

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 9 Sep 2015 19:58:39 +0000

My original response inadvertently gloss over that point. My understanding
is the same as yours, Sam.

Cheers,
Charles

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Sep 2015 08:52:06 +1200

>> the contributor, although the IETF is granted a rather broad

If somebody wants to provide their hackathon code to the IETF, they could
submit an Internet Draft whose body consists of their code, between
<CODE BEGINS> and <CODE ENDS>. Then it becomes an IETF contribution with a
Simplified BSD licence, as I understand the IETF Trust's legal provisions.

     Brian

---

From: Sam Hartman <[email-masked]>
Date: Wed, 09 Sep 2015 17:15:49 -0400

>>>>> "Brian" == Brian E Carpenter <[email-masked]> writes:

    Brian> If somebody wants to provide their hackathon code to the
    Brian> IETF, they could submit an Internet Draft whose body consists
    Brian> of their code, between <CODE BEGINS> and <CODE ENDS>. Then it
    Brian> becomes an IETF contribution with a Simplified BSD licence,
    Brian> as I understand the IETF Trust's legal provisions.

No, I think you're wrong.
I think marking something as code has nothing to do with the rights that
 the IETF gets, it only affects whether the rest of the world can
 actually use our contributions  in open-source contexts.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Sep 2015 10:16:02 +1200

>  actually use our contributions  in open-source contexts.

Oh sure: but putting it under Simplified BSD allows the IETF tools team
and the Secretariat to use it, just like anyone else.

    Brian

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 9 Sep 2015 18:19:46 -0400

On Wed, Sep 9, 2015 at 5:15 PM, Sam Hartman <[email-masked]> wrote:

> [...]

I think that both of you are correct, as quoted above.

Of course, please note well that a Contribution to the IETF does not
necessarily have to take the form of a document. Thus, I think it is
reasonable to question whether code developed during the Hackathon is
considered a Contribution to the IETF. I am uncertain whether Hackathon
code is inherently Contributed by nature of being developed under the Note
Well etc, or whether its Contribution status is optional based on the
author's intent. I believe the latter is the case, but that is an open
question to be confirmed. I've asked the rest of the IAOC Legal Committee
and the IETF's counsel to discuss this question.

Even if code developed at a Hackathon is a Contribution (either inherently
or optionally), under IETF IPR rules the original author retains ownership
rights to the work and thus should be able to contribute it to non-IETF
open source projects as long as those projects accept contributions under a
compatible license. Likewise, existing "outside" open source code that is
used at a Hackathon is not necessarily a Contribution to the IETF unless
the IPR owner (e.g. original author) intends for it to be Contributed. Both
of these aspects (outgoing and incoming code) need to be described more
clearly for the benefit of the Hackathon community, and so I've also asked
the IAOC Legal Committee and IETF counsel to discuss this topic as well.

We will attempt to provide some additional guidance to the community after
we've performed appropriate diligence.

-Benson

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 10 Sep 2015 09:19:39 +0200

> Simplified BSD licence, as I understand the IETF Trust's legal provisions.

Since ownership of the contribution stays with the author, it is simpler
for the author to release the contribution under a suitable license
directly.

Further, releasing it directly allows the author to place a copyright
notice on the work -- something many free software licenses requires to
be preserved.  If you submit it in an ID, according to the IETF
policies, you aren't allowed to add your own copyright notice to it.

/Simon

---

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Mon, 14 Sep 2015 02:10:25 +0000

Thanks for bringing this to IAOC, Benson!

A particular intricate problem is the potential IPR rule confliction between IETF and other open source community/foundation, if a project is brought to Hackathon from that community/foundation. This is especially problematic for patent, where usually many open sources require free licensing, contrastively IETF requires disclosure only if one knows.

-        Miao

From: Benson Schliesser [mailto:[email-masked]]
Sent: Thursday, September 10, 2015 6:20 AM
To: Sam Hartman
Cc: Brian E Carpenter; IETF Discussion; Miaofuyou (Miao Fuyou); Charles Eckel (eckelcu); [email-masked]
Subject: Re: [hackathon] What is the IPR policy for Hackathon? RE: [94all] IETF 94 - Hackathon Information

On Wed, Sep 9, 2015 at 5:15 PM, Sam Hartman <[email-masked]<mailto:[email-masked]>> wrote:
>>>>> "Brian" == Brian E Carpenter <[email-masked]<mailto:[email-masked]>> writes:

[...]

Of course, please note well that a Contribution to the IETF does not necessarily have to take the form of a document. Thus, I think it is reasonable to question whether code developed during the Hackathon is considered a Contribution to the IETF. I am uncertain whether Hackathon code is inherently Contributed by nature of being developed under the Note Well etc, or whether its Contribution status is optional based on the author's intent. I believe the latter is the case, but that is an open question to be confirmed. I've asked the rest of the IAOC Legal Committee and the IETF's counsel to discuss this question.

Even if code developed at a Hackathon is a Contribution (either inherently or optionally), under IETF IPR rules the original author retains ownership rights to the work and thus should be able to contribute it to non-IETF open source projects as long as those projects accept contributions under a compatible license. Likewise, existing "outside" open source code that is used at a Hackathon is not necessarily a Contribution to the IETF unless the IPR owner (e.g. original author) intends for it to be Contributed. Both of these aspects (outgoing and incoming code) need to be described more clearly for the benefit of the Hackathon community, and so I've also asked the IAOC Legal Committee and IETF counsel to discuss this topic as well.

We will attempt to provide some additional guidance to the community after we've performed appropriate diligence.

-Benson

---

From: "GTW" <[email-masked]>
Date: Mon, 14 Sep 2015 10:29:29 -0400

on the matter of  issue of relations between the “formal” standards community and the  “open source” community , not exactly the issue of this email thread but close    ...  I am on an  ANSI IPR policy committee  Copyright-in-Software Task Force   working on a draft paper that describes  matters an SDO might contemplate when writing a standard that includes some mandatory use of software ... welcome insight that I might contribute to the ANSI TF

George T. Willingmyre
President GTW Associates

From: Miaofuyou (Miao Fuyou) 
Sent: Sunday, September 13, 2015 10:10 PM
To: Benson Schliesser ; Sam Hartman 
Cc: [email-masked] ; IETF Discussion 
Subject: RE: [hackathon] What is the IPR policy for Hackathon? RE: [94all] IETF 94 - Hackathon Information

-        Miao

[...]

-Benson

---

From: Jari Arkko <[email-masked]>
Date: Fri, 18 Sep 2015 10:14:20 -0700

The question of rights is important for the Hackathon. I have a personal
perspective on this, largely from a pragmatic viewpoint.

My primary goal is to make it possible for people to hack the things they want
to hack. This means that they should be able to work on Linux kernel and
whatever else, without causing issues in their ability to commit code to the
relevant open source projects. And change existing code. And work together
with others inside and outside the IETF Hackathon. To me this says: respect
the rules of the relevant open source project when it comes to
code.

But code is not everything in the Hackathon. You also have discussions,
presentations, and demos. I think it is a reasonable assumption that the
usual IETF copyright and IPR rules apply there. For instance, that IETF
gets rights to use the slides in proceedings, or that if you convince your
IETF colleagues to work on some cool extension, you should let the
IETF and those colleagues know about the IPR you know of…

Is this an approach that people feel comfortable with?

Note: The IAOC and IETF legal team are also working on this topic and may
be saying something as well. This e-mail isn’t a legal opinion; I just want
to express my view on what kind of a setup works for the participants.
And that I think needs to be the starting point.

Jari

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 18 Sep 2015 18:35:33 +0000

We should encourage 'non-open source' (i.e. commercial software developers) to participate - participation does not make that code public or gives the IETF any rights.

This should be about testing implementations (regardless of source status) and making sure that they interoperate and working out issues with drafts and RFC; not about transferring any ownership or other rights. There are some past well know events of a similar nature - such as Sun's Connectathons. Perhaps some of that legal framework exists somewhere?

Sure, for discussions, presentations, and demos, the IETF rules can apply (as they would in any WG sessions or similar).

- Bernie 

-----Original Message-----
From: hackathon [mailto:[email-masked]] On Behalf Of Jari Arkko
Sent: Friday, September 18, 2015 1:14 PM
To: Miaofuyou (Miao Fuyou) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [hackathon] What is the IPR policy for Hackathon? RE: [94all] IETF 94 - Hackathon Information

The question of rights is important for the Hackathon. I have a personal perspective on this, largely from a pragmatic viewpoint.

My primary goal is to make it possible for people to hack the things they want to hack. This means that they should be able to work on Linux kernel and whatever else, without causing issues in their ability to commit code to the relevant open source projects. And change existing code. And work together with others inside and outside the IETF Hackathon. To me this says: respect the rules of the relevant open source project when it comes to code.

But code is not everything in the Hackathon. You also have discussions, presentations, and demos. I think it is a reasonable assumption that the usual IETF copyright and IPR rules apply there. For instance, that IETF gets rights to use the slides in proceedings, or that if you convince your IETF colleagues to work on some cool extension, you should let the IETF and those colleagues know about the IPR you know of...

Note: The IAOC and IETF legal team are also working on this topic and may be saying something as well. This e-mail isn't a legal opinion; I just want to express my view on what kind of a setup works for the participants.
And that I think needs to be the starting point.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Fri, 18 Sep 2015 11:52:55 -0700

> We should encourage 'non-open source' (i.e. commercial software developers) to participate - participation does not make that code public or gives the IETF any rights.

While the hackathon focus is on open source, I do agree that we shouldn’t limit people to participate for, say, interop purposes using their non-open-source implementations.

Jari

---

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Sat, 19 Sep 2015 03:53:38 +0000

Hi Yari,

Thanks for sharing your insight! 

My comments are in-line. 

> together with others inside and outside the IETF Hackathon. To me this says:
> respect the rules of the relevant open source project when it comes to code.

I agree it is a reasonable principle. But I still have a question.

IETF is individual based, however, not all open source project/community are individual based. Probably IPR rules of some of them are more adapted to organization membership, for example, it may require the member to license the member's patent for free, which match the contributed code by this member's employees. Put such open source project under Hackathon environment, who is the member for the project, IETF or the individual's affiliation? Is the Hackathon participant qualified to write code on or contribute it, if his/her affiliation is not a member of that project/community? etc...

Probably we could have a guideline for selection of open source project for Hackathon, or add some note (complementary to Note Well at Hackathon) to remind the project specific IPR rule to participants to make sure they are aware of it. 

> usual IETF copyright and IPR rules apply there. For instance, that IETF gets
> rights to use the slides in proceedings, or that if you convince your IETF
> colleagues to work on some cool extension, you should let the IETF and
> those colleagues know about the IPR you know of...

Sure.

> Is this an approach that people feel comfortable with?

In principle, I like it:-) 

> be saying something as well. This e-mail isn't a legal opinion; I just want to
> express my view on what kind of a setup works for the participants.

---

From: Jari Arkko <[email-masked]>
Date: Fri, 18 Sep 2015 22:09:23 -0700

> Probably we could have a guideline for selection of open source project for Hackathon, or add some note (complementary to Note Well at Hackathon) to remind the project specific IPR rule to particip…

Those are good questions.

I don’t have a ready thought out answer for them. It would
seem though that it is easier and probably necessary for
an individual to work it out with his or her affiliation whether
contribution to a particular open source project is possible,
and what it might mean for the organisation. That is certainly
how it works in the corporate environments that I am familiar
with.

Jari

---

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Sat, 19 Sep 2015 06:37:13 +0000

Jari, 

Sure, the individual should figure it out with his/her affiliation, but the organizers of Hackathon could give some warn/remind in advance, just like Note Well, to participant. 

I believe this is more needed than Note Well, considering there are 10+ projects/Hackathon technology for each Hackathon. Also, the projects vary from a Hackathon to another with different license and membership model. 

BTW, I wish all Hackathon technology, that is developed within Hackathon without dependency to external body, would apply IETF IPR and membership rule. That will be much more convenient to participants. 

- Miao

> From: Jari Arkko [mailto:[email-masked]]
> Sent: Saturday, September 19, 2015 1:09 PM
> To: Miaofuyou (Miao Fuyou)
> > IETF is individual based, however, not all open source project/community
> are individual based. Probably IPR rules of some of them are more adapted
> to organization membership, for example, it may require the member to
> license the member's patent for free, which match the contributed code by
> this member's employees. Put such open source project under Hackathon
> environment, who is the member for the project, IETF or the individual's
> affiliation? Is the Hackathon participant qualified to write code on or
> contribute it, if his/her affiliation is not a member of that project/community?
> etc...
> >
> > Probably we could have a guideline for selection of open source project for
> Hackathon, or add some note (complementary to Note Well at Hackathon)
> to remind the project specific IPR rule to participants to make sure they are
> aware of it.
> 
> I don't have a ready thought out answer for them. It would seem though
> that it is easier and probably necessary for an individual to work it out with
> his or her affiliation whether contribution to a particular open source project
> is possible, and what it might mean for the organisation. That is certainly
> how it works in the corporate environments that I am familiar with.
> 
> Jari

---

From: Jari Arkko <[email-masked]>
Date: Sat, 19 Sep 2015 06:48:04 -0700

> Sure, the individual should figure it out with his/her affiliation, but the organizers of Hackathon could give some warn/remind in advance, just like Note Well, to participant.

This might be useful. Thanks.

Jari

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 21 Sep 2015 20:54:30 +0000

I am thinking that for each technology and proposed project, the champions
can call out the relevant open source software projects. While they cannot
provide legal advice to others who want to use and/or contribute to it,
they can at least make participants aware of it such that they can do
their own due diligence.

Cheers,
Charles

On 9/19/15, 6:48 AM, "hackathon on behalf of Jari Arkko"
<[email-masked] on behalf of [email-masked]> wrote:

>
>> Sure, the individual should figure it out with his/her affiliation, but
>>the organizers of Hackathon could give some warn/remind in advance, just
>>like Note Well, to participant.
>

---

From: Jari Arkko <[email-masked]>
Date: Mon, 28 Sep 2015 18:56:39 +0300

I have not heard further on this thread, but heard some
supportive comments of the overall principle, and
some suggestions regarding the details of how the
principle is applied.

I think that means that we are going ahead with the
upcoming and further IETF Hackathons under this principle:

You are free to work on any code, and the rules regarding
that code are what your organisation or open source project
says they are; the code itself is not an IETF contribution.
However, discussions, presentations, demos, are the
same type of IETF contributions as we make in working
groups, so, for instance, the usual IETF copyright or
IPR disclosure rules apply.

I believe this maximises the ability of everyone to
participate.

Lets put the above text into the wiki page. I have
also asked the IAOC legal committee to draft a more
exact definition and determine whether that needs
to become a more formal document as well as being
listed on the wiki page.

Jari

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 28 Sep 2015 18:19:31 +0000

I have added this to the IETF 94 hackathon wiki:
https://www.ietf.org/registration/MeetingWiki/wiki/94hackathon

Cheers,
Charles

On 9/28/15, 8:56 AM, "Jari Arkko" <[email-masked]> wrote:

>> IETF and those colleagues know about the IPR you know ofŠ

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 30 Sep 2015 20:46:08 +0000

Just a friendly reminder. The hackathon is only a month away.
Registration is open, free, and independent of your registration for IETF
94.
If your name is not on the list below, you have not registered for the
hackathon.
https://www.ietf.org/registration/ietf94/hackathonattendance.py?sortkey=3&l
ogin=%0A

Several additional technologies, champions, and projects have been added.
More are welcome.
See the wiki for the current info:
https://www.ietf.org/registration/MeetingWiki/wiki/94hackathon

The original announcement with additional links follows.

Cheers,
Charles

On 8/31/15, 2:37 PM, "IETF-Announce on behalf of IETF Secretariat"
<[email-masked] on behalf of [email-masked]>
wrote:

>IETF 94 Hackathon
>
>The Internet Engineering Task Force (IETF) is holding a Hackathon at IETF
>94 to encourage developers to discuss, collaborate and develop utilities,
>ideas, sample code and solutions that show practical implementations of
>IETF standards.  
>
>https://communities.cisco.com/community/developer/opensource/blog/2015/08/
>03
>Video:  https://www.youtube.com/watch?v=emZ-pIJLDlg&feature=youtu.be
>
>Currently the technologies that will be focused on at the IETF 94
>Hackathon include:
>* DHCP 4o6
>* I2RS
>* ICE
>* NETVC
>* SFC
>
>technology to the list, sign up as its Champion and show up to work on
>it. Note: you must login to the wiki to add content. If you do add a new
>bottom right corner of the page, and choose ³register.² If you need a new
>password please click on the ³login² button on the bottom right corner of
>the page and choose ³Send new password.²
>