Subject: [hackathon] Sociologists Examine Hackathons and See Exploitation

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 22 Mar 2018 08:08:14 +0000

[Wired's title, not mine]

https://www.wired.com/story/sociologists-examine-hackathons-and-see-exploitation/

I don't think that most of the remarks in this article apply to IETF
hackathon but it may be useful to review other hackathons.

---

From: Michael Koster <[email-masked]>
Date: Thu, 22 Mar 2018 08:23:36 +0000

I was asked once to host a hackathon where the organizers wanted all the participants to sign a TOU agreeing that all resulting code and design artifacts become the intellectual property of the organizing company.

I of course refused, and the organizers claimed that this was "standard".

> On Mar 22, 2018, at 8:08 AM, Stephane Bortzmeyer <[email-masked]> wrote:
> 
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 22 Mar 2018 09:24:58 +0000

Interesting article. Not all hackathons are the same, just like not all conferences are the same. The IETF hackathon is not a typical hackathon, just like the IETF conference is not a typical conference. That said, we need to be mindful that there are some negative connotations with the word hackathon. While I do not believe the IETF hackathon exemplifies those, I may be too close to it to see if and where it does. 

In any case, we need to be diligent in our messaging of the hackathon to make it clear that the IETF hackathon is a collaborative event focused on increasing the pace, quality, and relevance of internet standards. The hackathon is also meant to welcome newcomers and make it easy for them to get involved and make real contributions to the IETF. If it is not, we need to change something.

Cheers,
Charles

---

From: Michael Richardson <[email-masked]>
Date: Thu, 22 Mar 2018 11:14:04 +0000

+1

I found it rather difficult at the beginning to understand what the IETF
Hackathon was about.  And maybe how I'm using it is very difficult than
others.
In general, we (ANIMA/6tisch) have used it as an interop event (with the
deadline implicit in that) where we try to validate if the document
accurately documents the running code.

I'm also very very much +100 with Michael Koster's response.
I would rather like to know who those organizers were.
Did they proceed anyway?

Charles Eckel (eckelcu) <[email-masked]> wrote:
    > Interesting article. Not all hackathons are the same, just like not all
    > conferences are the same. The IETF hackathon is not a typical
    > hackathon, just like the IETF conference is not a typical
    > conference. That said, we need to be mindful that there are some
    > negative connotations with the word hackathon. While I do not believe
    > the IETF hackathon exemplifies those, I may be too close to it to see
    > if and where it does.

    > In any case, we need to be diligent in our messaging of the hackathon
    > to make it clear that the IETF hackathon is a collaborative event
    > focused on increasing the pace, quality, and relevance of internet
    > standards. The hackathon is also meant to welcome newcomers and make it
    > easy for them to get involved and make real contributions to the
    > IETF. If it is not, we need to change something.

    > Cheers, Charles

Michael Koster <[email-masked]> wrote: 
    mk>     I was asked once to host a hackathon where the organizers wanted
    mk> all the participants to sign a TOU agreeing that all resulting code and
    mk> design artifacts become the intellectual property of the organizing
    mk> company.
    
    mk>     I of course refused, and the organizers claimed that this was
    mk> "standard".
    
    >> _______________________________________________ hackathon mailing list
    >> [email-masked] https://www.ietf.org/mailman/listinfo/hackathon
    
    >     _______________________________________________ hackathon mailing
    > list [email-masked] https://www.ietf.org/mailman/listinfo/hackathon

    > _______________________________________________ hackathon mailing list
    > [email-masked] https://www.ietf.org/mailman/listinfo/hackathon

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 22 Mar 2018 11:27:38 +0000

Hi Charles,

I can't fault the messaging from you or the IETF, however there are connotations. I don't have an answer but FWIW I do have a datapoint.

I brought some new colleagues to the Hackathon event and had to go to some length to explain that *this IETF* Hackathon is not like *that XYZ* Hackathon. Some key differences IMO:

Disparate projects and goals (as opposed to hack on a common problem / data set / etc)
Considerate Intellectual Property terms
Considerate time scheduling
Cooperation (as opposed to competition)

Kind regards
Lucas

> From: hackathon [mailto:[email-masked]] On Behalf Of Charles
> Eckel (eckelcu)
> Sent: 22 March 2018 09:25
> To: Michael Koster <[email-masked]>; Stephane Bortzmeyer
> <[email-masked]>
> Cc: [email-masked]
> conferences are the same. The IETF hackathon is not a typical hackathon, just
> like the IETF conference is not a typical conference. That said, we need to be
> mindful that there are some negative connotations with the word
> hackathon. While I do not believe the IETF hackathon exemplifies those, I
> may be too close to it to see if and where it does.
> 
> In any case, we need to be diligent in our messaging of the hackathon to
> make it clear that the IETF hackathon is a collaborative event focused on
> increasing the pace, quality, and relevance of internet standards. The
> hackathon is also meant to welcome newcomers and make it easy for them
> to get involved and make real contributions to the IETF. If it is not, we need
> to change something.
> 
> Cheers,
> Charles
> 
>     I was asked once to host a hackathon where the organizers wanted all the
> participants to sign a TOU agreeing that all resulting code and design artifacts
> become the intellectual property of the organizing company.
>

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 22 Mar 2018 11:34:56 +0000

We've faced the problem in the States with events like "civic hacking"
or "gov data hackathons" where mostly lay people see the work "hack"
and assume it's malicious hacking (essentially gaining unauthorized
access to certain things). We've had to describe that hacking really
is more about tinkering and there are of course bad people that tinker
and very good ones too. ::)

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

CDT's Annual Dinner, Tech Prom, is March 29, 2018. Don't miss the tech
event of the year!
Reserve a table today.: https://cdt.org/annual-dinner/

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 Mar 2018 11:35:40 +0000

On Mar 22, 2018, at 08:23, Michael Koster <[email-masked]> wrote:
> 
> I of course refused, and the organizers claimed that this was “standard".

The problem is that the prevalence of these predatory hackathons is already giving the concept of “hackathon” a bad name.

(Disclaimer: in some of my classes, I use terms of participation where all participants agree to make all results of the class the common property of all those participants.  So I do not believe all terms of participation are bad…)

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 23 Mar 2018 07:57:36 +1300

"Zukin was surprised to find that hackathon participants almost
universally view the events positively."

I am not surprised to find that sociologists don't understand geeks.

Honestly, can anybody take twaddle like "multi-dimensional agents
of change" seriously? Why do people invent nonsense words like "Co-optation"?

I'm not saying there's no exploitation in hackathons, but that doesn't
excuse sociological pseudoscience.

Regards
   Brian

On 22/03/2018 21:08, Stephane Bortzmeyer wrote:
> .

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Thu, 22 Mar 2018 20:15:44 +0000

> excuse sociological pseudoscience.

yeah, why don't they use terms like "congestion control mechanisms" and
"application layer", or invent nonsense words like "multi-path" and
"InetAddressIPv4z" instead‽

I'm not saying that i agree with everything these sociologists write,
but if jargon impenetrable to the out-group means something shouldn't be
taken seriously, then we should abandon the IETF.

If you haven't seen the kind of hackathon that the article describes,
please be glad :) That doesn't mean that this kind of unscrupulous
exploitation doesn't exist.  I see them as the tech-world, shorter-term
analog to "unpaid internships" common in the NGO community, where
relatively inexperienced laborers feel obliged to prove their worth
under a pretty severe power imbalance.  Sure, they learn something.  But
more value is often extracted from their labor than they gain.

fwiw, my experience of the IETF hackathon is that it is not of the
exploitative type described in the Wired article.  I've been really
pleased with the IETF hackathon, and i routinely describe it to friends
as "the productive part of the IETF meetings". :) Many thanks to those
who organize it, who bring a sane perspective on "IP" issues, and who
take feedback seriously and continue to improve the experience for
participants.

      --dkg

PS lest anyone misconstrue my snark above, i actually think there is a
   place for jargon -- as a means of concise communication about complex
   ideas between skilled practitioners.

---

From: Randy Bush <[email-masked]>
Date: Sun, 25 Mar 2018 09:56:45 -0700

> more value is often extracted from their labor than they gain.

tragically true