Subject: [hackathon] YANG based EVC Service Modeling in OpenDaylight

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 14 Mar 2018 17:39:14 -0700

The focus of this project is to develop and demonstrate how YANG based service models can be used to configure and manage EVC based services. Common EVC services include E-Line, E-LAN and E-Tree services. Examples of these services are shown below.

These services have been defined in MEF[1], and the YANG models developed there can be found in GitHub here[2].

Our project will focus on developing and demonstrating a solution where Postman can be used to call set of REST APIs to configure a EVPL service on top of Mininet[3]. Users can play with Swagger APIs to create, update, view and delete services using the GUI interface. We will be using Unimgr[4] project in OpenDaylight to host the solution.

This solution can be extended to manage both physical and virtual devices from different networking vendors, in-lieu of the mininet.

Come check us out in the hackathon on Saturday (mid-day onwards) and Sunday.

[1] https://www.mef.net/Assets/Technical_Specifications/PDF/MEF_58.pdf
[2] https://github.com/MEF-GIT/YANG-public <https://github.com/MEF-GIT/YANG-public>
[3] http://mininet.org/ <http://mininet.org/>
[4] https://wiki.opendaylight.org/view/Unimgr:Main <https://wiki.opendaylight.org/view/Unimgr:Main>

Mahesh Jethanandani
[email-masked]

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 15 Mar 2018 13:52:01 +0000

Hi Mahesh,

Thanks for championing this project. I especially like the way it pulls together work being done in multiple SDOs and uses them within the content of an open source platform.

Cheers,
Charles

From: hackathon <[email-masked]> on behalf of Mahesh Jethanandani <[email-masked]>
Date: Wednesday, March 14, 2018 at 5:39 PM
To: "[email-masked]" <[email-masked]>
Subject: [hackathon] YANG based EVC Service Modeling in OpenDaylight

[1] https://www.mef.net/Assets/Technical_Specifications/PDF/MEF_58.pdf
[2] https://github.com/MEF-GIT/YANG-public
[3] http://mininet.org/
[4] https://wiki.opendaylight.org/view/Unimgr:Main

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>