Subject: [hackathon] Quantum networks at IETF 104 hackathon

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 11 Mar 2019 10:08:24 +0100

Hi all,

Some of us at the IRTF are working on quantum networks, networks capable 
of sharing and using quantum entanglement. The first lab demonstrations 
are due later this year and the plan is to connect a few cities in the 
Netherlands in 2020 already.

First of all: _quantum physics knowledge is NOT required to participate_ 
- we will introduce the necessary basics to anyone. If you would like 
more insight into the technology now two places to start reading up on 
the subject:

  * ​https://www.nature.com/articles/d41586-018-01835-3
  * ​https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/

This is a very broad subject for a hackathon, but we have two main 
themes to propose open to anyone who would like to contribute to the 
subject:

  * Quantum Ping (discussion and writing a document)
      o What is the abstraction of the quantum ping in the Quantum
        Internet.
      o What functionalities quantum ping should have.
      o How functionalities be realized in quantum plane and classical
        plane, etc.
  * Applications for 2019/2020 lab setups and beyond (using published
    API on a simulator)
      o Entanglement advertisement
        ​https://tools.ietf.org/html/draft-kaws-qirg-advent-01
      o Anonymous quantum state transfer
      o Bit commitment
          + Over a trusted network
          + Measurement-device independent
          + Device independent
      o Blind Quantum Computation
      o QKD variants (e.g device-independent)
      o Conference Key agreement (multi-party QKD)
      o Quantum Secret Sharing
      o Consensus algorithms (e.g. Byzantine)
      o Leader election algorithms
      o Coin-flipping
      o Formal verification of quantum algorithms

Don't worry if any of that sounds unfamiliar. We will explain everything 
at the event and try to involve anyone who wants to make a contribution.

The project champions are:

  * Shota Nagayama <shota.nagayama at mercari.com <http://mercari.com>>
  * Wojciech Kozlowski <w.kozlowski at tudelft.nl <http://tudelft.nl>>

Thanks,
Wojciech

---

From: Shota NAGAYAMA <[email-masked]>
Date: Wed, 13 Mar 2019 15:07:34 +0900

Hi all,

This book would also fit to IETF folks to start quantum networks
technically.
https://www.amazon.com/Quantum-Networking-Networks-Telecommunications-Rodney-ebook-dp-B00K9K0GO6/dp/B00K9K0GO6/ref=mt_kindle?_encoding=UTF8&me=&qid=1552140895
I’ll bring a hardcopy to the hackathon.

Bests,
Shota

On Mon, Mar 11, 2019 at 6:08 PM Wojciech Kozlowski <[email-masked]>
wrote:

> of sharing and using quantum entanglement. The first lab demonstrations are
> due later this year and the plan is to connect a few cities in the
> First of all: *quantum physics knowledge is NOT required to participate*
> - we will introduce the necessary basics to anyone. If you would like more
> insight into the technology now two places to start reading up on the
> subject:
>
>    - ​https://www.nature.com/articles/d41586-018-01835-3
>    - ​https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/
>
> This is a very broad subject for a hackathon, but we have two main themes
> to propose open to anyone who would like to contribute to the subject:
>
>    - Quantum Ping (discussion and writing a document)
>       - What is the abstraction of the quantum ping in the Quantum
>       Internet.
>       - What functionalities quantum ping should have.
>       - How functionalities be realized in quantum plane and classical
>       plane, etc.
>    - Applications for 2019/2020 lab setups and beyond (using published
>    API on a simulator)
>       - Entanglement advertisement ​
>       https://tools.ietf.org/html/draft-kaws-qirg-advent-01
>       - Anonymous quantum state transfer
>       - Bit commitment
>          - Over a trusted network
>          - Measurement-device independent
>          - Device independent
>       - Blind Quantum Computation
>       - QKD variants (e.g device-independent)
>       - Conference Key agreement (multi-party QKD)
>       - Quantum Secret Sharing
>       - Consensus algorithms (e.g. Byzantine)
>       - Leader election algorithms
>       - Coin-flipping
>       - Formal verification of quantum algorithms
>
>    - Shota Nagayama <shota.nagayama at mercari.com>
>    - Wojciech Kozlowski <w.kozlowski at tudelft.nl>
>
> Thanks,
> Wojciech
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
>

---

From: "Trevor Lee Oakley" <[email-masked]>
Date: Wed, 13 Mar 2019 02:26:47 -0400

I am on the blockchain side of all this - QKD and entanglement. I have been working on the entanglement aspects. Quantum networks are very important to blockchain concepts.

 Is there any overlap between blockchain concepts and what you are doing at the hackathon (I know IETF is engaged in decentralised internet work via IRTF)?

----------------------------------------
 From: "Shota NAGAYAMA" <[email-masked]>
Sent: 13 March 2019 02:08
To: "Wojciech Kozlowski" <[email-masked]>
Cc: [email-masked]
Subject: Re: [hackathon] Quantum networks at IETF 104 hackathon   
  Hi all,  
  This book would also fit to IETF folks to start quantum networks technically.
 https://www.amazon.com/Quantum-Networking-Networks-Telecommunications-Rodney-ebook-dp-B00K9K0GO6/dp/B00K9K0GO6/ref=mt_kindle?_encoding=UTF8&me=&qid=1552140895
 I'll bring a hardcopy to the hackathon.

 Bests,
 Shota

    On Mon, Mar 11, 2019 at 6:08 PM Wojciech Kozlowski <[email-masked]> wrote:
  Hi all,

Some of us at the IRTF are working on quantum networks, networks capable of sharing and using quantum entanglement. The first lab demonstrations are due later this year and the plan is to connect a few cities in the Netherlands in 2020 already.

First of all: quantum physics knowledge is NOT required to participate - we will introduce the necessary basics to anyone. If you would like more insight into the technology now two places to start reading up on the subject:   	?https://www.nature.com/articles/d41586-018-01835-3 	?https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/ 
This is a very broad subject for a hackathon, but we have two main themes to propose open to anyone who would like to contribute to the subject:   	Quantum Ping (discussion and writing a document) 	 		What is the abstraction of the quantum ping in the Quantum Internet. 		What functionalities quantum ping should have. 		How functionalities be realized in quantum plane and classical plane, etc. 	
	 	Applications for 2019/2020 lab setups and beyond (using published API on a simulator) 	 		Entanglement advertisement ?https://tools.ietf.org/html/draft-kaws-qirg-advent-01 		Anonymous quantum state transfer 		Bit commitment 		 			Over a trusted network 			Measurement-device independent 			Device independent 		
		 		Blind Quantum Computation 		QKD variants (e.g device-independent) 		Conference Key agreement (multi-party QKD) 		Quantum Secret Sharing 		Consensus algorithms (e.g. Byzantine) 		Leader election algorithms 		Coin-flipping 		Formal verification of quantum algorithms 	

Don't worry if any of that sounds unfamiliar. We will explain everything at the event and try to involve anyone who wants to make a contribution.

The project champions are:  	Shota Nagayama <shota.nagayama at mercari.com> 	Wojciech Kozlowski <w.kozlowski at tudelft.nl> 
Thanks,
Wojciech
_______________________________________________
hackathon mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hackathon

---

From: "Trevor Lee Oakley" <[email-masked]>
Date: Wed, 13 Mar 2019 02:27:39 -0400

Is this the one in Prague?

 Bests,
 Shota

---

From: "Trevor Lee Oakley" <[email-masked]>
Date: Wed, 13 Mar 2019 03:03:36 -0400

I saw this is the one in Prague. I just signed up. I am looking forward to it. Actually the blockchain use case is super relevant to this. If we can have secure communications we will be able to dramatically change blockchain implementations. I have been following some of the edx material on Quantum. 

----------------------------------------
 From: "Trevor Lee Oakley" <[email-masked]>
Sent: 13 March 2019 02:28
To: "Wojciech Kozlowski" <[email-masked]>, "Shota NAGAYAMA" <[email-masked]>
Cc: [email-masked]
Subject: Re: [hackathon] Quantum networks at IETF 104 hackathon   
 Is this the one in Prague?

   Bests,
   Shota

---

From: "Shigeya Suzuki" <[email-masked]>
Date: Fri, 15 Mar 2019 00:22:17 -0400

Hi,

As a person working on both of the topics (separately), I have an interest in what you're working on.
Please let me find time to talk on what you're working on.

I probably at the quantum group table this time.

thanks!

shigeya

On Wed, Mar 13, 2019, at 15:27, Trevor Lee Oakley wrote:
> *From*: "Shota NAGAYAMA" <[email-masked]>
> *Sent*: 13 March 2019 02:08
> *To*: "Wojciech Kozlowski" <[email-masked]>
> *Cc*: [email-masked]
> *Subject*: Re: [hackathon] Quantum networks at IETF 104 hackathon 
> 
> Hi all, 
> 
> On Mon, Mar 11, 2019 at 6:08 PM Wojciech Kozlowski <[email-masked] <mailto:w.kozlowski@tudelft..nl>> wrote:
>> Hi all,
>> 
>>  First of all: _quantum physics knowledge is NOT required to participate_ - we will introduce the necessary basics to anyone. If you would like more insight into the technology now two places to start reading up on the subject: 
>>  * ?https://www.nature.com/articles/d41586-018-01835-3
>>  * ?https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/
>> This is a very broad subject for a hackathon, but we have two main themes to propose open to anyone who would like to contribute to the subject:
>>    * What is the abstraction of the quantum ping in the Quantum Internet.
>>    * What functionalities quantum ping should have.
>>    * How functionalities be realized in quantum plane and classical plane, etc.
>>  * Applications for 2019/2020 lab setups and beyond (using published API on a simulator) 
>>    * Entanglement advertisement ?https://tools.ietf.org/html/draft-kaws-qirg-advent-01
>>    * Anonymous quantum state transfer
>>    * Bit commitment 
>>      * Over a trusted network
>>      * Measurement-device independent
>>      * Device independent
>>    * Blind Quantum Computation
>>    * QKD variants (e.g device-independent)
>>    * Conference Key agreement (multi-party QKD)
>>    * Quantum Secret Sharing
>>    * Consensus algorithms (e.g. Byzantine)
>>    * Leader election algorithms
>>    * Coin-flipping
>>    * Formal verification of quantum algorithms
>>  * Shota Nagayama <shota.nagayama at mercari.com>
>>  * Wojciech Kozlowski <w.kozlowski at tudelft.nl>
>> Thanks,
>>  Wojciech

---

From: "Trevor Lee Oakley" <[email-masked]>
Date: Fri, 15 Mar 2019 00:56:52 -0400

Yes. I will look you up.
  
 I am travelling from Southend (there is a direct flight to Prague). Is there a recommend hotel? I was checking hotels.com. I saw costs varied a lot. 

----------------------------------------
 From: "Shigeya Suzuki" <[email-masked]>
Sent: 15 March 2019 00:23
To: "Trevor Lee Oakley" <[email-masked]>, "Wojciech Kozlowski" <[email-masked]>, "Shota NAGAYAMA" <[email-masked]>
Cc: [email-masked]
Subject: Re: [hackathon] Quantum networks at IETF 104 hackathon   
 Hi,

   
 thanks!
  
 shigeya

  

  
   Hi all, 

 Bests,
 Shota

  
  
 First of all: quantum physics knowledge is NOT required to participate - we will introduce the necessary basics to anyone. If you would like more insight into the technology now two places to start reading up on the subject: 
  	?https://www.nature.com/articles/d41586-018-01835-3 	?https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/ 
 This is a very broad subject for a hackathon, but we have two main themes to propose open to anyone who would like to contribute to the subject:
  	 	Quantum Ping (discussion and writing a document) 
 	 		What is the abstraction of the quantum ping in the Quantum Internet. 		What functionalities quantum ping should have. 		How functionalities be realized in quantum plane and classical plane, etc. 	
	 	 	Applications for 2019/2020 lab setups and beyond (using published API on a simulator) 
 	 		Entanglement advertisement ?https://tools.ietf.org/html/draft-kaws-qirg-advent-01 		Anonymous quantum state transfer 		 		Bit commitment 
 		 			Over a trusted network 			Measurement-device independent 			Device independent 		
		 		Blind Quantum Computation 		QKD variants (e.g device-independent) 		Conference Key agreement (multi-party QKD) 		Quantum Secret Sharing 		Consensus algorithms (e.g. Byzantine) 		Leader election algorithms 		Coin-flipping 		Formal verification of quantum algorithms 	

 The project champions are: 
  	Shota Nagayama <shota.nagayama at mercari.com> 	Wojciech Kozlowski <w.kozlowski at tudelft.nl> 
 Thanks,
 Wojciech

---

From: "Trevor Lee Oakley" <[email-masked]>
Date: Fri, 15 Mar 2019 10:53:03 -0400

I am flying in from Southend (London) to Prague, if anyone wants to meetup please let me know. I am booked into the Holiday Inn. My whatsapp is +44 7452986739

Sent: 15 March 2019 00:30

   
 thanks!
  
 shigeya

  

  
   Hi all, 

 Bests,
 Shota

---

From: Bruno Rijsman <[email-masked]>
Date: Fri, 22 Mar 2019 20:03:14 -0300

Will be there be some mechanism (e.g. a Slack channel, a Zoom meeting, a Google Meetup, etc.) for remote participants to attend?

>> ?https://www.nature.com/articles/d41586-018-01835-3 <https://www.nature.com/articles/d41586-018-01835-3>
>> ?https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/ <https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/>
>> What is the abstraction of the quantum ping in the Quantum Internet.
>> What functionalities quantum ping should have.
>> How functionalities be realized in quantum plane and classical plane, etc.
>> Entanglement advertisement ?https://tools.ietf.org/html/draft-kaws-qirg-advent-01 <https://tools.ietf.org/html/draft-kaws-qirg-advent-01>
>> Anonymous quantum state transfer
>> Bit commitment 
>> Over a trusted network
>> Measurement-device independent
>> Device independent
>> Blind Quantum Computation
>> QKD variants (e.g device-independent)
>> Conference Key agreement (multi-party QKD)
>> Quantum Secret Sharing
>> Consensus algorithms (e.g. Byzantine)
>> Leader election algorithms
>> Coin-flipping
>> Formal verification of quantum algorithms
>> Shota Nagayama <shota.nagayama at mercari.com <http://mercari.com/>>
>> Wojciech Kozlowski <w.kozlowski at tudelft.nl <http://tudelft.nl/>>
>> Thanks,
>> Wojciech
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/hackathon <https://www.ietf.org/mailman/listinfo/hackathon>
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/hackathon <https://www.ietf.org/mailman/listinfo/hackathon>
>>  
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hackathon <https://www.ietf.org/mailman/listinfo/hackathon>

---

From: Wojciech Kozlowski <[email-masked]>
Date: Sat, 23 Mar 2019 08:05:11 +0100

For those who wish to participate remotely, I just created this slack 
workspace:

https://join.slack.com/t/ietf104quantumhack/shared_invite/enQtNTg1Nzg2NTE4NzM4LTZmNDg0OWRhZDU5ZTIyMjdiYjQ0ZDk5ZGEyZjMyZjM4ZmQwOGQzNDU0MzU4ZjUxYTI3ZDYxMzkxODQ0NGQyOWQ

I will coordinate further on that slack channel.

Thanks,
Wojtek

On 23/03/2019 00:03, Bruno Rijsman wrote:
> Will be there be some mechanism (e.g. a Slack channel, a Zoom meeting, 
> a Google Meetup, etc.) for remote participants to attend?
>
>>>
>>> On Mon, Mar 11, 2019 at 6:08 PM Wojciech Kozlowski 
>>> <[email-masked] <mailto:w.kozlowski@tudelft..nl>> wrote:
>>>
>>>     Hi all,
>>>     Some of us at the IRTF are working on quantum networks, networks
>>>     capable of sharing and using quantum entanglement. The first lab
>>>     demonstrations are due later this year and the plan is to
>>>     connect a few cities in the Netherlands in 2020 already.
>>>     First of all:_quantum physics knowledge is NOT required to
>>>     participate_- we will introduce the necessary basics to anyone.
>>>     If you would like more insight into the technology now two
>>>     places to start reading up on the subject:
>>>
>>>     This is a very broad subject for a hackathon, but we have two
>>>     main themes to propose open to anyone who would like to
>>>     contribute to the subject:
>>>
>>>      *
>>>           o What is the abstraction of the quantum ping in the
>>>             Quantum Internet.
>>>           o How functionalities be realized in quantum plane and
>>>             classical plane, etc.
>>>      *
>>>           o Entanglement
>>>             advertisement?https://tools.ietf.org/html/draft-kaws-qirg-advent-01
>>>          o
>>>     Don't worry if any of that sounds unfamiliar. We will explain
>>>     everything at the event and try to involve anyone who wants to
>>>     make a contribution.
>>>       * Shota Nagayama <shota.nagayama atmercari.com
>>>         <http://mercari.com/>>
>>>       * Wojciech Kozlowski <w.kozlowski attudelft.nl
>>>         <http://tudelft.nl/>>
>>>
>>>     Thanks,
>>>     Wojciech