Subject: [hackathon] Virtual hackathon? (Was: IETF 107 Vancouver In-Person Meeting Cancelled)

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 11 Mar 2020 13:42:02 +0000

Hackathoners,

Hopefully all of you have already seen the attached email from the IESG canceling the in-person IETF 107 meeting. As it says, we are trying to determine if it is worthwhile to proceed with a virtual hackathon on March 21-22, or if it would be better to cancel it altogether.

A virtual hackathon would work essentially as follows:

* We kick off the hackathon at 09:30 PDT on Saturday using a Meetecho session allocated for the Hackathon. 
* Afterward, hackathon project teams are free to manage their time as they see fit based on the time zones of their participants.
* We encourage teams to create and upload presentations to https://github.com/IETF-Hackathon/ietf107-project-presentations, but will we will not come together Sunday afternoon to present them due to the respective time zones of the various participants. Rather, teams can ask for time in their working group sessions to present if/when appropriate.
* There is no Hackdemo Happy Hour or Code Lounge.
* The hackathon Jabber room and [email-masked] email list may be used to communicate across project teams.
* Project champions may request a Webex session for their team that they may use for the duration of the hackathon (available from 08:00 on Saturday until 20:00 on Sunday) and/or a repo in the IETF GitHub org (https://github.com/IETF-Hackathon/) for their project in order to share code.

We kindly request that everyone who registered for the hackathon, or are interested to now participate in this virtual hackathon, fill out the following 3-question survey, https://www.surveymonkey.com/r/107hackathon 

It is extremely important that project champions do this to help us to correctly identify which projects would be included in the virtual hackathon.

Thank you for your understanding and help,
Barry and Charles

On 3/10/20, 12:11 PM, "ietf on behalf of The IESG" <[email-masked] on behalf of [email-masked]> wrote:

    The IESG and the IRTF Chair have decided to cancel the in-person IETF 107 Vancouver meeting. This decision is based on input we gathered from Working Group (WG) and Research Group (RG) chairs about our ability to hold productive WG and RG sessions at IETF 107. Our assessment of this feedback is that a majority of sessions would not be viable if we were to hold the in-person IETF meeting. On this basis, we believe we cannot hold an effective in-person meeting. 
    
    As a result of this cancellation, the in-person Hackathon, Code Sprint, all other in-person events planned for the weekend of March 21-22, the chairs training scheduled for March 20, and all other in-person sessions during the week are cancelled.
    
    The IESG is working on an alternative all-virtual agenda for the week of March 21-27 with a limited schedule adapted to accommodate the time zones of as many participants as possible. We are also planning to support an increased volume of virtual interim meetings during the weeks that follow. We will send another update to the community soon with more information about these plans. The Hackathon organizers are also considering plans for virtual Hackathon support.
    
    We have re-opened Internet-Draft submissions, which had been closed on March 9 in anticipation of the in-person meeting. Internet-Drafts may be submitted at <https://datatracker.ietf.org/submit/>.
    
    A separate announcement from the IETF Executive Director will follow with details about registration cancellations and refunds.  
    
    These are unusual times given the circumstances created by the spread of COVID-19.  We hope that everyone remains safe and healthy.
    
    Regards,
    The IESG and the IRTF Chair

---

From: [email-masked] <[email-masked]>
Date: Thu, 12 Mar 2020 14:52:42 +0100

> Hopefully all of you have already seen the attached email from the IESG canceling the in-person IETF 107 meeting. As it says, we are trying to determine if it is worthwhile to proceed with a virtua…

We are happy to participate remotely from Mauritius. Thank you Charles & Barry. 
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon