Subject: [hackathon] IETF 110 Hackathon Virtual Network

From: Sean Croghan <[email-masked]>
Date: Thu, 21 Jan 2021 21:59:38 +0000

Everyone,

As meetings are still remote the NOC team continues to work on an experiment that allows you to join the IETF network remotely. The system provides a bunch of networks, very similar to what we offer at a meeting, just at your home, school, lab, office - just "virtual via the Internet".

The goal is not to provide "Internet Access”, you already have that. This VPN rather puts you into the ietf network as close as possible, very much as if you were sitting next to each other plugged into the same switch or connected to the same WLAN. Currently functionality is key, while performance varies based on your location and network speed.

The system is based on our regional network hubs and your provided equipment (CPE). The CPE is currently based on the Raspberry Pi platform, but is designed to accommodate others. We have tested with Cisco and Microtik routers as well.

More info and setup details, if you are interested for yourself or your team to use the virtual network.

https://tickets.meeting.ietf.org/wiki/IETF110network#Experiments

Sean and the NOC Team

---

From: Michael Richardson <[email-masked]>
Date: Thu, 21 Jan 2021 17:42:50 -0500

Sean Croghan <[email-masked]> wrote:
    > The goal is not to provide "Internet Access”, you already have
    > that. This VPN rather puts you into the ietf network as close as
    > possible, very much as if you were sitting next to each other plugged
    > into the same switch or connected to the same WLAN. Currently
    > functionality is key, while performance varies based on your location
    > and network speed.

My setup from IETF109 is still alive.

On top of other interesting uses like interop testing for things that run
over IPv6-LL... (really very useful...),
if you connect your phone to the network,  you'll be geo-located to the
previous IETF meeting location (so.. Madrid).
So it's actually bug-comptible with being on site! :-)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 22 Jan 2021 23:07:42 +0000

Huge thanks to Sean and the NOC team for providing this key capability. There are several challenges to overcome with online collaboration on hackathon projects, but access to a shared IETF network can be a big help.

The current set of hackathon projects is here, https://trac.ietf.org/trac/ietf/meeting/wiki/110hackathon#ProjectsIncludedinHackathonaddyourprojectusingthetemplateprovidedatendofprojectlist

If you plan to lead a project, please add it to the wiki asap. You can always update things at a later date. Sharing your plans now via the wiki will help others plan accordingly.

Cheers,
Charles

From: hackathon <[email-masked]> on behalf of Sean Croghan <[email-masked]>
Reply-To: Ietf <[email-masked]>
Date: Thursday, January 21, 2021 at 2:00 PM
To: "[email-masked]" <[email-masked]>
Subject: [hackathon] IETF 110 Hackathon Virtual Network

Everyone,

Sean and the NOC Team