Subject: [hackathon] Interop testing within hackathon network

From: Juhamatti Kuusisaari <[email-masked]>
Date: Thu, 11 Mar 2021 18:01:50 +0200

Hello,

Just wondering how people have been doing interop testing in remote
hackathons so far, what would be the best practices? For my use case
the simplest thing would be to have a common server where a KVM image
would be instantiated and other KVM instances or even host processes
could connect to it over kernel switch. Anything like this available?

Thanks,
--
 Juhamatti

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 11 Mar 2021 20:47:50 +0000

Hi Juhamatti,

Shared compute resources were made available at some previous in person hackathons, but that practice stoped due to low utilization. 
For recent online only hackathons, we have provided remote networking options, as described here,
https://datatracker.ietf.org/doc/html/draft-eckel-shmoo-ietf-hackathon-03#section-6.8

We ran into some complications that resulted in these services not being available for IETF 110, but we intend to offer something comparable for future hackathons. If so, would this work for the interop testing you have in mind?

Cheers,
Charles

On 3/11/21, 8:06 AM, "hackathon on behalf of Juhamatti Kuusisaari" <[email-masked] on behalf of [email-masked]> wrote:

    Hello,

    Thanks,
    --
     Juhamatti

    _______________________________________________
    hackathon mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/hackathon

---

From: Pierre Francois <[email-masked]>
Date: Thu, 11 Mar 2021 21:51:41 +0100 (CET)

Charles, 

these are great initiatives, but shouldn't we simply rely on the champions to provide the env for interop testing?

Cheers, 

Pierre.

----- Mail original -----
> De: "Charles Eckel (eckelcu)" <eckelcu=[email-masked]>
> À: "Juhamatti Kuusisaari" <[email-masked]>, [email-masked]
> Envoyé: Jeudi 11 Mars 2021 21:47:50
> Objet: Re: [hackathon] Interop testing within hackathon network

> Hi Juhamatti,
> 
> Shared compute resources were made available at some previous in person
> hackathons, but that practice stoped due to low utilization.
> We ran into some complications that resulted in these services not being
> available for IETF 110, but we intend to offer something comparable for future
> hackathons. If so, would this work for the interop testing you have in mind?
> 
> Cheers,
> Charles
> 
>On 3/11/21, 8:06 AM, "hackathon on behalf of Juhamatti Kuusisaari"
><[email-masked] on behalf of [email-masked]> wrote:
> 
>    Hello,
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 11 Mar 2021 21:21:10 +0000

Pierre,

Thanks, and yes, ultimately it is up to the project champions and the rest of the team to determine how they want to work and what tools they want to use. A goal of the hackathon is to provide an environment and tools that can be helpful.

Cheers,
Charles

On 3/11/21, 12:52 PM, "Pierre Francois" <[email-masked]> wrote:

    Charles, 

    Cheers, 

    Pierre.

---

From: Badma Butaev <[email-masked]>
Date: Fri, 12 Mar 2021 02:15:43 +0300

Hello!

Please remove me from the mailing list.

> 12 марта 2021 г., в 00:22, Charles Eckel (eckelcu) <eckelcu=[email-masked]> написал(а):
> 
> Pierre,
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 12 Mar 2021 02:13:42 +0000

You can modify or cancel your subscription at https://www.ietf.org/mailman/listinfo/hackathon.

Cheers,
Charles

On Mar 11, 2021, at 3:16 PM, Badma Butaev <[email-masked]> wrote:

Hello!

Pierre,

Cheers,
Charles

  Charles,

  Cheers,

  Pierre.

  ----- Mail original -----
De: "Charles Eckel (eckelcu)" <eckelcu=[email-masked]>
À: "Juhamatti Kuusisaari" <[email-masked]>, [email-masked]
Envoyé: Jeudi 11 Mars 2021 21:47:50
Objet: Re: [hackathon] Interop testing within hackathon network

Hi Juhamatti,

Shared compute resources were made available at some previous in person
hackathons, but that practice stoped due to low utilization.
For recent online only hackathons, we have provided remote networking options,
as described here,
https://datatracker.ietf.org/doc/html/draft-eckel-shmoo-ietf-hackathon-03#section-6.8

Cheers,
Charles

 Hello,

 Thanks,
 --
  Juhamatti

---

From: Juhamatti Kuusisaari <[email-masked]>
Date: Fri, 12 Mar 2021 12:31:22 +0200

Hello,

> https://datatracker.ietf.org/doc/html/draft-eckel-shmoo-ietf-hackathon-03#section-6.8

Thanks for the draft link! So, NOC would then be a place to ask in
advance for networking services. I could imagine some reasonably
scaled cloud instance would also do fine, no need for actual HW in
that sense. It would be nice if the IETF hackathon organization had
some credits for those, through sponsors maybe?

> We ran into some complications that resulted in these services not being available for IETF 110, but we intend to offer something comparable for future hackathons. If so, would this work for the in…

I was thinking fairly simple TCP authentication option testing over
e.g. IPv6 telnet, or whatever may work best for possible attendees.
This does not need any fancy networking as such, only server-internal
connectivity - a cloud instance that can run KVM instances (enough
memory+cpus) would probably work fine for this.

Cheers,
--
 Juhamatti

---

From: Juhamatti Kuusisaari <[email-masked]>
Date: Fri, 12 Mar 2021 12:36:57 +0200

Hello,

It is nice though that the draft has no requirement for champions to
provide these resources. This way anyone can be the champion.

BR,
--
 Juhamatti

---

From: Benson Muite <[email-masked]>
Date: Fri, 12 Mar 2021 13:49:10 +0300

Hi,

Many cloud companies are usually happy to sponsor hackathons with cloud 
resources if asked appropriately and if these are efficiently used. 
Possibly a guide for Champions could be useful.

Regards,
Benson

---

From: Chris Morrow <[email-masked]>
Date: Fri, 12 Mar 2021 14:29:00 -0500

People need to learn how mailing lists work, please read the headers
and click the included link to unsubscribe.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Mar 2021 08:55:21 +1300

In fairness, Chris, the unsubscribe link in the headers is significantly hard to find since typical user agents will not normally display it. For example, on Thunderbird you need to select View/Headers/All and scroll down about three pages. On the gmail webmail interface you have to find the "Show Original" option and scroll through the whole SMTP header junk.

However, the convention of sending an Unsubscribe message to <listname>-request@<domain> should be known to everybody.

Regards
   Brian

---

From: Ted Lemon <[email-masked]>
Date: Fri, 12 Mar 2021 15:04:47 -0500

> In fairness, Chris, the unsubscribe link in the headers is significantly hard to find since typical user agents will not normally display it. For example, on Thunderbird you need to select View/Hea…

Depends on the MUA. If you are running MacOS, it looks like this:

It’s weird that GMail doesn’t do better. They definitely know how to read the header, because they do it for spam. Somebody ought to add this to Thunderbird. It’s sad how many mail UAs are stuck in the 20th century (not to say that Apple Mail is a paragon in every way, but it does get this right).

---

From: Chris Morrow <[email-masked]>
Date: Fri, 12 Mar 2021 15:24:01 -0500

> However, the convention of sending an Unsubscribe message to <listname>-request@<domain> should be known to everybody.

Sure, it's the year 2021 ... people should know how mailing lists work by now.

---

From: Randy Bush <[email-masked]>
Date: Fri, 12 Mar 2021 15:12:17 -0800

> However, the convention of sending an Unsubscribe message to
> <listname>-request@<domain> should be known to everybody.

who is over 60

randy

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Fri, 12 Mar 2021 23:32:20 +0000

And it doesn't really seem to work, I did it yesterday and still get mails :-)

Oliver

-----------------------------------------------
Oliver Borchert, Computer Scientist
National Institute of Standards and Technology
(Office) +1.301.975.4856
(GVoice) +1.240.668.4117

    who is over 60

    randy

    _______________________________________________
    hackathon mailing list
    [email-masked]
    https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fhackathon&amp;data=04%7C01%7Coliver.borchert%40nist.gov%7C57456273ca3d49e4ed5608d8e5ac6e70%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C637511876051084083%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=XKZ62ta8aMqc3lC%2F%2B%2B0IfKvqsyxF12cWnyBhEgr7FNQ%3D&amp;reserved=0