Subject: [hackathon] constrained-voucher Hackathon IETF111 efforts

From: Michael Richardson <[email-masked]>
Date: Fri, 11 Jun 2021 11:46:00 -0400

At the beginning of May, the participants in the Thursday BRSKI Design team
call expressed interest in doing some interop testing among implementations.

We will do this during the IETF111 Hackathon online.
We have been waiting to hear if there will be any kind of L2 VPN available,
as our discovery protocol runs over IPv6-LL addresses.  Having heard nothing
we are pessimistically planning to operate with VPN.

Some participants will have a Join proxy locally, and others will just be
hardcoding Internet URLs into their pledge.

We have created a document to capture all the planning into at:
   https://docs.google.com/document/d/1T8Rtfk1zia_p05_6eb_WQA2Mmid-eP1-cAgnwdpF9Xk/edit?usp=sharing

We plan to use gather.town to chat, which allows us to jump into 1:1
conversations easily.  We also plan to use the [email-masked] channel.

We have just posted draft-ietf-anima-constrained-voucher-11.txt on which
the work is expected to be based.

There are still a few issues open which are editorial, and a few which also
more RFC8995 errata (still being debated).

We'd like to suggest that the WG start a WGLC on July 9, ending on July 30.

We've asked for some reviews, and Russ Housley already provided one (the same
day!), which we have yet to act on.  Any feedback/clarification from the
interop would go in as WGLC comments.

If we get VPN, then we may be able to test
  https://datatracker.ietf.org/doc/draft-ietf-anima-constrained-join-proxy/
as well, which is also ready for WGLC.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 14 Jun 2021 18:26:59 +0000

Hi Michael,

We anticipate having support for L2 VPN available for the IETF 111 Hackathon.
Adding Sean to the thread to comment on the availability of this service and whether a device other than a previously supported Raspberry Pi will be required.

Cheers,
Charles

> On Jun 11, 2021, at 8:46 AM, Michael Richardson <[email-masked]> wrote:
> 
> 
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
> Unsubscribe: mailto:[email-masked]?subject=unsubscribe

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Jun 2021 18:29:07 -0400

My RPI based VPN is still plugged in and appears to be still working.
I suspect that's also true of Brian Carpenter's.

Charles Eckel \(eckelcu\) <eckelcu=[email-masked]> wrote:
    > Adding Sean to the thread to comment on the availability of this
    > service and whether a device other than a previously supported
    > Raspberry Pi will be required.

Thanks for the update!

    >> we are pessimistically planning to operate with VPN.

should be:
  _we are pessimistically planning to operate *without* a VPN_

---

From: [email-masked]
Date: Fri, 18 Jun 2021 09:51:16 +0300

Leave my fucking email alone. I never asked to be tracked or for for u guys to fuck up my email. I was hacked so end the fucking tracking. I am pissed the fuck off. Tanya Yahola and phone number 1 (918) 525-8978. 
--
Sent from myMail for Android Monday, 14 June 2021, 05:30PM -05:00 from Michael Richardson  [email-masked] :

>Charles Eckel \(eckelcu\) < eckelcu=[email-masked]> wrote:
>    > We anticipate having support for L2 VPN available for the IETF 111 Hackathon.
>    > Adding Sean to the thread to comment on the availability of this
>    > service and whether a device other than a previously supported
>    > Raspberry Pi will be required.
>
>Thanks for the update!
>
>    >> We will do this during the IETF111 Hackathon online.
>    >> We have been waiting to hear if there will be any kind of L2 VPN available,
>    >> as our discovery protocol runs over IPv6-LL addresses.  Having heard nothing
>    >> we are pessimistically planning to operate with VPN.
>
>should be:
>    >> If we get VPN, then we may be able to test
>    >> https://datatracker.ietf.org/doc/draft-ietf-anima-constrained-join-proxy/
>    >> as well, which is also ready for WGLC.
>
>--
>Michael Richardson < [email-masked]> . o O ( IPv6 IøT consulting )