Subject: [hackathon] LwM2M at the IETF hackathon

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 26 Jun 2021 13:16:31 +0000

Hi all,

Matt and I co-chair a group in the OMA SpecWorks organization that develops the LwM2M protocol, a protocol for managing IoT devices over the entire lifecycle.
(For a short intro please look at the recent presentation at the IoTOPS WG meeting, see https://www.youtube.com/watch?v=ZJN9IiQjcUk (~13min into the session) or https://datatracker.ietf.org/meeting/110/materials/slides-110-iotops-iot-device-management-with-lwm2m-00)

LwM2M uses many IETF protocols (see http://www.openmobilealliance.org/release/LightweightM2M/V1_2-20201110-A/), such as CoAP plus various extensions, EST, TLS/DTLS, OSCORE, COSE, ....

Since many of those protocols are also subject to hackathon projects, we were wondering whether there is interest to team up to perform interop tests, develop new test cases, write tools for developers or run implementations on IoT hardware.

If you are interested in IoT, work on those protocols and plan to participate at the upcoming hackathon, please reach out to us. If you need help with IoT hardware in your project, please let us know even sooner.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 28 Jun 2021 15:29:46 +0000

Hannes and Matt,

Great idea and thanks for sharing with the Hackathon community. Please add corresponding information to the wiki (https://trac.ietf.org/trac/ietf/meeting/wiki/111hackathon) to make it easy for others to find this info and get involved.

Cheers,
Charles

On Jun 26, 2021, at 6:16 AM, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
hackathon mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hackathon
Unsubscribe: mailto:[email-masked]?subject=unsubscribe