Subject: Re: [hackathon] LwM2M at the IETF hackathon

From: Rikard Höglund <[email-masked]>
Date: Fri, 16 Jul 2021 16:17:35 +0000

Hello.

My name is Rikard Höglund and I am working on implementing support for OSCORE in the LwM2M framework called Leshan [1]. Leshan is written in Java and its support for OSCORE in turn relies on the Californium CoAP library [2], which I have also been working on adding support for OSCORE to. Currently the code for OSCORE-support in Leshan exists in a separate branch [3] in the Leshan project, but the plan is to get it integrated into the main branch of Leshan.

I would be very interested in participating in any tests or work related to OSCORE in LwM2M.

Best wishes
Rikard Höglund

[1] https://www.eclipse.org/leshan/
[2] https://www.eclipse.org/californium/
[3] https://github.com/eclipse/leshan/tree/oscore
________________________________
From: hackathon <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Sent: Saturday, June 26, 2021 15:16
To: [email-masked] <[email-masked]>
Cc: Gillmore, Matthew <[email-masked]>
Subject: [hackathon] LwM2M at the IETF hackathon

Hi all,

Matt and I co-chair a group in the OMA SpecWorks organization that develops the LwM2M protocol, a protocol for managing IoT devices over the entire lifecycle.

(For a short intro please look at the recent presentation at the IoTOPS WG meeting, see https://www.youtube.com/watch?v=ZJN9IiQjcUk<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DZJN9IiQjcUk&data=04%7C01%7Crikard.hoglund%40ri.se%7C510f98b2789b4db34c9508d938a4cc18%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637603102863308314%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ItDyTgOKcEWlBowu4b3Qd1UL7l%2BUbPYKhsktRuoy%2FvU%3D&reserved=0> (~13min into the session) or https://datatracker.ietf.org/meeting/110/materials/slides-110-iotops-iot-device-management-with-lwm2m-00<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F110%2Fmaterials%2Fslides-110-iotops-iot-device-management-with-lwm2m-00&data=04%7C01%7Crikard.hoglund%40ri.se%7C510f98b2789b4db34c9508d938a4cc18%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637603102863318269%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=oDTKv3NX2Qe9St2L872j0ketDgHpITga5eXG2%2BK%2Bs6g%3D&reserved=0>)

LwM2M uses many IETF protocols (see http://www.openmobilealliance.org/release/LightweightM2M/V1_2-20201110-A/<https://eur02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.openmobilealliance.org%2Frelease%2FLightweightM2M%2FV1_2-20201110-A%2F&data=04%7C01%7Crikard.hoglund%40ri.se%7C510f98b2789b4db34c9508d938a4cc18%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637603102863318269%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=no6IxmbfNMd1mq7Oud0KLrAEdtP2jl7aRXFJ6Gq2UTk%3D&reserved=0>), such as CoAP plus various extensions, EST, TLS/DTLS, OSCORE, COSE, ....

Since many of those protocols are also subject to hackathon projects, we were wondering whether there is interest to team up to perform interop tests, develop new test cases, write tools for developers or run implementations on IoT hardware.

If you are interested in IoT, work on those protocols and plan to participate at the upcoming hackathon, please reach out to us. If you need help with IoT hardware in your project, please let us know even sooner.

Ciao

Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 16 Jul 2021 16:24:21 +0000

Thanks, Rikard.

We are going to have a conference call next Monday to discuss the interest of the participants. I will send you a meeting invite. Then, we can quickly find out who else is interested in OSCORE.

Ciao
Hannes

From: Rikard Höglund <[email-masked]>
Sent: Friday, July 16, 2021 6:18 PM
To: Hannes Tschofenig <[email-masked]>; [email-masked]
Cc: Gillmore, Matthew <[email-masked]>
Subject: Re: LwM2M at the IETF hackathon

Hello.

Best wishes
Rikard Höglund

[1] https://www.eclipse.org/leshan/
[2] https://www.eclipse.org/californium/
[3] https://github.com/eclipse/leshan/tree/oscore
________________________________
From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, June 26, 2021 15:16
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: Gillmore, Matthew <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] LwM2M at the IETF hackathon

Hi all,

Ciao

Hannes

---

From: gahar ana <[email-masked]>
Date: Fri, 16 Jul 2021 18:00:07 +0000

No, I do not need you. You are the marathon, your passion, lock and directing on what you want. You have penetrated everything, even the mind, soul and race. You are criminals.

تم الإرسال من Galaxy الخاص بي

-------- الرسالة الأصلية --------
من: Hannes Tschofenig <[email-masked]>
التاريخ: ١٦‏/٧‏/٢٠٢١ ٧:٢٥ م (GMT+03:00)
إلى: Rikard Höglund <[email-masked]>, [email-masked]
نسخة: "Gillmore, Matthew" <[email-masked]>
الموضوع: Re: [hackathon] LwM2M at the IETF hackathon

Thanks, Rikard.

Ciao
Hannes

Hello.

Best wishes
Rikard Höglund

[1] https://www.eclipse.org/leshan/<https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.eclipse.org%2Fleshan%2F&data=04%7C01%7C%7C68992723f7fe4af3e8b008d9487641bb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637620495011539448%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=0dT8XzQKyaiA4m%2Bpbi8588AGwiNgrroKmzwTEr4Vi4c%3D&reserved=0>
[2] https://www.eclipse.org/californium/<https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.eclipse.org%2Fcalifornium%2F&data=04%7C01%7C%7C68992723f7fe4af3e8b008d9487641bb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637620495011539448%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2F6%2FJdwxvdJ0fH%2Fyj%2BuiE%2Bk1%2BJsAtG4omJ4af7fVbDvY%3D&reserved=0>
[3] https://github.com/eclipse/leshan/tree/oscore<https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Feclipse%2Fleshan%2Ftree%2Foscore&data=04%7C01%7C%7C68992723f7fe4af3e8b008d9487641bb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637620495011549414%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=uhRjg6mGdEoCnAwSdiP8U9%2BR26y3X6ejy8VfnitDaD0%3D&reserved=0>
________________________________
From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, June 26, 2021 15:16
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: Gillmore, Matthew <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] LwM2M at the IETF hackathon

Hi all,

(For a short intro please look at the recent presentation at the IoTOPS WG meeting, see https://www.youtube.com/watch?v=ZJN9IiQjcUk<https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DZJN9IiQjcUk&data=04%7C01%7C%7C68992723f7fe4af3e8b008d9487641bb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637620495011549414%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=rwJQ9F4DCbuYnzpMskfv1g2ByamxmhM7rQATartTn%2FM%3D&reserved=0> (~13min into the session) or https://datatracker.ietf.org/meeting/110/materials/slides-110-iotops-iot-device-management-with-lwm2m-00<https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F110%2Fmaterials%2Fslides-110-iotops-iot-device-management-with-lwm2m-00&data=04%7C01%7C%7C68992723f7fe4af3e8b008d9487641bb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637620495011559361%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SR1cEWt1fopW77Sw60q51TYYmJOrkBDI04s5nV0PqJw%3D&reserved=0>)

LwM2M uses many IETF protocols (see http://www.openmobilealliance.org/release/LightweightM2M/V1_2-20201110-A/<https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.openmobilealliance.org%2Frelease%2FLightweightM2M%2FV1_2-20201110-A%2F&data=04%7C01%7C%7C68992723f7fe4af3e8b008d9487641bb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637620495011559361%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=f4TAS0ElOj7mZCOTqgC7D9CpEledjQKZ9%2B2%2FaEZWi5o%3D&reserved=0>), such as CoAP plus various extensions, EST, TLS/DTLS, OSCORE, COSE, ....

Ciao

Hannes

---

From: gahar ana <[email-masked]>
Date: Fri, 16 Jul 2021 18:11:27 +0000

You are carbon and you send to us in your language, and I do not know it. This is why I must spread your news and who cooperated with you. Which country allowed this and how the news is. 500 companies are working in races to end devices and networks and violate privacy. I know that Saudi Arabia is with the Emirates and you have the task, but tell me what you publish and in what way and how all  Restrictions on my phone
All my phones and who is responsible for my family's phones

Sent from my Galaxy

-------- الرسالة الأصلية --------
من: Hannes Tschofenig <[email-masked]>
التاريخ: ١٦‏/٧‏/٢٠٢١ ٧:٢٥ م (GMT+03:00)
إلى: Rikard Höglund <[email-masked]>, [email-masked]
نسخة: "Gillmore, Matthew" <[email-masked]>
الموضوع: Re: [hackathon] LwM2M at the IETF hackathon

Thanks, Rikard.

Ciao
Hannes

Hello.

Best wishes
Rikard Höglund

Hi all,

Ciao

Hannes

---

From: "Gillmore, Matthew" <[email-masked]>
Date: Sat, 17 Jul 2021 02:00:49 +0000

All your Base are belong to us.

From: gahar ana <[email-masked]>
Sent: Friday, July 16, 2021 2:11 PM
To: Hannes Tschofenig <[email-masked]>; Rikard Höglund <[email-masked]>; [email-masked]
Cc: Gillmore, Matthew <[email-masked]>
Subject: [EXTERNAL] RE: [hackathon] LwM2M at the IETF hackathon

Sent from my Galaxy

-------- الرسالة الأصلية --------
من: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
التاريخ: ١٦‏/٧‏/٢٠٢١ ٧:٢٥ م (GMT+03:00)
إلى: Rikard Höglund <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
نسخة: "Gillmore, Matthew" <[email-masked]<mailto:[email-masked]>>
الموضوع: Re: [hackathon] LwM2M at the IETF hackathon

Thanks, Rikard.

Ciao
Hannes

From: Rikard Höglund <[email-masked]<mailto:[email-masked]>>
Sent: Friday, July 16, 2021 6:18 PM
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Gillmore, Matthew <[email-masked]<mailto:[email-masked]>>
Subject: Re: LwM2M at the IETF hackathon

Hello.

Best wishes
Rikard Höglund

[1] https://www.eclipse.org/leshan/<https://urldefense.com/v3/__https:/emea01.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.eclipse.org*2Fleshan*2F&data=04*7C01*7C*7C68992723f7fe4af3e8b008d9487641bb*7C84df9e7fe9f640afb435aaaaaaaaaaaa*7C1*7C0*7C637620495011539448*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=0dT8XzQKyaiA4m*2Bpbi8588AGwiNgrroKmzwTEr4Vi4c*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!F7jv3iA!ht0A8uRy858OuAnLHjl8bST4d_JTvCQn5XfAFS8EIIz5D7xhXd1Sahy8T9MUEgecAl3D$>
[2] https://www.eclipse.org/californium/<https://urldefense.com/v3/__https:/emea01.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.eclipse.org*2Fcalifornium*2F&data=04*7C01*7C*7C68992723f7fe4af3e8b008d9487641bb*7C84df9e7fe9f640afb435aaaaaaaaaaaa*7C1*7C0*7C637620495011539448*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=*2F6*2FJdwxvdJ0fH*2Fyj*2BuiE*2Bk1*2BJsAtG4omJ4af7fVbDvY*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!F7jv3iA!ht0A8uRy858OuAnLHjl8bST4d_JTvCQn5XfAFS8EIIz5D7xhXd1Sahy8T9MUEvMnW2f_$>
[3] https://github.com/eclipse/leshan/tree/oscore<https://urldefense.com/v3/__https:/emea01.safelinks.protection.outlook.com/?url=https*3A*2F*2Fgithub.com*2Feclipse*2Fleshan*2Ftree*2Foscore&data=04*7C01*7C*7C68992723f7fe4af3e8b008d9487641bb*7C84df9e7fe9f640afb435aaaaaaaaaaaa*7C1*7C0*7C637620495011549414*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=uhRjg6mGdEoCnAwSdiP8U9*2BR26y3X6ejy8VfnitDaD0*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!F7jv3iA!ht0A8uRy858OuAnLHjl8bST4d_JTvCQn5XfAFS8EIIz5D7xhXd1Sahy8T9MUEscSTP7a$>
________________________________
From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, June 26, 2021 15:16
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: Gillmore, Matthew <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] LwM2M at the IETF hackathon

Hi all,

(For a short intro please look at the recent presentation at the IoTOPS WG meeting, see https://www.youtube.com/watch?v=ZJN9IiQjcUk<https://urldefense.com/v3/__https:/emea01.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.youtube.com*2Fwatch*3Fv*3DZJN9IiQjcUk&data=04*7C01*7C*7C68992723f7fe4af3e8b008d9487641bb*7C84df9e7fe9f640afb435aaaaaaaaaaaa*7C1*7C0*7C637620495011549414*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=rwJQ9F4DCbuYnzpMskfv1g2ByamxmhM7rQATartTn*2FM*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!F7jv3iA!ht0A8uRy858OuAnLHjl8bST4d_JTvCQn5XfAFS8EIIz5D7xhXd1Sahy8T9MUEgErQ_Cw$> (~13min into the session) or https://datatracker.ietf.org/meeting/110/materials/slides-110-iotops-iot-device-management-with-lwm2m-00<https://urldefense.com/v3/__https:/emea01.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fmeeting*2F110*2Fmaterials*2Fslides-110-iotops-iot-device-management-with-lwm2m-00&data=04*7C01*7C*7C68992723f7fe4af3e8b008d9487641bb*7C84df9e7fe9f640afb435aaaaaaaaaaaa*7C1*7C0*7C637620495011559361*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=SR1cEWt1fopW77Sw60q51TYYmJOrkBDI04s5nV0PqJw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!F7jv3iA!ht0A8uRy858OuAnLHjl8bST4d_JTvCQn5XfAFS8EIIz5D7xhXd1Sahy8T9MUEvO9AA7O$>)

LwM2M uses many IETF protocols (see http://www.openmobilealliance.org/release/LightweightM2M/V1_2-20201110-A/<https://urldefense.com/v3/__https:/emea01.safelinks.protection.outlook.com/?url=http*3A*2F*2Fwww.openmobilealliance.org*2Frelease*2FLightweightM2M*2FV1_2-20201110-A*2F&data=04*7C01*7C*7C68992723f7fe4af3e8b008d9487641bb*7C84df9e7fe9f640afb435aaaaaaaaaaaa*7C1*7C0*7C637620495011559361*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=f4TAS0ElOj7mZCOTqgC7D9CpEledjQKZ9*2B2*2FaEZWi5o*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!F7jv3iA!ht0A8uRy858OuAnLHjl8bST4d_JTvCQn5XfAFS8EIIz5D7xhXd1Sahy8T9MUEqZug3QH$>), such as CoAP plus various extensions, EST, TLS/DTLS, OSCORE, COSE, ....

Ciao

Hannes