Subject: [hackathon] GNAP Interoperability Hackathon

From: Justin Richer <[email-masked]>
Date: Fri, 14 Jan 2022 11:42:36 -0500

For the IETF113 hackathon, the editors of the GNAP specification are proposing a project to get several different implementations of GNAP built and working with each other:

'''GNAP: Grant Negotiation and Authorization Protocol'''
   * Champion(s)
     * Justin Richer, Aaron Parecki, Fabien Imbault
   * Project(s)
     * Build and connect implementations of GNAP across different platforms. We plan to have implementations of the AS, Client, and RS available for people to extend and use, and to deploy against with other components.
     * Interop profile for the hackathon consists of the "redirect" interaction start method, the "redirect" interaction finish method, and key proofing provided by the combination of HTTP Signatures with RSA-PSS-SHA512 and a Content-Digest with SHA-512 hash (for requests with bodies).
     * Other modes (user-code, push) and signature methods (JWS) will be partially supported by some libraries and are encouraged.

 — Justin

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 14 Jan 2022 18:06:18 +0000

Hi Justin,

Thanks for bringing this project to the Hackathon and making it the first project added to the wiki!
Are there IETF drafts associated with the GNAP specification? If so, it would be helpful to add those to the project description in the wiki as well.

Cheers,
Charles

> On Jan 14, 2022, at 8:42 AM, Justin Richer <[email-masked]> wrote:
> 
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
> Unsubscribe: mailto:[email-masked]?subject=unsubscribe

---

From: Justin Richer <[email-masked]>
Date: Fri, 14 Jan 2022 13:30:07 -0500

Ok, I have done this now — https://www.ietf.org/archive/id/draft-ietf-gnap-core-protocol-08.html <https://www.ietf.org/archive/id/draft-ietf-gnap-core-protocol-08.html> is the core draft from the WG. This was my first time proposing a project for the hackathon, so apologies if I missed a few things. :)

 — Justin

> On Jan 14, 2022, at 1:06 PM, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> Hi Justin,
>

---

From: guest271314 <[email-masked]>
Date: Fri, 14 Jan 2022 17:27:22 -0800

Interesting. Native Messaging provides similar functionality, in browser
extensions. It would be useful if that data exchange could be achieved on
any site in spite of CSP and CORS or extension code.

On Fri, Jan 14, 2022 at 10:30 AM Justin Richer <[email-masked]> wrote:

> Ok, I have done this now —
> https://www.ietf.org/archive/id/draft-ietf-gnap-core-protocol-08.html is
> the core draft from the WG. This was my first time proposing a project for
> the hackathon, so apologies if I missed a few things. :)
>
>  — Justin
>
> Are there IETF drafts associated with the GNAP specification? If so, it
> would be helpful to add those to the project description in the wiki as
> well.
>
> Cheers,
> Charles
>
> For the IETF113 hackathon, the editors of the GNAP specification are
> proposing a project to get several different implementations of GNAP built
> and working with each other:
>
>    * Build and connect implementations of GNAP across different platforms.
> We plan to have implementations of the AS, Client, and RS available for
> people to extend and use, and to deploy against with other components.
>    * Interop profile for the hackathon consists of the "redirect"
> interaction start method, the "redirect" interaction finish method, and key
> proofing provided by the combination of HTTP Signatures with RSA-PSS-SHA512
> and a Content-Digest with SHA-512 hash (for requests with bodies).
>    * Other modes (user-code, push) and signature methods (JWS) will be
> partially supported by some libraries and are encouraged.
>
>
>
> — Justin
>