Subject: [hackathon] 2FA requirement on GitHub

From: Benson Muite <[email-masked]>
Date: Mon, 3 Jan 2022 20:30:09 +0300

Joining the Hackathon GitHub organization requires two factor 
authentication. The recommended applications in the current GitHub 
documentation do not mention that TOTP is based on an open IETF standard[1]:
https://docs.github.com/en/authentication/securing-your-account-with-two-factor-authentication-2fa/configuring-two-factor-authentication
My attempt to fix this seem to have failed[2].

As the IETF process is quite rigorous, the specification is one that 
many people can implement.[3][4][5]

Is there any certifying body for 2FA applications or requirements on 
TOTP authenticators for using to join the Hackathon GitHub organization?

[1] https://datatracker.ietf.org/doc/html/rfc6238
[2] https://github.com/github/docs/pull/11604
[3] https://github.com/Netthaw/TOTP-MCU
[4] https://github.com/lucadentella/TOTP-Arduino
[5] https://freeotp.github.io/

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 4 Jan 2022 08:40:50 +1300

Benson,
> documentation do not mention that TOTP is based on an open IETF standard[1]:

s/standard/document/

RFC6238 is not a standard.
"Status of This Memo

    This document is not an Internet Standards Track specification; it is
    published for informational purposes."

This doesn't change your underlying point, of course, but RFC1796.title.

    Brian

> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
> Unsubscribe: mailto:[email-masked]?subject=unsubscribe
>

---

From: Benson Muite <[email-masked]>
Date: Wed, 5 Jan 2022 12:26:02 +0300

>     published for informational purposes."
Thanks. GitLab 2FA documentation [6] does have a link to RFC6238

[6] 
https://docs.gitlab.com/ee/user/profile/account/two_factor_authentication.html