Subject: [hackathon] IETF ALTO WG hackathon project and participation

From: Jordi Ros Giralt <[email-masked]>
Date: Wed, 23 Feb 2022 14:04:23 +0000

Hi all,

The ALTO WG is starting an initiative to develop an open-source code base for the ALTO standard. During the upcomming IETF 113 Hackathon, we plan to do some initial work and demonstrations (see the ALTO project description in the Hackathon Wiki<https://trac.ietf.org/trac/ietf/meeting/wiki/113hackathon>). Our current team includes a small community of companies and universities participating in the ALTO WG as well as students from Yale University and Sichuan University. If anyone is interested in participating, please let me know by replying to this note.

Thank you.

Jordi

---

From: Muhammad Usman Bashir <[email-masked]>
Date: Thu, 24 Feb 2022 01:29:28 +0500

I am interested in the project.

On Wed, Feb 23, 2022 at 7:05 PM Jordi Ros Giralt <[email-masked]>
wrote:

> Hi all,
>
> The ALTO WG is starting an initiative to develop an open-source code base
> for the ALTO standard. During the upcomming IETF 113 Hackathon, we plan to
> do some initial work and demonstrations (see the ALTO project description
> in the Hackathon Wiki
> <https://trac.ietf.org/trac/ietf/meeting/wiki/113hackathon>). Our current
> team includes a small community of companies and universities participating
> in the ALTO WG as well as students from Yale University and Sichuan
> University. If anyone is interested in participating, please let me know by
> replying to this note.
>
> Thank you.
>
> Jordi
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
> Unsubscribe: mailto:[email-masked]?subject=unsubscribe
>

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 23 Feb 2022 21:39:02 +0000

Hello,

Will the stack be developed from scratch or there is something? If there is something what is the proposed license?

Thanks,

From: hackathon <[email-masked]> on behalf of Muhammad Usman Bashir <[email-masked]>
Date: Wednesday, February 23, 2022 at 12:30 PM
To: Jordi Ros Giralt <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [hackathon] IETF ALTO WG hackathon project and participation
I am interested in the project.

On Wed, Feb 23, 2022 at 7:05 PM Jordi Ros Giralt <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Thank you.

Jordi
_______________________________________________
hackathon mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hackathon
Unsubscribe: mailto:[email-masked]<mailto:[email-masked]>?subject=unsubscribe

---

From: [email-masked]
Date: Thu, 24 Feb 2022 20:55:36 +0800 (GMT+08:00)

Hi Reinaldo and all,

There are some projects where the hackathon can be based on. If you are developing something on top of these projects, I would recommend using the same or compatible licenses.

https://github.com/openalto/sextant  (EPL v1.0)

https://github.com/reservoirlabs/g2-mininet (Apache v2.0)

https://github.com/rucio/rucio (Apache v2)

Best,

Kai

-----Original Messages-----
From:"Reinaldo Penno (repenno)" <repenno=[email-masked]>
Sent Time:2022-02-24 05:39:02 (Thursday)
To: "Muhammad Usman Bashir" <[email-masked]>, "Jordi Ros Giralt" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [alto] [hackathon] IETF ALTO WG hackathon project and participation

Hello,

Thanks,

 

On Wed, Feb 23, 2022 at 7:05 PM Jordi Ros Giralt <[email-masked]> wrote:

Hi all,

The ALTO WG is starting an initiative to develop an open-source code base for the ALTO standard. During the upcomming IETF 113 Hackathon, we plan to do some initial work and demonstrations (see the ALTO project description in the Hackathon Wiki). Our current team includes a small community of companies and universities participating in the ALTO WG as well as students from Yale University and Sichuan University. If anyone is interested in participating, please let me know by replying to this note.

Thank you.

Jordi

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Fri, 25 Feb 2022 08:36:21 -0300

Nice initiative!

I always felt that hving reference client and server implementations
for ALTO would boost interest and adoption of the protocol.

I will present the hackathon topics to my students but unfortunately
we do not have any chance to participate on-site in this edition.

In the past we have done some ALTO research and produced some open
source work that may be of interest:

https://github.com/intrig-unicamp/alto-based-broker-assisted-mdo
https://github.com/intrig-unicamp/ALTO-as-a-Service

Thanks,
Christian

On Thu, Feb 24, 2022 at 9:58 AM <[email-masked]> wrote:
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto