Subject: [Hipsec] ¿Is there any linux based NAT/FW HIP aware version?

From: "Alejandro Parra Briones" <[email-masked]>
Date: Tue, 26 Jul 2005 15:01:07 -0600

Dear HIP comunity:
   I am a HIP newbie. I am a full time professor at a University in Mexico.
I have been reading the hip drafts. I am interested in the middle boxes problem.
I wonder if you have already working any NAT/FW HIP aware version. If not
I could help to make a prototype of a FW xor a NAT.

Regards
Alejandro Parra Briones
Centro de Investigacion en Informatica
CETEC 6to. Piso Torre norte

83284012

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Miika Komu <[email-masked]>
Date: Wed, 27 Jul 2005 00:51:23 +0300 (EEST)

> I could help to make a prototype of a FW xor a NAT.

See e.g.
http://www.ietf.org/internet-drafts/draft-tschofenig-hiprg-hip-natfw-traversal-02.txt
for the references for SPINAT. Please ask the authors for more
information.

InfraHIP is working on FW and NAT on Linux. Please send further queries
to "[email-masked]".

-- 
Miika Komu              [email-masked]          http://www.iki.fi/miika/

---

From: Andrei Gurtov <[email-masked]>
Date: Wed, 27 Jul 2005 22:03:04 +0300

I think it would be useful to have several implementations. Hence, it 
would be great if you can provide an open source NAT/FW traversal e.g. 
using  STUN, see http://openhip.sourceforge.net/develop.html

Andrei

---

From: Martin Stiemerling <[email-masked]>
Date: Sun, 31 Jul 2005 12:03:53 +0200

Hi Alejandro,

If you are interested on HIP across NAT and firewall you might consider
reading this draft too:

<http://www.ietf.org/internet-drafts/draft-stiemerling-hip-nat-05.txt>

This document is mainly discussed in the HIP research group.

  Martin

--On Dienstag, 26. Juli 2005 15:01 Uhr -0600 Alejandro Parra Briones 
<[email-masked]> wrote:

| Dear HIP comunity:
|    I am a HIP newbie. I am a full time professor at a University in
| Mexico. I have been reading the hip drafts. I am interested in the middle
| boxes problem. I wonder if you have already working any NAT/FW HIP aware
| version. If not I could help to make a prototype of a FW xor a NAT.
|
|
| Regards
| Alejandro Parra Briones
| Centro de Investigacion en Informatica
| CETEC 6to. Piso Torre norte
|
| 83284012
|
|
| _______________________________________________
| Hipsec mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/hipsec
|