Subject: [Hipsec] Conflicting text in RFC5201 - RFC5201-bis

From: Tobias Heer <[email-masked]>
Date: Wed, 26 May 2010 12:37:10 +0200

Hello, 

I have a question regarding some text in RFC5201 that conflicts with the crypto agility that we envisioned.
	
The new BEX will have to start the negotiations of the DH groups already in I1 to allow the Responder to pick a sensible DH group (there are simple countermeasures against downgrade attacks, too, so don't worry).
Therefore, the I1 becomes slightly more important than it was (although it stays unsigned and cheap).

In Section 4.1 RFC5201 states:

...
 705          The Initiator first sends a trigger packet, I1, to the 
 706          Responder.  The packet contains the HIT of the Initiator 
 707          and possibly the HIT of the Responder, if it is known. 
 708          Moreover, it contains a list of Diffie Hellman Group IDs 
 709          supported by the Initiator.  Note 
 710          that in some cases it may be possible to replace this trigger 
 711          packet by some other form of a trigger, in which case the 
 712          protocol starts with the Responder sending the R1 packet. 
...

With the DH group negotiations already starting in I1 it becomes difficult to omit the I1 (you can do it but you lose DH crypto agility).
Moreover, I doubt that omitting the I1 works well even without considering the DH group negotiations because some of the measures to keep the Responder stateless until I2 rely on having information from the I1 (IP address or HIT) for the puzzle/ opaque data field.

My questions are: 
Is anyone using or does anyone intent to use this omission of the I1?
Is there any specification on how to do it (at least this is the only place in 5201 where it is mentioned).
Do we need this feature because there are cases where you cannot send an I1?
And finally: can we live without that note?

Of course, even if we skip it there is nothing that will keep someone defining it as an extension to the base specs if it is needed in the future.

Thanks for any input.

Tobias

-- 
Dipl.-Inform. Tobias Heer, Ph.D. Student
Distributed Systems Group 
RWTH Aachen University, Germany
tel: +49 241 80 207 76
web: http://ds.cs.rwth-aachen.de/members/heer

---

From: Samu Varjonen <[email-masked]>
Date: Wed, 26 May 2010 13:59:25 +0300

> Is anyone using or does anyone intent to use this omission of the I1?

Check out draft-ietf-hip-hiccups-02 Section 5.3
"
    A host receiving a HIP DATA packet makes decision whether to process
    the packet or not.  If the host, following its local policy, suspects
    that this packet could be part of a DoS attack.  The host MAY respond
    with an R1 packet to the HIP DATA packet...
"