Subject: [Hipsec] Simultaneous end-host mobility & High availability for RVS servers(mechanism of backup RVS)

From: "HU Zhangfeng" <[email-masked]>
Date: Sun, 30 May 2010 17:06:11 +0800

hi all,
As you know, 1) the scenario of simultaneous end-host mobility maybe actually exist in real world, while it still has not been specified in HIP.  2) RVS servers in HIP functioning as HAs in MIP play very important roles for the management of mobile nodes. If a RVS server stops working, then all the mobile nodes managed by it should be lost in the network and cannot be re-managed any more before the mobile nodes re-register to a new RVS server. So a mechanism of backup RVS should be proposed to solve this problem.

I'm considering doing some work on both or either of the two above-mentioned topics, and I'm wondering if some ones have completed some work or got some achievement on both of them. Thank you.

2010-05-30 

Zhangfeng HU, phD candidate of
Broadband Network Research Center,
State Key Laboratory of Networking and Switching Technology, 
Beijing University of Posts and Telecommunications, Beijing, China

Email:[email-masked]
Tel:86+13811892137

---

From: Fabrice HOBAYA <[email-masked]>
Date: Sun, 30 May 2010 13:11:46 +0200

Hi Zhangfeng,

   1) FYI, with some colleagues, we have worked on the end host
simultaneous mobility in HIP. Here is our paper on this work where we
propose a first solution we have implemented with OpenHIP and
performed several preliminary tests.
http://ieeexplore.ieee.org/search/srchabstract.jsp?tp=&arnumber=5279586&queryText%3D%28Authors%3Ahobaya%29%26openedRefinements%3D*%26matchBoolean%3Dtrue%26searchField%3DSearch+All

   2) I have not worked on this topic but my colleagues have worked on
a home agent redundancy solution for MIP, may be some ideas could be
useful for the similar issue in HIP.
http://ieeexplore.ieee.org/search/srchabstract.jsp?tp=&arnumber=4976739&queryText%3D%28Authors%3Agay%29%26refinements%3D4293762425%26openedRefinements%3D*%26matchBoolean%3Dtrue%26searchField%3DSearch+All

We'd be happy to discuss about these issues with you. Feel free to
discuss/comment our works.

Best Regards,
Fabrice & al.

On 30 May 2010 11:06, HU Zhangfeng <[email-masked]> wrote:
> hi all,
> As you know, 1) the scenario of simultaneous end-host mobility maybe
> actually exist in real world, while it still has not been specified in HIP.
> 2) RVS servers in HIP functioning as HAs in MIP play very important roles
> for the management of mobile nodes. If a RVS server stops working, then all
> the mobile nodes managed by it should be lost in the network and cannot be
> re-managed any more before the mobile nodes re-register to a new RVS server.
> So a mechanism of backup RVS should be proposed to solve this problem.
>
> I'm considering doing some work on both or either of the two above-mentioned
> topics, and I'm wondering if some ones have completed some work or got some
> achievement on both of them. Thank you.
>
> 2010-05-30
> ________________________________
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec
>
>

-- 
Fabrice HOBAYA -- PhD student
CNES / Thales Alenia Space / TéSA
+335 34 35 41 12 - from monday to wednesday
+335 61 24 73 82 - from thursday to friday
[email-masked]