Subject: [Hipsec] Fwd: New Version Notification for draft-moskowitz-hip-hhit-registries-00.txt

From: Robert Moskowitz <[email-masked]>
Date: Fri, 13 Sep 2019 10:23:14 -0400

Greetings!

This is the second of the drafts I have been developing.  It provides 
the basics for the HHIT registrar activities.

I welcome all comments.

I am now working on the New crypto draft.  It is still drafty as there 
are a couple areas needing work.  This includes a KMAC approach to 
KEYMAT, replacing HMAC.  In fact KMAC completely replaces HMAC (much 
more efficient).

And the new cipher choice is Keyak.  For now.  How do we get the ESP 
transform number assigned?  What docs do we need for that?

I hope to have something ready for New crypto before Monday.

Bob

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-moskowitz-hip-hhit-registries-00.txt
Date: 	Fri, 13 Sep 2019 07:13:14 -0700
From: 	[email-masked]
To: 	Stuart Card <[email-masked]>, Adam Wiethuechter 
<[email-masked]>, Robert Moskowitz 
<[email-masked]>, Stuart W. Card <[email-masked]>

A new version of I-D, draft-moskowitz-hip-hhit-registries-00.txt
has been successfully submitted by Robert Moskowitz and posted to the
IETF repository.

Name: draft-moskowitz-hip-hhit-registries
Revision: 00
Title: Hierarchical HIT Registries
Document date: 2019-09-13
Group: Individual Submission
Pages: 11
URL: 
https://www.ietf.org/internet-drafts/draft-moskowitz-hip-hhit-registries-00.txt
Status: 
https://datatracker.ietf.org/doc/draft-moskowitz-hip-hhit-registries/
Htmlized: https://tools.ietf.org/html/draft-moskowitz-hip-hhit-registries-00
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-moskowitz-hip-hhit-registries

Abstract:
This document describes using the registration protocol and
registries to support hierarchical HITs (HHITs). New and existing
HIP parameters are used to communicate Registry Policies and data
about the HHIT device and the Registries. Further Registries are
expected to provide RVS services for registered HHIT devices.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jeff Ahrenholz <[email-masked]>
Date: Fri, 13 Sep 2019 15:48:27 +0000

> And the new cipher choice is Keyak.  For now.  How do we get the ESP transform
> number assigned?  What docs do we need for that?

Probably needs a short RFC, similar to this one?  https://tools.ietf.org/html/rfc4543

And this:  https://www.iana.org/protocols/apply

-Jeff

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 13 Sep 2019 11:57:25 -0400

> Probably needs a short RFC, similar to this one?  https://tools.ietf.org/html/rfc4543

Yes, but no AH.  Perhaps.  I have to read more on Keyak: 
https://keccak.team/keyak.html

> And this:  https://www.iana.org/protocols/apply

Tero does the expert review on any IPsec additions.