Subject: [hops] Fwd: measurement platforms and their capabilities (previously was HOPS bar bof notes)

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 6 Aug 2015 11:47:51 +0200

Hi all,

there was a request for an overview/survey paper on measurement platforms in the meeting. I just realized that this pointer was already posted on the hops list a while ago (see below).

We, as chairs, will start a Wiki (soon) to collect information about measurement platforms as well as measurement tools (and take this as a starting point). 

Let us as well as the group know if you have further knowledge about this kind of overview papers or similar things by posting a pointer on the list!

Mirja

> Anfang der weitergeleiteten Nachricht:
> 
> Von: "Bajpai, Vaibhav" <[email-masked]>
> Betreff: [hops] measurement platforms and their capabilities (previously was HOPS bar bof notes)
> Datum: 7. April 2015 09:30:59 MESZ
> An: "[email-masked]" <[email-masked]>
> Kopie: "Bajpai, Vaibhav" <[email-masked]>, Aaron Falk <[email-masked]>
> 
> Dear hops,
> 
>> On 23 Mar 2015, at 18:51, Aaron Falk <[email-masked]> wrote:
> 
> [...]
> 
>> Test infrastructure
>> 	• AI: group to share on the list what measurement (platforms) exists and what capabilities they have
> 
> Early discussions within LMAP [1] also often lead to folks asking for feature
> sets and possibilities of each contemporary performance measurement platform.
> So we started digging literature work in this space and found that although
> there were surveys on topology-based measurement platforms (such CAIDA Ark
> and DIMES); literature work on performance measurement platforms (such RIPE
> Atlas, SamKnows and BISmark) was missing.
> 
> Therefore, we started writing such a survey in 2013 to plug this gap. This
> work got published this week. Thought would share this with you.
> 
> Hope it helps.
> 
> ----------------8<-----------------8<-----------------8<-----------------8<
> A Survey on Internet Performance Measurement Platforms and Related Standardization Efforts
> Vaibhav Bajpai, Jürgen Schönwälder
> IEEE Communications Surveys & Tutorials
> April, 2015
> 
> A number of Internet measurement platforms have emerged in the last few years.
> These platforms have deployed thousands of probes at strategic locations
> within access and backbone networks and behind residential gateways. In this
> paper we provide a taxonomy of these measurement platforms on the basis of
> their deployment use-case. We describe these platforms in detail by exploring
> their coverage, scale, lifetime, deployed metrics and measurement tools,
> architecture and overall research impact. We conclude the survey by describing
> current standardization efforts to make large-scale performance measurement
> platforms interoperable.
> 
> DOI: http://dx.doi.org/10.1109/COMST.2015.2418435
> Author Copy: http://vaibhavbajpai.com/documents/papers/proceedings/lsmp-comst-2015.pdf
> ----------------8<-----------------8<-----------------8<-----------------8<
> 
> Thanks!
> 
> [1] https://datatracker.ietf.org/wg/lmap
> 
> Best, Vaibhav
> 
> =====================================================
> Vaibhav Bajpai
> 
> Research I, Room 91
> Computer Networks and Distributed Systems (CNDS) Lab
> School of Engineering and Sciences
> Jacobs University Bremen, Germany
> 
> www.vaibhavbajpai.com
> =====================================================
> _______________________________________________
> hops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hops

---

From: Joachim Fabini <[email-masked]>
Date: Thu, 6 Aug 2015 14:16:25 +0200

Hi Mirja, all

we can contribute some methodological findings and advances in one-way
delay measurements.

Background: Today's networks have evolved to complex, stateful systems
(at layers below IP). It's time to question the stateless copper wire
model, the main abstraction on which our algorithms, applications, and
measurements rely. We can improve measurement methodologies to better
capture the behavior of networks and to find out where the limits of
measurements are.

Concerning the hops charter: from an end-to-end perspective it's very
hard to differentiate if systematic impairments have been caused by a)
network operation and coding at lower layers and b) middlebox actions
(unless these middleboxes modify network, transport- or application
header values). In other words, it is difficult to draw a line between
network scheduling, policing and middlebox behavior that directly
affects the extensibility of the Internet. Aggregation and interaction
of subsequent links in a path complicate matters even more.
The main point is that accurate delay measurements can detect (some?)
network elements on the path that maintain state. And these are
potential/ideal candidates for substantially touching other layers, too.

If there is interest in hops I can present some slides at the next
meeting @ IETF94 (online or offline, depending on travel/time budget).
My feeling is that the findings can support some of the ongoing projects
(RIPE, Monroe).

Some related publications (please drop me a note if you need a personal
copy):
http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=6553584
http://dl.acm.org/citation.cfm?id=2747654
http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=7151564
and, of course: https://tools.ietf.org/html/rfc7312

Joachim

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 6 Aug 2015 15:09:16 +0200

Hi Joachim,

this certainly sounds interesting and thanks for sending the pointers. We will keep you in mind for the next meeting. We will probably send out an email a couple weeks before the meeting to ask for additional agenda requests. Just in case we didn’t contact you again at this point of time, please reply to that mail and request a presentation (again).

It seems like this is in scope and if you have data to share that’s great!

Mirja

> Am 06.08.2015 um 14:16 schrieb Joachim Fabini <[email-masked]>:
> 
> Hi Mirja, all
>