Subject: Re: [http-extensions] Updated encryption examples (#158)

From: HTTP issue updates <[email-masked]>
Date: Mon, 14 Mar 2016 16:45:27 -0700

> @@ -359,13 +359,13 @@ header field.
>  
>  aesgcm:
>  
> -: The "aesgcm" parameter contains the URL-safe base64 [RFC4648] octets of the
> -input keying material.
> +: The "aesgcm" parameter contains the URL and filename safe base64 [RFC4648]
> +  octets of the input keying material with padding removed.

Well, it turns out that '=' is an invalid character unless you quote the string.  I think that we should be strict here.  I believe that Firefox is, but I could be wrong about that.

---
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/158/files#r56095628

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 15 Mar 2016 06:17:44 -0700

> +  octets of the input keying material with padding removed.

I'll change Chrome to play ball then.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/158/files#r56160068

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 15 Mar 2016 06:18:20 -0700

> @@ -598,6 +629,28 @@ added for presentation purposes only.
>  ~~~
>  
>  
> +## Diffie-Hellman with Authentication Secret {#ex-authSecret}
> +
> +This example shows the same receiver key pair from {{ex-dh}}, but with a shared
> +authentication secret of "R29vIGdvbyBnJyBqb29iIQ".
> +
> +~~~
> +HTTP/1.1 200 OK
> +Content-Length: 33
> +Content-Encoding: aesgcm
> +Encryption: keyid="dhkey"; salt="lngarbyKfMoi9Z75xYXmkg"
> +Crypto-Key: keyid="dhkey";
> +                dh="BNoRDbb84JGm8g5Z5CFxurSqsXWJ11ItfXEWYVLE85Y7
> +                    CYkDjXsIEc4aqxYaQ1G8BqkXCJ6DPpDrWtdWj_mugHU"
> +
> +6nqAQUME8hNqw5J3kl8cpVVJylXKYqZOeseZG8UueKpA

Confirmed! Thanks.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/158/files#r56160125

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 16 Mar 2016 17:57:14 -0700

Merged manually

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/158#issuecomment-197626565

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 16 Mar 2016 17:57:15 -0700

Closed #158.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/158#event-592731027