Subject: Re: [http-extensions] Define more precisely which CH headers are sent by default (#156)

From: HTTP issue updates <[email-masked]>
Date: Tue, 22 Mar 2016 14:49:48 -0700

Yes, that seems like a good approach. And yes, CH needs to define how to parse and set the "client hints policy". Or at least some spec needs to before CH is implementable.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-200045915

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 22 Mar 2016 17:50:47 -0700

So, Fetch gets updated every time a new hint is defined?

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-200097319

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 22 Mar 2016 18:01:35 -0700

Do we have an easy way of identifying them as hints so that it would be unnecessary to do that?

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-200099616

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 22 Mar 2016 19:41:09 -0700

I think it's OK if every time we create a new hint, we update Fetch (based on the anticipated number / volume).

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-200140157

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 22 Mar 2016 21:13:32 -0700

In which case, the remaining question is: @annevk are you comfortable (re, https://github.com/whatwg/fetch/pull/258) with integrating this as part of Fetch? I'm happy to draft the update. Alternatively, I guess I can try and monkey patch it from CH spec, but that's far less appealing..

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-200165644

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 23 Mar 2016 01:00:41 -0700

Yeah, I am. It seems @hsivonen still has concerns with this entire feature, but if Mozilla will ship regardless (?) it sounds like that would be a good way to define all the edge cases here.

Another way to do this would be to patch the HTML Standard to set these headers as appropriate. Though the HTML Standard, especially the navigate algorithm, still needs some work done so perhaps it's better to use Fetch (at least for now).

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-200236296

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 30 Mar 2016 16:10:52 -0700

If anyone wants to follow along: https://github.com/whatwg/fetch/pull/258 -- initial run at integrating CH and Fetch.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/156#issuecomment-203677084