Subject: [httpwg/http-extensions] save-data extensibility (#168)

From: HTTP issue updates <[email-masked]>
Date: Mon, 04 Apr 2016 12:41:47 -0700

I understand that the current method has the save-data aspect of client hints as a simple on/off switch.  I wonder, though, about the willingness to consider allowing for some extensibility.  Right now, someone saying "save-data=on" is signing up for pretty much anything.   Separating acceptance of data saving for different elements, e.g. agreeing to smaller video resources but not lower fidelity audio, seems like it may be useful.  I suggest that the working group consider making this an extensible field with "save-date=all" as the default, with semantics matching the current "save-data=on".  Then later extensions can be specified for more granular statements.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 06 Apr 2016 11:15:48 -0700

I think we can already achieve this with current definition:

- We can define other tokens
- We can define parameters - e.g. "on;video-only", etc.

Changing from "on" to "all" doesn't really change anything. Also, we already have both client and server implementations that are relying on "on". 

_p.s. some background: https://github.com/igrigorik/http-client-hints/pull/63/commits/e8bafcf5702e23a4052905137a741274e80d602b_

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-206500218