Subject: Re: [httpwg/http-extensions] make Save-Data extensible (#179)

From: HTTP issue updates <[email-masked]>
Date: Wed, 25 May 2016 19:01:33 -0700

> @@ -247,10 +247,13 @@ If Downlink occurs in a message more than once, the minimum value should be used
>  The "Save-Data" request header field is a token that indicates client's preference for reduced data usage, due to high transfer costs, slow connection speeds, or other reasons.
>  
>  ~~~ abnf7230
> -  Save-Data = "on"
> +  Save-Data = "Save-Data" ":" sd-token *( ";" [ sd-parameter ] )
> +
> +  sd-token = "on"
> +  sd-parameter = token

Convention is to name this sort of thing "sd-extension" or similar.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/179/files/b82532fbb3b6d089c9207fd60f1ba1e5c388bda1#r64682138

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 25 May 2016 21:29:25 -0700

@mnot thanks, updated! getting warmer? 

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/179#issuecomment-221774734

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 27 May 2016 08:15:43 -0700

>  ~~~
>  
> -The "on" token is a signal indicating explicit user opt-in into a reduced data usage mode on the client, and when communicated to origins allows them to deliver alternate content honoring such preference - e.g. smaller image and video resources, alternate markup, and so on.
> +The "on" token is a signal indicating explicit user opt-in into a reduced data usage mode on the client, and when communicated to origins allows them to deliver alternate content honoring such preference - e.g. smaller image and video resources, alternate markup, and so on. Future versions of this specification may define other token values.
>  
>  

"New extension tokens can only be defined by revisions of this specification".

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/179/files/b82532fbb3b6d089c9207fd60f1ba1e5c388bda1..9e24d4b50810eddddccc845d208b623fc2a40665#r64920587

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 27 May 2016 08:46:59 -0700

@reschke @mnot thanks. Updated, do you want to do a last sanity check before I merge?     

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/179#issuecomment-222181984

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 31 May 2016 03:25:51 -0700

Looks good to me.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/179#issuecomment-222650298