Subject: Re: [httpwg/http-extensions] save-data extensibility (#168)

From: HTTP issue updates <[email-masked]>
Date: Tue, 03 May 2016 08:45:26 -0700

I think the parameter method would be quite useful, and if the doc describes that it would be useful.  I'm less sanguine about introducing parameters later, but I certainly wouldn't fall on any sharp objects if that were the decision of the WG.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-216571729

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 04 May 2016 09:36:22 -0700

I guess we _should_ clarify that it is extensible and define "on" as one of its recognized values...

```
Save-Data = "Save-Data" ":" save-data-token *( ";" [ token ] )
            save-data-token = "on"
```

Does that make sense? I'm sure my ABNF is off.. :)

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-216922587

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 04 May 2016 11:23:01 -0700

On Wed, May 4, 2016 at 9:36 AM, Ilya Grigorik <[email-masked]>
wrote:

> I guess we *should* clarify that it is extensible and define "on" as one
> of its recognized values...
>
> Does that make sense?
That does make sense.  I think you need a way to define how someone gets a
token value created, and then register "on" as the first token value.

regards,

Ted

> I'm sure my ABNF is off.. :)
>
> —
> You are receiving this because you were mentioned.
> Reply to this email directly or view it on GitHub
> <https://github.com/httpwg/http-extensions/issues/168#issuecomment-216922587>
>

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-216955806

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 31 May 2016 09:19:11 -0700

Is there a reason to use semicolon here instead of the more typical comma?

Also, the grammar does seem off: it does not allow whitespace (because the “implicit `*LWS`” rule of RFC 2616 no longer applies), and it uses `:` instead of `=`. Assuming you really want semicolons, I think it should be:

         Save-Data = sd-token *( OWS ";" OWS [sd-token] )

(I can file a separate issue if you want)

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-222740727