Subject: Re: [httpwg/http-extensions] Wildcard names (#178)

From: HTTP issue updates <[email-masked]>
Date: Mon, 30 May 2016 22:19:10 -0700

Thinking out loud, what about two new flags:

* `INHERIT` - if true, we assume that all origins implied by the presented cert are usable on this connection.
* `NOT` - if true, the origins in the frame are subtracted from the set of origins usable on this connection.

In conjunction, that would give more flexibility (and brevity) than wildcards, and be easier to process (is just strings). Would have to work out the interaction with the certs draft tho.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/178#issuecomment-222594607

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 30 May 2016 22:55:19 -0700

The implication being that if both were specified, you would be saying "what is in my cert, except these things".

If we do something like `NOT`, then the implication is that there is an existing understanding of the set of origins that are active.  That would need careful definition, and maybe a `RESET` flag so that you can incrementally modify the set in the common case, but set back to baseline as you see fit.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/178#issuecomment-222598529

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 30 May 2016 23:00:38 -0700

Yup, pretty much.

NOT also allows me to pare away origins in a long-lived connection (e.g., for load balancing).

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/178#issuecomment-222599165

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 30 May 2016 23:02:11 -0700

Oh, that's devious, it's like alt-svc without the actual useful parts.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/178#issuecomment-222599348