Subject: [httpwg/http-extensions] Missing OWS in encryption_params and crypto_key_params (#194)

From: HTTP issue updates <[email-masked]>
Date: Tue, 07 Jun 2016 02:45:41 -0700

`draft-ietf-httpbis-encryption-encoding.md`:

>      encryption_params = [ parameter *( ";" parameter ) ]

>      crypto_key_params = [ parameter *( ";" parameter ) ]

These rules do not permit whitespace between a semicolon and a parameter, which was probably intended (judging from the examples and from similar rules elsewhere in HTTP). They should be rewritten as follows:

>      encryption_params = [ parameter *( OWS ";" OWS parameter ) ]

>      crypto_key_params = [ parameter *( OWS ";" OWS parameter ) ]

and the import of the `OWS` rule from RFC 7230 should be noted in the preceding text (“The "Encryption" header field uses the extended ABNF syntax . . .” and similarly for `Crypto-Key`).

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/194

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 21 Jun 2016 23:28:43 -0700

Closed #194 via #197.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/194#event-700035918