Subject: Re: [httpwg/http-extensions] Separate lifetime from commitment element (#162)

From: HTTP issue updates <[email-masked]>
Date: Mon, 06 Jun 2016 21:16:13 -0700

Not sure we closed the original issue here - confirm?

~~~
{
  "http://example.com": {
    "tls-ports": [443]
  },
  "http://www.example.com:81": {
    "tls-ports": [],
    "tls-commit": true
  }
  "http:/other.example.com": {
    "tis-ports": [443,8080],
    "tls-commit": true
  }
}
~~~

With some sort of lifetime mechanism. That could be a `lifetime` member, or it could be HTTP caching freshness lifetime.

If we have a `lifetime` member, I think we have to either a) require it on EVERY origin, or b) fall back to HTTP caching freshness lifetime.

I know my preference. @martinthomson?

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/162#issuecomment-224170518

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 06 Jun 2016 21:16:14 -0700

Reopened #162.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/162#event-683849494

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 08 Jun 2016 17:19:49 -0700

That's what's currently in the spec; see straw-man I made before you said "that works".

The problem is that doing so doesn't seem to address the original issue here.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/162#issuecomment-224769664