Subject: Re: [httpwg/http-extensions] Client Hints: Accept-CH html meta http-equiv (#189)

From: HTTP issue updates <[email-masked]>
Date: Wed, 01 Jun 2016 14:36:29 -0700

> Q: does the SHOULD also apply to the HTML http-equiv variant?

Yes. Is there a common term we can use here to refer to both the header field value and attribute value?

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/189#issuecomment-223132409

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 01 Jun 2016 22:47:59 -0700

Well, that implies that every user agent SHOULD parse HTML and process <meta> elements. Is this a realistic requirement?

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/189#issuecomment-223201239

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 03 Jun 2016 10:47:58 -0700

From: https://lists.w3.org/Archives/Public/ietf-http-wg/2016AprJun/0322.html

> This "all subsequent requests" is obviously intended to be qualified
> somehow. It's not "all requests to all servers ever", is it? Should it
> be "all subsequent requests to the same origin"? Should it be "all
> subsequent requests to this resource"?
>
> Likewise, the "SHOULD append" phrase is unclear: append to what exactly?

How about...

> When a client receives Accept-CH, or if it is capable of processing the HTML response and finds an equivalent HTML meta element, it SHOULD append the Client-Hint header fields that match the advertised field-values to the header list of all subsequent requests. For example, based on Accept-CH example above, a user agent could append DPR, Width, Viewport-Width, and Downlink header fields to all subresource requests initiated by the page constructed from the response. Alternatively, a client may remember the preference at origin level and advertise same header fields on all future requests initiated to and by the resources associated with that origin.

In other words, it's not the intent of this spec to spell out a specific behavior, we leave that to the client.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/189#issuecomment-223646386

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 03 Jun 2016 10:56:00 -0700

SGTM, where "may" ought to be "MAY" or "can".

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/189#issuecomment-223648336

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 03 Jun 2016 11:22:07 -0700

Thanks, updated in https://github.com/httpwg/http-extensions/pull/190. 

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/189#issuecomment-223654955