Subject: Re: [httpwg/http-extensions] Address feedback on client-hints-01 draft (#190)

From: HTTP issue updates <[email-masked]>
Date: Tue, 07 Jun 2016 08:52:56 -0700

> @@ -143,12 +143,11 @@ For example:
>    Accept-CH: DPR, Width, Viewport-Width, Downlink
>  ~~~
>  
> -When a client receives Accept-CH, it SHOULD append the Client Hint header fields that match the advertised field-values. For example, based on Accept-CH example above, the client would append DPR, Width, Viewport-Width, and Downlink header fields to all subsequent requests.
> -
> +When a client receives Accept-CH, or if it is capable of processing the HTML response and finds an equivalent HTML meta element, it SHOULD append the Client-Hint header fields that match the advertised field-values to the header list of all subsequent requests. For example, based on Accept-CH example above, a user agent could append DPR, Width, Viewport-Width, and Downlink header fields to all subresource requests initiated by the page constructed from the response. Alternatively, a client may treat advertised support as a persistent origin preference and append same header fields on all future requests initiated to and by the resources associated with that origin.
>  

s/may treat/can treat/

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/190/files/844d299b10a07b94a9d15c659f78ac6b7d2435ad#r66098734

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 07 Jun 2016 08:53:34 -0700

> @@ -244,10 +243,10 @@ If Downlink occurs in a message more than once, the minimum value should be used
>  
>  # The Save-Data Client Hint {#save-data}
>  
> -The "Save-Data" request header field is a token that indicates client's preference for reduced data usage, due to high transfer costs, slow connection speeds, or other reasons.
> +The "Save-Data" request header field is one or more tokens that indicate client's preference for reduced data usage, due to high transfer costs, slow connection speeds, or other reasons.
>  
>  ~~~ abnf7230

maybe "consists of"  instead of "is"?

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/190/files/844d299b10a07b94a9d15c659f78ac6b7d2435ad#r66098848