Subject: Re: [httpwg/http-extensions] Provide rules for handling duplicate keys (#205)

From: HTTP issue updates <[email-masked]>
Date: Wed, 29 Jun 2016 22:03:05 -0700

> @@ -171,6 +171,12 @@ Connection: close
>  }
>  ~~~
>  
> +The JSON format for the http-opportunistic resource makes it possible to include multiple values
> +for the same origin.  Variations in case allow for duplicate keys that a JSON parser will treat
> +as different.  Duplicated keys might not be detected by a client (see Section 4 of {{RFC7159}}).
> +A client SHOULD NOT use origin objects if multiple keys match, though it MAY use any origin
> +object with a matching key.
> +

The SHOULD NOT might not be implementable if the parser doesn't report the fact...

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/205/files/4cfbeba2412caceb5e12e32c1ed61dde884f4d35#r69069747

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 29 Jun 2016 22:45:29 -0700

> +object with a matching key.

That's why it's a SHOULD NOT and not MUST NOT.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/205/files/4cfbeba2412caceb5e12e32c1ed61dde884f4d35#r69074049