Subject: Re: [httpwg/http-extensions] save-data extensibility (#168)

From: HTTP issue updates <[email-masked]>
Date: Wed, 01 Jun 2016 03:36:30 -0700

I wouldn't say comma is "typical" -- it depends a bit on the use case. For instance, alt-svc uses a list of comma-delimited directives, each of which can have semicolon delimited parameters.

In any case, if this does not use commas, the spec ought to state what happens when commas turn up in a field value, or if a field occurs multiple times in a messages (this is stated for the other client hints).

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-222955547

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 01 Jun 2016 14:29:44 -0700

> I wouldn't say comma is "typical" -- it depends a bit on the use case. For instance, alt-svc uses a list of comma-delimited directives, each of which can have semicolon delimited parameters.

That, indeed, was the intent - e.g. "on;video-only". 

Re, OWS: good catch. Addressed in https://github.com/httpwg/http-extensions/pull/190.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/168#issuecomment-223130655