Subject: Re: [httpwg/http-extensions] JFV + ECMA-262 (#225)

From: HTTP issue updates <[email-masked]>
Date: Wed, 12 Oct 2016 09:41:57 -0700

> FWIW, another plausible thing to do would be to require conformance to the I-JSON profile (see https://tools.ietf.org/html/rfc7493).

@reschke that's effectively what we proposed above.. ECMA-262 and I-JSON dictate same rules for number encoding?

---

@clelland @esprehn fyi... phk put together a rough draft of his (alternative) proposal: 
- https://lists.w3.org/Archives/Public/ietf-http-wg/2016OctDec/0099.html
- https://datatracker.ietf.org/doc/draft-kamp-httpbis-structure/ 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/225#issuecomment-253268449

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 12 Oct 2016 22:23:41 -0700

easier to specify from an IETF spec :-).

At the end of the day, we'll forbid sending duplicate keys anyway, right? The difference is just how the recipient handles those (complain vs last wins)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/225#issuecomment-253417238

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 13 Oct 2016 08:29:05 -0700

> At the end of the day, we'll forbid sending duplicate keys anyway, right? The difference is just how the recipient handles those (complain vs last wins)

Right. I got internal pushback earlier on special-casing this in our JSON parser (to ignore+complain).. last-wins is simple and consistent with the rest of the (browser) platform.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/225#issuecomment-253548016

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 17 Oct 2016 13:53:10 -0700

Yeah we don't want to have two versions of the JSON parser. So whatever this spec says should agree with 262.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/225#issuecomment-254330628