Subject: Re: [httpwg/http-extensions] [6265bis] Add double-keying policy example to "Third-party cookies" section (#248)

From: HTTP issue updates <[email-masked]>
Date: Tue, 11 Oct 2016 22:46:41 -0700

Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/248#issuecomment-253125079

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 12 Oct 2016 04:49:54 -0700

Better than that, in Firefox we have the ability to segment/compartmentalize based on user categorization of tabs (which uses the same underlying mechanism, which we call origin attributes; "extended origin" was already taken).

That means that there are multiple criteria that we might use to partition cookies: primary origin, top-level browsing context origin, "container", user profile, etc...  Maybe this needs to be a even more generic:

> Clients might refuse to process cookies or segregate cookies based on context.  This might be done to prevent correlation of requests between separate contexts.  For instance, cookies sent to a browser in a third-party context might be separated based on the first-party context.

(Your words are likely to be better here.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/248#issuecomment-253192418