Subject: Re: [httpwg/http-extensions] Client hints: add support for hinting Display Gamut / Color Profile (#263)

From: HTTP issue updates <[email-masked]>
Date: Tue, 08 Nov 2016 00:29:52 -0800

The spec is past WGLC, so adding new hints right now might be bad timing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/263#issuecomment-259075398

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 21 Nov 2016 00:43:11 -0800

@igrigorik Exactly. 
Still the poll numbers are not high but we can expect them to go wild next year since most manufactured displays are now wide-color. We can expect something alike to the Retina/Non-Retina race revolution. 

> Color-Gamut + Content-Color-Gamut: I think this makes sense.

Yes, this would cover 95% of use cases, and spec-wise it should be simple enough. 

So, even for simple cases, this CH spec addition is close to a `MUST` for responsive color optimisation. Why? Because `wide-gamut` is one of things those things that cannot even be guessed by *User Agent*: there is no info about the display on the string. So this spec is gonna be the only way to advertise to the server in an automated way.

> @color-profile.. I'm still trying to grok. From what I can tell right now, it accepts a URL to a profile, plus a rendering intent. Do we have some concrete examples of how we expect developers to use this?
Yes, I agree the use cases for `color-profile` are few, thus I don't see this one as `MUST`, however a `nice to have` one.

The use cases I see for this are minor but:
1) To override a photo ICC profile (ie. it was wrong in the first place)
2) To specify a ICC profile for a photo that had ICC stripped - or didn't had one in the first place (ie. it was removed by some "optimisation" tool like [jpegoptim](http://www.kokkonen.net/tjko/src/man/jpegoptim.txt) or [ImageOptim](https://imageoptim.com/color-profiles.html))

So yeah I can guess mostly photographer / design websites would make use of this one.
Note that, at least [CSS Level 4](https://www.w3.org/TR/css-color-4/#at-ruledef-profile), doesn't need to include the URL for the profile since its predefined in two cases: `DCI-P3` and `Rec.2020`.

> Does this prevent us from publishing a new "replacement" draft? How do we advance these things forward?

I don't know about this *WG particular timing interests*,
however having `Color-Gamut + Content-Color-Gamut` in the spec as soon as possible would give Browser vendors enough time and pave the way to implement it smoothly. 
Be either an addition to CH or a different spec. For **consistency** it makes sense to be a part of the CH spec though, just like `DPR`.

I can understand well why some don't see the *urge for it*: 
you need to have a `wide-color` hardware first to *see* the need, 
but we can be sure that almost **any smartphone or computer display that you get in 2017 is gonna be a `wide-color` one**.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/263#issuecomment-261876846

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 21 Nov 2016 14:15:33 -0800

Just to be clear -- there's no guarantee that the WG will adopt such a document; it depends on getting consensus to adopt, which in turn often depends on implementer interest. That's not to dissuade you from writing a document; however, the next logical step would be to engage with implementers (probably, Chrome) to see if they want to support it, not to create a standard in hopes of getting it implemented.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/263#issuecomment-262084829