Subject: [httpwg/http-extensions] Record size (rs) should be of ciphertext, not padded-plaintext (#274)

From: HTTP issue updates <[email-masked]>
Date: Tue, 06 Dec 2016 23:37:44 -0800

It would be better to define the 'rs' (record size) parameter as the size of each ciphertext record (including the 16 byte tag for AEAD_AES_128_GCM).

That way a receiver can split the body into records without needing to add the algorithm-specific tag length. Then pass the bytes to a crypto library that does know details such as the tag length for a given alg.

This spec doesn't absolutely need alg agility as other algs would define their own content-encoding label. But it would be cleaner (& safer) if future algs could follow exactly the same pattern and same body format by simply defining a new content-encoding label. The format is very close, with the need to add 16 to 'rs' being the only wart.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/274

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 22 Dec 2016 04:20:40 -0800

Yes, I will define it this way.  Forgot to tag this correctly, so I missed it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/274#issuecomment-268788704