Subject: Re: [httpwg/http-extensions] define `cache-digest` header in appendix (#341)

From: HTTP issue updates <[email-masked]>
Date: Wed, 10 May 2017 22:17:47 -0700

mnot commented on this pull request.

> @@ -263,8 +276,8 @@ we can determine whether there is a match in the digest using the following algo
 
 # IANA Considerations
 
-This draft currently has no requirements for IANA. If the CACHE_DIGEST frame is standardised, it
-will need to be assigned a frame type.
+This draft currently has no requirements for IANA.
+If the specification is standardised, the CACHE_DIGEST frame will need to be assigned a frame type and the Cache-Digest header will need to be registered.

I'm afraid this isn't adequate; if an RFC -- even an experimental one -- defines a header, it really needs to register it. I can do a separate PR if you like.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/341#pullrequestreview-37484938

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 24 May 2017 23:37:12 -0700

Merged #341.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/341#event-1096816572

---

From: HTTP issue updates <[email-masked]>
Date: Sat, 27 May 2017 06:36:28 -0700

@kazuho Would it make sense to also describe the cookie-based method in this spec?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/341#issuecomment-304452000

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 28 May 2017 17:55:06 -0700

While we could do that, I am kind of negative against it.

We need a specification for Cache-digest using HTTP/2 frames or HTTP/1 headers, since it needs to be defined as an interaction between a server and a client (that has the knowledge of what is being cached).

OTOH, we do not need a specification for a Cache-Digest cookie, since it is totally controlled by the server. So it is entirely up to each server implementation to use whatever format it wants. Also, it is not easy to find out the right way to implement a cookie-based Cache-Digest that would work on all web browsers, since the timing the browser consumes the cookies sent from the server depend on the timing of the response.

To summarize, the relatively low necessity and the technical difficulty makes me hesitate in pursuing the idea.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/341#issuecomment-304551723