Subject: Re: [httpwg/http-extensions] Incomplete responses and immutable (#325)

From: HTTP issue updates <[email-masked]>
Date: Tue, 02 May 2017 12:26:14 -0700

I think we ought to close this issue as not relevant in any special way to immutable.

The issue you are talking about is that conditional reloads do not work for fixing corrupted content because they re validate headers and not the corrupted content. The presence of immutable doesn't really matter to that equation - all it does is bypass a conditional request that wasn't working right anyhow because it is unaware the corruption is in the message body. You can insert this proposed rule to 'fix' that, but it doesn't fix all the resources without immutable that have the same problem for the same reason. The problem has nothing to do with immutable.

I could support a rule for all resources that says clients SHOULD NOT issue a conditional revalidation when the stored response is potentially corrupted (i.e. they should do force reloads) - indeed that's firefox policy. but its not really immutable specific.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-298735756

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 02 May 2017 18:55:05 -0700

Fair enough. I'll raise an issue on the http11bis repo.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-298806996

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 02 May 2017 18:55:08 -0700

Closed #325.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#event-1066570526