Subject: Re: [httpwg/http-extensions] Intermediaries need to be consistent too (#408)

From: HTTP issue updates <[email-masked]>
Date: Wed, 27 Sep 2017 17:10:56 -0700

mnot commented on this pull request.

> @@ -251,9 +251,11 @@ Early-Data: 1
 
 ~~~
 
-An intermediary that forwards a request received in TLS early data MUST send it
-with the `Early-Data` header field set to "1" (i.e., it adds it if not present
-in the request).
+An intermediary that forwards a request prior to the completion of the TLS
+handshake MUST send it with the `Early-Data` header field set to "1" (i.e., it
+adds it if not present in the request).  This is also true if the intermediary

s/true/required/? But if that's the case, it should really be a REQUIREMENT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/408#pullrequestreview-65722287

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 28 Sep 2017 00:20:40 +0000 (UTC)

@martinthomson pushed 1 commit.

23b4e30  MUST this, MUST that

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/408/files/b8f85899daaa6311348c9ba5ce06eafd6ac2f404..23b4e30e35aa066c2a7f3d615b47ed000b7fda63

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 27 Sep 2017 17:20:46 -0700

martinthomson commented on this pull request.

 ~~~

Sure. Reworded.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/408#discussion_r141499698

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 28 Sep 2017 22:41:05 +0000 (UTC)

Merged #408.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/408#event-1270740820