Subject: [httpwg/http-extensions] ORIGIN-compliant clients and legacy servers (#438)

From: HTTP issue updates <[email-masked]>
Date: Tue, 28 Nov 2017 17:27:23 +0000 (UTC)

The text in 2.4 says....

> Once an Origin Set has been initialized... [lots of stuff]
>
> Additionally, clients MAY avoid consulting DNS to establish the connection’s authority for new requests; however, those that do so face new risks, as explained in Section 4.

I think part of our issue with how Edge implemented coalescing without considering DNS arises from the fact that this "Additionally" isn't clearly tied to being something that clients do "Once an Origin Set has been initialized" versus something that clients do in addition to the above behavior.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/438

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 29 Nov 2017 00:32:14 +0000 (UTC)

Closed #438 via #439.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/438#event-1362574651