Subject: Re: [httpwg/http-extensions] Can dictionary keys repeat? (#281)

From: HTTP issue updates <[email-masked]>
Date: Wed, 06 Dec 2017 10:15:38 -0800

As @jyasskin is encountering, there needs to be something better here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/281#issuecomment-349727817

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 06 Dec 2017 18:15:39 +0000 (UTC)

Reopened #281.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/281#event-1375360032

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 06 Dec 2017 11:12:35 -0800

Specifically, I believe this issue is a request to have some way to represent a dictionary member whose value is an ordered list? My use is in https://tools.ietf.org/id/draft-yasskin-http-origin-signed-responses-01.html#signature-header, where `certUrl` and `validityUrl` maybe should be lists of strings, and maybe the order should be significant to express a series of fallback URLs.

[Quic](https://quicwg.github.io/base-drafts/draft-ietf-quic-http.html#alt-svc-version-hint) specifies its order to be significant.

I do appreciate the default provided by "SHALL be unique" that dictionary members aren't lists unless we explicitly write that they are, since it helps my algorithms fail closed when someone sends an unexpected extra value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/281#issuecomment-349743568