Subject: Re: [httpwg/http-extensions] Clarify what to do with out-of-order early data (#442)

From: HTTP issue updates <[email-masked]>
Date: Fri, 01 Dec 2017 14:50:56 +0000 (UTC)

kaduk approved this pull request.

This does seem to help.  The rest of the document is probably enough that we don't need to say more about proper processing of data that is identified as early.

> @@ -345,11 +345,12 @@ requests, which could result in increased load.
 
 ## Out of Order Delivery
 
-In protocols that deliver data out of order (such as QUIC {{HQ}}) early data
-can arrive after the handshake completes.  This leads to potential ambiguity
-about the status of requests and could lead to inconsistent treatment (see
+In protocols that deliver data out of order (such as QUIC {{HQ}}) early data can
+arrive after the handshake completes.  This leads to potential ambiguity about
+the status of requests and could lead to inconsistent treatment (see

Hmm, I wonder how we ended up with the gratuitous re-flowing.  (Different editors using different thresholds for which column to wrap at?)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/442#pullrequestreview-80516974

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 03 Dec 2017 23:45:47 +0000 (UTC)

martinthomson commented on this pull request.

 ## Out of Order Delivery

I use both emacs and vim at different times, but both are configured with the same value.  ¯\\_(ツ)_/¯

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/442#discussion_r154541511

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 07 Dec 2017 16:51:24 -0800

Closed #442.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/442#event-1378031659

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 08 Dec 2017 00:51:42 +0000 (UTC)

I've a new fix, based on discussion with davidben.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/442#issuecomment-350139970