Subject: [httpwg/http-extensions] CONNECT: consider using ALPN registry for the :protocol values. (#471)

From: HTTP issue updates <[email-masked]>
Date: Tue, 16 Jan 2018 23:17:37 +0000 (UTC)

Please consider using the [ALPN protocol IDs registry] instead of the [HTTP Upgrade token registry] for the `:protocol` values in HTTP/2 extended CONNECT method, since it's more appropriate for the use case.

The only downside is that there is no `"websocket"` ALPN value, but that could be easily added.

Also, we should add `"bytes"` / `"bytestream"` to the registry, for the purpose of proxying arbitrary TCP connections over HTTP/2.

[ALPN protocol IDs registry]: https://www.iana.org/assignments/tls-extensiontype-values/tls-extensiontype-values.xhtml#alpn-protocol-ids
[HTTP Upgrade token registry]: https://www.iana.org/assignments/http-upgrade-tokens/http-upgrade-tokens.xhtml

cc @mcmanus 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 16 Jan 2018 22:02:09 -0800

IMHO this would not be logical. CONNECT and Upgrade are really similar in that they are used to transport something over HTTP, and that something may very well be a TLS stream which itself contains its own ALPN.

Anyway this should be discussed on the mailing list, not via issues here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471#issuecomment-358206329