Subject: Re: [httpwg/http-extensions] Avoid sending the digest when not used (#410)

From: HTTP issue updates <[email-masked]>
Date: Thu, 04 Jan 2018 14:56:57 -0800

Related to the question of when to send the digest, there's also the question of which digests to send when a connection could be authoritative for many hostnames.  A certificate with multiple SANs, or worse yet, a wildcard subdomain?  A client likely won't want to send the digest for all origins if the set is large, but sending it just for the first origin isn't likely to be sufficient assuming that the page has resources on subdomains / related domains.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/410#issuecomment-355423149

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 01 Feb 2018 07:39:14 +0000 (UTC)

@MikeBishop the frame already has a slot for origin, so I think the approach would be to send separate digests for those origins you're interested in sending them for. If you find text that contradicts that (or if it isn't clear enough), or want to advocate another approach, open a separate issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/410#issuecomment-362183191