Subject: Re: [httpwg/http-extensions] Shortnames in gh-pages (#467)

From: HTTP issue updates <[email-masked]>
Date: Wed, 03 Jan 2018 19:31:11 +0000 (UTC)

@MikeBishop pushed 1 commit.

d9ff779  Integrate with clean as well

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/467/files/9884e528e1ce2d56cb11f7dc93343d29ec4a96d1..d9ff7790b52e8ac4a3db4ff1ee25c023ea990d7f

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 03 Jan 2018 23:06:18 +0000 (UTC)

martinthomson approved this pull request.

A few minor improvements.

> @@ -11,3 +13,12 @@ else
 	git clone -q --depth 10 $(CLONE_ARGS) \
 	    -b master https://github.com/martinthomson/i-d-template $(LIBDIR)
 endif
+
+$(GHPAGES_EXTRA):
+	ln -sf draft-ietf-httpbis-$@ $@
+
+.PHONY: clean-extra
+clean:: clean-extra
+
+clean-extra:
+	-rm -f $(GHPAGES_EXTRA)

Just do this:

```make
clean::
        -rm -f $(GHPAGES_EXTRA)
```

> @@ -1,6 +1,8 @@
 LIBDIR := lib
 USE_XSLT := true
 DISABLE_RIBBON := true
+GHPAGES_EXTRA = $(foreach ext,.html .txt,$(addsuffix $(ext),$(foreach draft,$(drafts),$(shell echo $(draft) | sed -e 's/draft-ietf-httpbis-//'))))

Use `:=` or the expansion of GHPAGES_EXTRA will run the loop every time that `$(GHPAGES_EXTRA)` appears.

> @@ -11,3 +13,12 @@ else
 	git clone -q --depth 10 $(CLONE_ARGS) \
 	    -b master https://github.com/martinthomson/i-d-template $(LIBDIR)
 endif
+
+$(GHPAGES_EXTRA):
+	ln -sf draft-ietf-httpbis-$@ $@

Cunning.  No dependencies, but then it doesn't need any.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/467#pullrequestreview-86517114

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 03 Jan 2018 23:09:14 +0000 (UTC)

0607e16  Simplified clean

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/467/files/d9ff7790b52e8ac4a3db4ff1ee25c023ea990d7f..0607e16ccfc72da782d754d997ff314508e7f07e

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 03 Jan 2018 23:10:30 +0000 (UTC)

MikeBishop commented on this pull request.

 LIBDIR := lib
 USE_XSLT := true
 DISABLE_RIBBON := true

That's intentional, actually.  $(drafts) is undefined until after the import, at which point it's too late.  By delaying expansion, it *is* defined by the time GHPAGES_EXTRA is used.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/467#discussion_r159550530

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 03 Jan 2018 15:15:40 -0800

martinthomson commented on this pull request.

 LIBDIR := lib
 USE_XSLT := true
 DISABLE_RIBBON := true

Ugh, oh well.  There should only be two expansions, so that isn't so bad.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/467#discussion_r159551252

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 03 Jan 2018 15:16:09 -0800

Merged #467.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/467#event-1408707979