Subject: Re: [httpwg/http-extensions] Fixed a couple references to "Very Large values" lower case and "^^" to "^" (#573)

From: HTTP issue updates <[email-masked]>
Date: Mon, 09 Apr 2018 02:54:29 -0700

martinthomson approved this pull request.

LGTM.

Do you think that you want to provide some guidance about choice?  That is, that the client chooses this value based on it being more than they are expecting to be present on the resource, or at least enough that making another range request isn't going to be onerous.  And that that is balanced against the risk of too large values causing problems like integer overflow on the server side.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/573#pullrequestreview-110392809

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 09 Apr 2018 18:05:50 +0000 (UTC)

@martinthomson 

Thanks Martin,

Do you think some of the language from Section 5 needs to be mentioned/reiterated earlier?

Guess I could say something like "a value much larger than the expected maximum size of the representation should be provided by the client (see section 5 for security considerations)"?

Here's most of Section 5

`...in applications where there's no expectation that the representation will ever exceed 2^63, a value smaller than this value should be used as the very large last-byte-pos in a byte-seek request or content-range response. Also, some implementations (e.g. JavaScript-based clients and servers) are not able to represent all values beyond 2^53. So similarly, if there's no expectation that a representation will ever exceed 2^53 bytes, values smaller than this limit should be used for the last-byte-pos in byte-range requests.`

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/573#issuecomment-379841815

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 09 Apr 2018 17:49:42 -0700

That would be perfect.  Note that the security considerations here are more "compatibility considerations" than anything else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/573#issuecomment-379938648

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 10 Apr 2018 07:38:43 +0000 (UTC)

Merged #573.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/573#event-1565490570