Subject: Re: [httpwg/http-extensions] Minimum version (#587)

From: HTTP issue updates <[email-masked]>
Date: Mon, 16 Apr 2018 12:28:22 +0000 (UTC)

The DoH WG answered this by saying "no" - applications are supposed to be defined at the semantic layer. (although I would quibble and say 56bis and the word 'allow' don't go too well together - its advice).

Most of the discussion centered around how it is impossible to really leverage the ecosystem and actually know what versions are available. (mitm, load balancers, browser portabiity, etc..) so this would be very fragile.

This conclusion was reached for DoH even though there was agreement  DoH really requires multiplexing to work well. DoH did end up documenting this relationship and SHOULDing h2, but not requiring it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/587#issuecomment-381581971

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 19 Apr 2018 00:45:56 -0700

@mcmanus how does that look?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/587#issuecomment-382642409

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 19 Apr 2018 08:17:27 +0000 (UTC)

Do we actually still have a concept of "maximum"? What would be the relation between HTTP/QUIC vs HTTP/2?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/587#issuecomment-382650690

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 19 Apr 2018 05:12:35 -0700

sgtm

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/587#issuecomment-382711207

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 30 Apr 2018 06:16:24 +0000 (UTC)

Closed #587.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/587#event-1600924102