Subject: [httpwg/http-extensions] Client probes for server certificates are awkward (#564)

From: HTTP issue updates <[email-masked]>
Date: Fri, 06 Apr 2018 23:09:12 +0000 (UTC)

In the current draft, the client ties up a stream for a pending request on an unproven domain so that it can send a `NEEDED` frame, permitting the server to respond with `USE`.  This is rather awkward.

However, the alternative is also somewhat unappealing.  In the process of updating #480, I'm adding a suggestion that servers SHOULD respond to `REQUEST` with an appropriate certificate if they have one, which makes this flow much cleaner.  However, there's current no way to *reject* a certificate request without a request stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/564

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 06 Apr 2018 23:10:09 +0000 (UTC)

One possibility:  Since the solution to #482 involves moving `USE`/`NEEDED` onto the control stream, perhaps it should be valid for clients to send those frames in reference to the connection itself?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/564#issuecomment-379407393