Subject: [httpwg/http-extensions] Stream-linking frames can reference Stream Zero (#586)

From: HTTP issue updates <[email-masked]>
Date: Fri, 13 Apr 2018 11:04:15 -0700

Fixes #564.

If clients need a server certificate before making requests for an origin, they can send `CERTIFICATE_NEEDED` for stream zero, indicating the connection.  Servers respond with `USE_CERTIFICATE`.

Known drawbacks:
  - Since `USE_CERTIFICATE` has to be sent in order, if the client requests a batch of domains, the server can't provide the requested certificates out-of-order (though it can outright reject some of them).
  - This is fine for H2; in HTTP/QUIC, we'll need to decide if this is still zero, or if it's 3/4, or something else.
You can view, comment on, or merge this pull request online at:

  https://github.com/httpwg/http-extensions/pull/586

-- Commit Summary --

  * Reference stream 0

-- File Changes --

    M draft-ietf-httpbis-http2-secondary-certs.md (27)

-- Patch Links --

https://github.com/httpwg/http-extensions/pull/586.patch
https://github.com/httpwg/http-extensions/pull/586.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/586

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 13 Apr 2018 11:05:20 -0700

@MikeBishop pushed 1 commit.

3067409  Changelog

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/586/files/bff9efd674968a0ebf5815e0f0291e875147827e..3067409864dcd5c719b99393c70c1d4e1cdf56ed