Subject: Re: [httpwg/http-extensions] Values for available-value by reference? (#560)

From: HTTP issue updates <[email-masked]>
Date: Tue, 03 Apr 2018 17:42:32 -0700

Hi Herbert,

I think it's possible to do this with Variants; the algorithm for `Accept-Datetime` would ignore `available-values` and consult another header for the URL, look it up and use the retrieved values.

Having said that, I don't think any cache would implement it, because the overhead would be spectacular. Even served from cache, it's looking up a separate URL and doing some non-trivial parsing.

Does that make sense? I know it's not terribly satisfying, but it _could_ be accommodated -- and I think that's good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/560#issuecomment-378443307

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 05 Apr 2018 15:44:43 +0000 (UTC)

Hi Mark,

2 things:

- My suggestion was not to have a cache ignore `available-value` (and look at another header), but rather to allow a URL as a value of `available-value` (or another param, e.g. `available-value-url`). 
- As I indicated,  Memento's datetime negotiation is currently the only negotiation with a potentially large namespace of possible values for `available-value`. I wonder whether that will remain the case, though (see e.g.  [fine grained content negotiation](https://ruben.verborgh.org/articles/fine-grained-content-negotiation/)) and as such I also wonder whether a new mechanism to support content negotiation - `Variants` - shouldn't be future proof with this regard?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/560#issuecomment-378981560

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 06 Apr 2018 07:21:16 +0000 (UTC)

Closed #560.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/560#event-1560309631

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 06 Apr 2018 07:21:15 +0000 (UTC)

1) Understood. However, the specified syntax for `available-value` is a token, and URLs can't fit into that, so that's the effect -- it has to come from somewhere else. Not a big deal, just how we'd do it.

2) Variant isn't that ambitious; it's just trying to encompass current practice on the Web, and near-future uses like Client Hints. It's definitely going to be inappropriate for some use cases, and this limitation is already documented.

Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/560#issuecomment-379170035