Subject: Re: [httpwg/http-extensions] Rough in Server Push (9985fa9)

From: HTTP issue updates <[email-masked]>
Date: Thu, 17 May 2018 04:53:37 -0700

Server push is based around request and response with headers and a body. How is this not part of the "core" semantics?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/9985fa930be5f61de1f43cedb9bbfe0084fd5038#commitcomment-29015204

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 17 May 2018 04:58:58 -0700

This language is jumping the gun quite a bit. For example, the Node.js v10 release just this month finally includes Server Push support and is expected to enter LTS in October. It is normal for implementors to lag the standard.

Lack of Browser API support is not for lack of enthusiasm by the web developer community, judged by the many conference talks and blog posts about Server Push. Many web developers eagerly await (and work towards) better support for this feature.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/9985fa930be5f61de1f43cedb9bbfe0084fd5038#commitcomment-29015281

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 17 May 2018 11:39:05 -0700

I agree, i think it's a little odd to encode this in an rfc. It's still early days and I see huge potential for things like API's. Maybe that's just me

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/9985fa930be5f61de1f43cedb9bbfe0084fd5038#commitcomment-29022174

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 17 May 2018 12:03:38 -0700

@evert I don't think you are alone. Shameless plug for a White Paper I wrote about prototyping a Server Push API that could be used for a variety of things (but in this particular case for video streaming).

[BBC R&D WHP 336 - Scalable media delivery on the Web with HTTP Server Push](https://www.bbc.co.uk/rd/publications/whitepaper336)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/9985fa930be5f61de1f43cedb9bbfe0084fd5038#commitcomment-29022549

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 17 May 2018 15:48:53 -0700

I agree. I_ think there is tremendous potential in HTTP/2 APIs for more fine grained control how to handle server push (e.g. priority/order)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/9985fa930be5f61de1f43cedb9bbfe0084fd5038#commitcomment-29025729