Subject: Re: [httpwg/http-extensions] Structured headers should explicitly allow multiple same-named headers (#596)

From: HTTP issue updates <[email-masked]>
Date: Tue, 01 May 2018 12:43:18 -0700

-1 on "overriding" anything the base spec says.

If you want list semantics, use the matching ABNF notation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/596#issuecomment-385768642

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 01 May 2018 19:52:17 +0000 (UTC)

To be clear, I have no objection to using the `#` ABNF notation if that's what folks think is best.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/596#issuecomment-385770962

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 01 May 2018 22:30:34 +0000 (UTC)

I don't think we should tie requirements for handling of HTTP extensions into what convention is used to define their syntax. Will raise an issue against httpwg/http-core.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/596#issuecomment-385809894

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 01 May 2018 21:43:31 -0700

Maybe, but the core question is the behavior, not the syntax (handling empty elements, for instance).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/596#issuecomment-385863288