Subject: Re: [httpwg/http-extensions] Add versioning and evolution (2b1fcbe)

From: HTTP issue updates <[email-masked]>
Date: Thu, 03 May 2018 19:26:57 -0700

Aren't these backward-**compatible** techniques?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/2b1fcbe69609c0bc63d3c37b1206cfb9a5e2a20d#commitcomment-28849378

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 03 May 2018 19:29:15 -0700

The changes are backwards-incompatible; if they were backwards-compatible, you could continue to use the existing URL / media type / header field.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/2b1fcbe69609c0bc63d3c37b1206cfb9a5e2a20d#commitcomment-28849390

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 03 May 2018 19:40:27 -0700

Hmm, a new header field can be sent alongside the old one.  Same for a new link relation.  A new media type might be backwards compatible, depending on who sends it (a server responding might use Accept from the request).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/2b1fcbe69609c0bc63d3c37b1206cfb9a5e2a20d#commitcomment-28849454

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 03 May 2018 19:42:37 -0700

note that I used the terminology "backwards-compatible *changes*", not "techniques". 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/commit/2b1fcbe69609c0bc63d3c37b1206cfb9a5e2a20d#commitcomment-28849455