Subject: [i2rs] Progressing the chartering effort

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 19 Nov 2012 11:37:10 -0000

Hi,

I have taken the charter text and milestones discussed at the BoF (minus the
paragraph we agreed to delete) and added it into the data tracker at
https://datatracker.ietf.org/doc/charter-ietf-i2rs/

This is our starting point for further charter discussions.

Cheers,
Adrian

---

From: Russ White <[email-masked]>
Date: Tue, 27 Nov 2012 12:16:14 -0500

This looks good --nice, well defined scope and strong requirements
language. The only question I have is:

==
A routing system is all or part of a routing network such as an
interface, a collection of interfaces, a router, or a collection of routers.
==

Should this include the control plane protocols, as well? The positive
would be to provide a (more) complete description of a routing system,
the negative is this might be seen as bringing interaction with
protocols into the charter.

Thoughts?

:-)

Russ

-- 
<><
[email-masked]
[email-masked]

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 27 Nov 2012 12:55:18 -0500

I am back from the holiday and have had a chance to re-read the proposed charter in detail. Here are some comments:

	1) A routing system is all or part of a routing network such as an interface, a collection of
interfaces, a router, or a collection of routers.

	This should specify that the "routers" may be real or virtual.

	2) This sentence is a bit awkward:

Initial work within the working group will be limited to
within a single administrative domain.

	Maybe change it to, "Initial work within the working group will be limited to frameworks, architectures, and use cases that apply one or more routed areas that are under the control of a single administrative domain.

	3) Change this:

	- Other use cases may be adopted by the working group only after milestones have 
  been added to the charter page.

	to:

- Other use cases may be adopted by the working group only after milestones have 
  been added to the working group's charter.

	4) I think it is important to ground the "abstract models" to somehow be useful in driving protocol construction or changes.  The way the text reads, there could be models for models' sake (albeit consistent with the official use cases):

- Abstract information models consistent with the use cases.

	5) Do these need to be consistent with the use cases?

- Requirements for I2RS protocols and encoding languages.

	That leads me to a procedural question: what comes first, the use cases or the requirements?

On Nov 19, 2012:6:37 AM, at 6:37 AM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>

---

From: Russ White <[email-masked]>
Date: Tue, 27 Nov 2012 13:17:04 -0500

> 	That leads me to a procedural question: what comes first, the use cases or the requirements?

I would argue the use cases should come first, because you can only
derive requirements by generalizing more specific instances of what you
are trying to accomplish.

:-)

Russ

-- 
<><
[email-masked]
[email-masked]

---

From: Alia Atlas <[email-masked]>
Date: Tue, 27 Nov 2012 13:50:30 -0500

I think it should include control plane protocols as well.  The first focus
is RIB-based use-cases, which seem to be easily tied to a forwarding
plane.  However, the BGP-based policy cases and topology cases do not need
to be co-located with a forwarding plane and, if that portion of the
routing system is supported by a software entity, I think that I2RS should
be able to handle that as well.

I feel that restricting the routing system to only those with an attached
forwarding plane (physical or virtual) is unnecessarily restrictive and we
already know of cases where it may not be sufficient.

Alia

---

From: David Meyer <[email-masked]>
Date: Tue, 27 Nov 2012 10:54:10 -0800

On Tue, Nov 27, 2012 at 10:50 AM, Alia Atlas <[email-masked]> wrote:

> I think it should include control plane protocols as well.  The first
> focus is RIB-based use-cases, which seem to be easily tied to a forwarding

Definitely, and well said.

> already know of cases where it may not be sufficient.

Agreed.

--dmm

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 27 Nov 2012 13:57:02 -0500

On Nov 27, 2012:1:50 PM, at 1:50 PM, Alia Atlas <[email-masked]> wrote:

> I think it should include control plane protocols as well.  The first focus is RIB-based use-cases, which seem to be easily tied to a forwarding plane.  However, the BGP-based policy cases and topology cases do not need to be co-located with a forwarding plane and, if that portion of the routing system is supported by a software entity, I think that I2RS should be able to handle that as well.
> 
> I feel that restricting the routing system to only those with an attached forwarding plane (physical or virtual) is unnecessarily restrictive and we already know of cases where it may not be sufficient.

	Good point.

	--Tom

---

From: "Keyur Patel (keyupate)" <[email-masked]>
Date: Tue, 27 Nov 2012 19:00:58 +0000

+1

Regards,
Keyur

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Tue, 27 Nov 2012 13:50:30 -0500
To: Russ White <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] Progressing the chartering effort

Alia

On Tue, Nov 27, 2012 at 12:16 PM, Russ White <[email-masked]<mailto:[email-masked]>> wrote:

==

Thoughts?

:-)

Russ

--
<><
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

_______________________________________________ i2rs mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/i2rs

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 27 Nov 2012 19:02:53 +0000

Agree, good points

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, November 27, 2012 10:51 AM
To: Russ White
Cc: [email-masked]
Subject: Re: [i2rs] Progressing the chartering effort

Alia

==

Thoughts?

:-)

Russ

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Tue, 27 Nov 2012 19:03:13 +0000

Agreed.

On 11/27/12 10:50 AM, "Alia Atlas" <[email-masked]> wrote:

>focus is RIB-based use-cases, which seem to be easily tied to a
>forwarding plane.  However, the BGP-based policy cases and topology cases
>do not need to be co-located with a forwarding plane
> and, if that portion of the routing system is supported by a software
>entity, I think that I2RS should be able to handle that as well.
>
>forwarding plane (physical or virtual) is unnecessarily restrictive and
>we already know of cases where it may not be sufficient.
>
>Alia 
>
>

---

From: Edward Crabbe <[email-masked]>
Date: Tue, 27 Nov 2012 11:40:36 -0800

+1

---

From: "George, Wes" <[email-masked]>
Date: Tue, 27 Nov 2012 16:38:44 -0500

Can someone clarify for me?

We have an unfortunate overloading of the term "interface" here:
"A routing system is all or part of a routing network such as an interface, a collection of
interfaces, a router, or a collection of routers.  Interfaces to the Routing System..."

These are not the same sort of interfaces, and their proximity can lead to confusion. One moves packet traffic, the other is more of an information interface or even an API. Do we need to modify the first one to refer to it as "an interface or collection of interfaces to transmit/receive packet data" or some such? Or am I inferring a distinction where none is desired?

Thanks

Wes George

> I have taken the charter text and milestones discussed at the BoF (minus
> the paragraph we agreed to delete) and added it into the data tracker at

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 29 Nov 2012 13:12:11 +0000

+1

AB