Subject: Re: [i2rs] Progressing the chartering effort

From: [email-masked] (Noel Chiappa)
Date: Tue, 27 Nov 2012 17:36:10 -0500 (EST)

> From: "George, Wes" <[email-masked]>

    > We have an unfortunate overloading of the term "interface" here
    > ...
    > These are not the same sort of interfaces, and their proximity can lead
    > to confusion. 

Good catch. I can't offhand think of a good synonym for either one (which we
could/would always use to refer to that flavour of interface) - can anyone
else?

Failing that, we'll have to use an attached modifier (which I suggest be
included in all uses of the word 'interface') - 'physical interface' or
'traffic-carrying interface' for one, and something like 'control plane
interface' for the other.

    > Or am I inferring a distinction where none is desired?

No, there's definitely a real distinction between i) an interface over which
user data packets are sent, to the next-hop router (or the final
destination), and ii) the interface between two control plane subsystems,
which the two subsystems use to interact with each other.

	Noel

---

From: "Zach Seils (seils)" <[email-masked]>
Date: Wed, 28 Nov 2012 01:24:20 +0000

What about simple "control interface" and "data interface" designations?

Regards,
Zach

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Noel
> Chiappa
> Sent: Tuesday, November 27, 2012 5:36 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [i2rs] Progressing the chartering effort
> 
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs

---

From: Russ White <[email-masked]>
Date: Wed, 28 Nov 2012 07:22:16 -0500

How about we push "interface" into an acronym in one case, so we don't
end up repeating the word itself constantly? Maybe:

- "interface," used in the traditional sense, as a physical or virtual
interface that connects a link to a packet processing engine of some type.

- "RSI," the routing system interface, defined as the bidirectional
interface into the set of software and hardware elements that control
the forwarding of packets through a routed (IP) network.

If we all used "RSI" consistently, then we could just leave "interface"
where it is, minimizing confusion for readers in the future.

Thoughts?

:-)

Russ

-- 
<><
[email-masked]
[email-masked]

---

From: Marcelo Reis <[email-masked]>
Date: Wed, 28 Nov 2012 09:10:37 -0500

What about using the term 'link' when referring to traditional virtual/physical interfaces. And leave the term 'interface' to indicate a routing system interface?

Marcelo

The interface term left alone will likely always be confused with an API interface.

---

From: Russ White <[email-masked]>
Date: Wed, 28 Nov 2012 09:21:44 -0500

> What about using the term 'link' when referring to traditional virtual/physical interfaces. And leave the term 'interface' to indicate a routing system interface?

I would agree --but I think using the term "link" throughout will be
difficult, and will confuse folks reading a few years from now --besides
which, "link," itself is rather overloaded.

OTOH, I'd rather not get into a full blown effort to define every
possible meaning of the word "interface." I'd rather just peel off the
one definition we want to be definite about, provide the right acronym
or phrase for that one meaning, and leave the rest alone as out of scope
and charter.

:-)

Russ

---

From: "George, Wes" <[email-masked]>
Date: Wed, 28 Nov 2012 11:00:31 -0500

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marcelo Reis
>
> What about using the term 'link' when referring to traditional
> virtual/physical interfaces. And leave the term 'interface' to indicate
> a routing system interface?
>
[WEG] I think that is going to end up being an artificial distinction that won't translate beyond those involved in the discussion, and to me, in that context "link" refers to a connection between two interfaces, not just one interface.

We could say "physical interface" and clarify that this includes virtual interfaces that are emulating a physical interface. I think that gets properly specific. (and then the I2RS interface would be "control interface")

I also like the idea of a crisper definition of the routing system interface as a way to disambiguate it from the more generic form that could mean lots of different things dependent on context. Maybe combined with making it clear in the definition of a routing system that in that case we're referring to interfaces carrying user data between devices (whether physical or virtual) it'd make the distinction more evident.

The only other way I can think of to clarify might be to actually tie it to the OSI layers involved.
A router interface is going to be Layers 1-3
An IRS interface is going to be Layer 7 really, even if it's manipulating things to affect the path of Layer 3 data.
But that had the potential to be pretty clunky too. Is it possible to mainly refer to the Routing System Interface as an API, or is that too limiting? That at least uses a well-known disambiguation.

Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Marcelo Reis <[email-masked]>
Date: Wed, 28 Nov 2012 14:20:38 -0500

I was trying to divert from yet another acronym. But I agree, it does seem the best option.

Marcelo

---

From: Marcelo Reis <[email-masked]>
Date: Wed, 28 Nov 2012 14:40:39 -0500

I agree, using the term 'link' won't help.

Defining the new RSI acronym does seem the best option.

I wouldn't entertain an OSI layer analogy though. That by itself would open a whole lot of discussion. For instance, a router interface doesn't need to be limited to layers 1-3. 

Marcelo

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 29 Nov 2012 13:18:33 +0000

I agree too, however we need to define clearly and if there are different
meanings with other RFC, then should be mentioned.

AB

On Wed, Nov 28, 2012 at 7:40 PM, Marcelo Reis <[email-masked]> wrote:

> I wouldn't entertain an OSI layer analogy though. That by itself would
> open a whole lot of discussion. For instance, a router interface doesn't
> need to be limited to layers 1-3.
>
> Marcelo
>
> > [WEG] I think that is going to end up being an artificial distinction
> that won't translate beyond those involved in the discussion, and to me, in
> that context "link" refers to a connection between two interfaces, not just
> one interface.
> >
> > We could say "physical interface" and clarify that this includes virtual
> interfaces that are emulating a physical interface. I think that gets
> properly specific. (and then the I2RS interface would be "control
> interface")
> >
> > I also like the idea of a crisper definition of the routing system
> interface as a way to disambiguate it from the more generic form that could
> mean lots of different things dependent on context. Maybe combined with
> making it clear in the definition of a routing system that in that case
> we're referring to interfaces carrying user data between devices (whether
> physical or virtual) it'd make the distinction more evident.
> >
> > An IRS interface is going to be Layer 7 really, even if it's
> manipulating things to affect the path of Layer 3 data.
> > But that had the potential to be pretty clunky too. Is it possible to
> mainly refer to the Routing System Interface as an API, or is that too
> limiting? That at least uses a well-known disambiguation.
> >
> > Wes George
> >
> > This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely
> for the use of the individual or entity to which it is addressed. If you
> are not the intended recipient of this E-mail, you are hereby notified that
> any dissemination, distribution, copying, or action taken in relation to
> the contents of and attachments to this E-mail is strictly prohibited and
> may be unlawful. If you have received this E-mail in error, please notify
> the sender immediately and permanently delete the original and any copy of
> this E-mail and any printout.
>