Subject: Re: [i2rs] Progressing the chartering effort

From: Lou Berger <[email-masked]>
Date: Thu, 06 Dec 2012 06:48:06 -0500

Why not data plane interface?  (Control plane and data plane, and their
distinction, are not exactly new terms/concepts...)

Lou

On 11/27/2012 10:30 PM, Nagendra Kumar (naikumar) wrote:
> Or May be some thing like Control Plane interface (CPi) and Data Forwarding/Forwarder interface (DFi)?.
> 
> -Nagendra
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Noel Chiappa
> Sent: Wednesday, November 28, 2012 8:11 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [i2rs] Progressing the chartering effort
> 
>     > From: "Zach Seils (seils)" <[email-masked]>
> 
>     > What about simple "control interface" and "data interface" designations?
> 
> "Control interface" I like. I'm a lot less sold on "data interface" - it sonuds like some sort of programmatic thing, rather that (usually) a piece of hardware over which user data packets are sent.
> 
> 'Physical interface' for the latter is probably not optimal, now that I think about it; we probably want to support virtual interfaces as well. How about 'network interface', though?
> 
> 	Noel
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
> 
> 
> 
>

---

From: Russ White <[email-masked]>
Date: Thu, 06 Dec 2012 12:11:01 -0500

> distinction, are not exactly new terms/concepts...)

Several thoughts...

First, I see this as a scoping problem. Trying to create both a control
plane and a data plane interface at the same time opens an entire can of
worms that I don't know if we want to address. Chewable chunks.

Second, there's a lot of other "stuff" going on in the data plane
interface area, while there's almost none (or rather none) going on in
the control plane interface area.

Third, a control plane interface assumes an underlying hybrid model,
which fits most of the unique use cases articulated to this point.

So, I wouldn't say we should rule out a data plane interface forever,
but rather that we should rule it out for right now --focus on that
which is different, and then move towards the more common if the need
arises or the work seems worth doing at some point in the future.

At least that's my thinking.

:-)

Russ

-- 
<><
[email-masked]
[email-masked]