Subject: Re: [i2rs] Kathleen Moriarty's No Objection on draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)

From: Alia Atlas <[email-masked]>
Date: Wed, 25 Jan 2017 08:35:53 -0500

Could one of you who are saying that a writable topology model can appear
in the regular configuration data-store please explain:

How does validation at reboot work when there is dependency on learned
topology data that isn't yet available?

I'd prefer more technology discussion of the nuances.  This one has been an
active topic of discussion for at least 2 years, so I'm hopeful that you
all have well thought out answers.

Regards,
Alia

On Wed, Jan 25, 2017 at 7:27 AM, Lou Berger <[email-masked]> wrote:

Sue,
>
>>
> In short, I'm going to agree with Benoit - but for slightly different
>
> reasons as I also co-chair TEAS, a group that is basing some of its
>
> work on I2RS developed models.
>
>>
> As a WG chair, I have always viewed the models being developed by I2RS
>
> as typical models that are generally useful, and being defined by I2RS
>
> simply because they were ahead of other groups that might otherwise
>
> define the models -- and I view this as a fine thing that has benefit
>
> for YANG users and other WGs. As TEAS chair, this is what lead me to
>
> ensure that the models being defined in TEAS built on the I2RS YANG
>
> modules vs their original path of redefining parallel function.
>
>>
> As part of my view of the I2RS models being generally applicable to uses
>
> beyond I2RS together with I2RS choosing YANG for modeling ephemeral
>
> data, I have always expected that the I2RS WG would at some (perhaps as
>
> part of the I2RS protocol definition) define how any YANG model can be
>
> used to support I2RS. This view certainly lead me to conclude that
>
> having the I2RS models move forward, just like any other YANG model,
>
> makes sense and would benefit the other models and WGs that reference
>
> this core work. This view also allows for the relationship to the
>
> revised-data store work, as well as the specification of which data
>
> store(s) I2RS uses, to be separately defined -- and to not gate
>
> publication of these models. This separate specification would be
>
> the location for any I2RS-specific transport and security considers,
>
> so such would not belong in the generally reusable models developed
>
> by I2RS.
>
>>
> Essentially, As NETMOD co-chair, I concluded that the revised data
>
> store work provided the direction on how ephemeral would be supported
>
> in a general YANG context and, therefore, the major open issue / gating
>
> impediment to progressing I2RS models had been removed and publication
>
> of these models were unblocked. This also motivated my comments in the
>
> related discussions at the last meeting.
>
>>
> If my understanding/view is correct, i.e., that the topology models are
>
> just like any other YANG model, then I think publication can and
>
> should proceed (with the appropriate text for a typical YANG model). If
>
> I misunderstood something, and the models produced by I2RS are limited
>
> to ephemeral representations/data stores as well as specific YANG
>
> transport protocols -- then as TEAS chair, I have to hit reset on the
>
> TEAS topology work, and as NETMOD chair I think the NETMOD WG needs to
>
> discuss what it means for a YANG model to be protocol/datastore
>
> specific and if any guidelines or other new NTEMOD documents are need
>
> to support such.
>
>>
> Less importantly, as I2RS participant, I'd also ask for the documents
>
> to be sent back to the WG for a new last call once the documents
>
> are updated to reflect their narrow scope -- as I bet I'm not the only
>
> person who viewed this work applicable to non-ephemeral uses.
>
>>
> I hope this helps.
>
>>
> Lou
>
>
> On January 24, 2017 11:56:32 AM "Susan Hares" <[email-masked]> wrote:
>
> > To: Martin:
> >
> > You have a reasonable request. If the NETMOD WG Chairs confirm their
> > decision to make I2RS Yang Modules part of the Control Plane Datastore
> then
> > as shepherd/WG-chair I will recommend these get added to the draft.
> >
> > Note to authors :
> >
> > As we wait for the NETMOD WG Chairs and Benoit to deliver the decision on
> > Config/Control Plane datastore, the authors should work on:  Basic Yang
> > security considerations and the other I2RS Yang Module information.
> >
> > Sue Hares (Shepherd)
> > -----Original Message-----
> > From: Martin Bjorklund [mailto:[email-masked]]
> > Sent: Tuesday, January 24, 2017 10:39 AM
> > To: [email-masked]
> > Cc: [email-masked]; [email-masked];
> > [email-masked]; [email-masked]; [email-masked];
> > [email-masked]; [email-masked]; [email-masked];
> > [email-masked]
> > Subject: Re: [i2rs] Kathleen Moriarty's No Objection on
> > draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)
> >
> > "Susan Hares" <[email-masked]> wrote:
> >> Martin:
> >>
> >>
> >>
> >> I'm sorry if misunderstood your comments regarding the
> >> draft-ietf-netmod-revised-datastores-00.txt.  The reason the answer is
> >> unclear is that it depends on the context of the question.
> >>
> >>
> >>
> >> .         If you ask if the pre-standardization I2RS Yang Topology
> models
> >> (basic and L3)  implemented are part of the configuration data store,
> >> the answer is yes - AFAIK.
> >
> > This is not my question.
> >
> >> .         If you ask if the WG LC Topology models are approved to be
> part
> > of
> >> the configuration data store, my understanding was no.   I2RS WG was to
> >> abide by the decision of NETMOD WG on which data store I2RS modules
> >> were placed in.
> >
> > Yes, this is my question.  And my concern is that even if your
> understanding
> > is that they are not designed to be part of the configuration datastores,
> > this fact is not mentioned in the drafts.
> >
> >> If you are concerned the implementation varies from the standardized,
> > please
> >> express this to Benoit Claise.   Based on your comments on my email
> > thread,
> >> I will be brief in my answers today.
> >
> > This is not my concern.
> >
> >
> > /martin
> >
> >
> >
> >>
> >>
> >>
> >> Sue
> >>
> >>
> >>
> >>
> >>
> >> -----Original Message-----
> >> From: Martin Bjorklund [mailto:[email-masked]]
> >> Sent: Tuesday, January 24, 2017 7:35 AM
> >> To: [email-masked]
> >> Cc: [email-masked]; [email-masked];
> >> [email-masked]; [email-masked];
> >> [email-masked]; [email-masked]; [email-masked];
> >> [email-masked]; [email-masked]
> >> Subject: Re: [i2rs] Kathleen Moriarty's No Objection on
> >> draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)
> >>
> >>
> >>
> >> "Susan Hares" < <mailto:[email-masked]> [email-masked]> wrote:
> >>
> >> > Martin:
> >>
> >> >
> >>
> >> > Your statement "One problem is that relying on the solution in
> >>
> >> > draft-ietf-netmod-revised-datastores-00 is a bit premature - in
> >> > fact,
> >>
> >> > that document does not yet provide any details at all on the I2RS
> >>
> >> > ephemeral data store." This statement is not what I understood from
> >> > IETF
> >> 98 or the netmod
> >>
> >> > ADs.   I guess your objection to this data model falls into Benoit
> > Claise
> >>
> >> > (AD) and the NETMOD folks to answer.
> >>
> >>
> >>
> >> Why do you think that I have any objection to
> >> draft-ietf-netmod-revised-datastores-00.  Please re-read what I wrote.
> >>
> >>
> >>
> >> My objection regards your statement:
> >>
> >>
> >>
> >>    1) I2RS Data models do not utilize the configuration data store,
> >>
> >>
> >>
> >> If this is true it needs to be clarified in the document.
> >>
> >>
> >>
> >> After all these emails back and forth, it is still not clear whether
> >> this statement is true or not.
> >>
> >>
> >>
> >>
> >>
> >> /martin
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >> >
> >>
> >> > Sue Hares
> >>
> >> >
> >>
> >> > -----Original Message-----
> >>
> >> > From: i2rs [ <mailto:[email-masked]>
> >> > mailto:[email-masked]]
> >> On Behalf Of Martin
> >>
> >> > Bjorklund
> >>
> >> > Sent: Monday, January 23, 2017 5:26 PM
> >>
> >> > To:  <mailto:[email-masked]> [email-masked]
> >>
> >> > Cc:  <mailto:[email-masked]> [email-masked];
> >> <mailto:[email-masked]>
> >> [email-masked];
> >>
> >> >  <mailto:[email-masked]>
> >> [email-masked];  <mailto:[email-masked]>
> >> [email-masked];
> >>
> >> >  <mailto:[email-masked]> [email-masked];
> >> <mailto:[email-masked]>
> >> [email-masked]; <mailto:[email-masked]> [email-masked]
> >>
> >> > Subject: Re: [i2rs] Kathleen Moriarty's No Objection on
> >>
> >> > draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)
> >>
> >> >
> >>
> >> > "Susan Hares" < <mailto:[email-masked]> [email-masked]> wrote:
> >>
> >> > > Robert and Martin:
> >>
> >> > >
> >>
> >> > > I agree with Robert that the current implementations of the ODL
> >>
> >> > > topology models are handled as part of the configuration data
> >> > > store
> >>
> >> > > with
> >>
> >> > ephemeral
> >>
> >> > > state.   I will point out that these implementation are
> pre-standards
> >>
> >> > > implementations of the I2RS YANG Data model.
> >>
> >> > >
> >>
> >> > > While standardizing the topology data models, the I2RS WG have
> >> > > been
> >>
> >> > > asked to align with the
> >> > > draft-ietf-netmod-revised-datastores-00.txt
> >>
> >> > > NETMOD WG document.  This NETMOD WG document moves the I2RS
> >>
> >> > > ephemeral data
> >>
> >> > store from
> >>
> >> > > configuration data store to a Control Plane data store.   If we
> follow
> >>
> >> > this
> >>
> >> > > draft, the I2RS Topology models are part of the I2RS ephemeral
> >> > > data
> >> store.
> >>
> >> > > If you disagree with the placement of the Topology data models,
> >>
> >> > > please indicate this to the NETMOD WG and to Benoit.  Could you
> >>
> >> > > propose a way that you would see the ephemeral state working with
> >>
> >> > > the configuration data
> >>
> >> > store
> >>
> >> > > to the NETMOD WG?
> >>
> >> > >
> >>
> >> > > Quite frankly, I feel a bit of whip-lash on this topic.   NETMOD WG
> > asks
> >>
> >> > for
> >>
> >> > > Control Plane Data store.  You ask for configuration data store
> >>
> >> > > (which was the I2RS initial proposal).
> >>
> >> >
> >>
> >> > Not really; I ask for clarification.
> >>
> >> >
> >>
> >> > > It is possible for either one to work for I2RS
> >>
> >> > > Topology models - if the right details are taken care of.   How do
> we
> >> make
> >>
> >> > > progress on choosing one method so we can write the I2RS Topology
> >>
> >> > > Models security considerations.?
> >>
> >> >
> >>
> >> > One problem is that relying on the solution in
> >>
> >> > draft-ietf-netmod-revised-datastores-00 is a bit premature - in
> >> > fact,
> >>
> >> > that document does not yet provide any details at all on the I2RS
> >>
> >> > ephemeral datastore.
> >>
> >> >
> >>
> >> > So I see two alternatives.  Either wait with these documents, or
> >>
> >> > publish them with their datamodels as is (i.e., no new additional
> >>
> >> > notes), for the existing protocols and architecure.  This would
> >> > allow
> >>
> >> > them to be implemented just like any other YANG data model.  This
> >>
> >> > would mean that the normal YANG security considerations guidelines
> >> > should
> >> be followed.
> >>
> >> >
> >>
> >> >
> >>
> >> >
> >>
> >> > /martin
> >>
> >> >
> >>
> >> > >
> >>
> >> > > Sue
> >>
> >> > >
> >>
> >> > > -----Original Message-----
> >>
> >> > > From: Robert Varga [ <mailto:[email-masked]> mailto:[email-masked]]
> >>
> >> > > Sent: Monday, January 23, 2017 4:11 PM
> >>
> >> > > To: Martin Bjorklund;  <mailto:[email-masked]> [email-masked]
> >>
> >> > > Cc:  <mailto:[email-masked]> [email-masked];
> >> <mailto:[email-masked]>
> >> [email-masked];
> >>
> >> > >  <mailto:[email-masked]>
> >> [email-masked];  <mailto:[email-masked]>
> >> [email-masked];
> >>
> >> > >  <mailto:[email-masked]>
> >> [email-masked];  <mailto:[email-masked]>
> >> [email-masked]
> >>
> >> > > Subject: Re: [i2rs] Kathleen Moriarty's No Objection on
> >>
> >> > > draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)
> >>
> >> > >
> >>
> >> > > On 01/23/2017 09:26 PM, Martin Bjorklund wrote:
> >>
> >> > > >> I'm pulling your questions to the top of this email.
> >>
> >> > > >>
> >>
> >> > > >>
> >>
> >> > > >>
> >>
> >> > > >> Question 1: Ok.  Just to make sure I understand this correctly
> >> > > >> -
> >>
> >> > > >> these topology models are intended to be I2RS-specific, and
> >> > > >> they
> >>
> >> > > >> cannot be used for any other purpose.  If anyone needs a
> >> > > >> general
> >>
> >> > > >> topology model outside of the I2RS protocol, they will have to
> >>
> >> > > >> design their own model.  Is this correct?
> >>
> >> > > >>
> >>
> >> > > >>
> >>
> >> > > >>
> >>
> >> > > >> Response 1:  Not really.
> >>
> >> > > > Ok, so are you saying that the models are in fact generic, and
> >> > > > can
> >>
> >> > > > be used outside of I2RS?  I.e., they *can* be used with the
> >> > > > normal
> >>
> >> > > > configuration datastores?
> >>
> >> > > >
> >>
> >> > >
> >>
> >> > > From implementation experience, yes, they can be used for storing
> >>
> >> > > configuration. OpenDaylight uses (an ancient predecessor of)
> >>
> >> > > yang-network-topo to store configure details about devices in its
> >>
> >> > > managed networks.
> >>
> >> > >
> >>
> >> > > Regards,
> >>
> >> > > Robert
> >>
> >> > >
> >>
> >> > >
> >>
> >> >
> >>
> >> > _______________________________________________
> >>
> >> > i2rs mailing list
> >>
> >> >  <mailto:[email-masked]> [email-masked]
> >>
> >> >  <https://www.ietf.org/mailman/listinfo/i2rs>
> >> https://www.ietf.org/mailman/listinfo/i2rs
> >>
> >> >
> >>
> >
> >
>
>

---

From: Giles Heron <[email-masked]>
Date: Wed, 25 Jan 2017 14:03:07 +0000

Hi Alia,

> On 25 Jan 2017, at 13:35, Alia Atlas <[email-masked]> wrote:
> 
> Could one of you who are saying that a writable topology model can appear in the regular configuration data-store please explain:
> 
> How does validation at reboot work when there is dependency on learned topology data that isn't yet available?

um - it can’t? (or I don’t think it can).    But why would you have a writeable topology depend on learned topology data?  Or am I totally misunderstanding your question?

At any rate I’m only thinking of writeable topology in the context of inventory (so stuff that is configured rather than learned from a dynamic protocol) and perhaps intent (so, for example a point-to-point circuit could be expressed in a “service” model as a pair of nodes connected by a pair of unidirectional links with bandwidth parameters etc. - which the network-facing OSS would create by configuring a PWE between the two nodes).

> I'd prefer more technology discussion of the nuances.  This one has been an active topic of discussion for at least 2 years, so I'm hopeful that you all have well thought out answers.

I’m afraid I’ve not followed I2RS closely enough.  When the WG was set up I hoped it would define an ephemeral data store, define that YANG-modelled data could be carried over various transports/encodings (and perhaps define a binary-encoded protocol over an asynchronous transport as an example of such), and then shut itself down.   It has taken a very different path so to a great extent I have disengaged (but remained subscribed to the list).  I only got suck(er)ed into this thread because Juergen mentioned ODL.

I’m not saying that the discussions over traceability, priority, security etc. are wrong but I see them as being largely orthogonal to the issue of ephemeral vs persistent config and to the selection of transport/protocol used to access the NE (just as I see the topology models themselves as being general rather than I2RS-specific).

Giles

> Regards,
> Alia
> 
> On Wed, Jan 25, 2017 at 7:27 AM, Lou Berger <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Sue,
> 
> On January 24, 2017 11:56:32 AM "Susan Hares" <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > To: Martin:
> >
> > decision to make I2RS Yang Modules part of the Control Plane Datastore then
> > From: Martin Bjorklund [mailto:[email-masked] <mailto:[email-masked]>]
> > To: [email-masked] <mailto:[email-masked]>
> > Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> > [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> > [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> > [email-masked] <mailto:[email-masked]>
> > "Susan Hares" <[email-masked] <mailto:[email-masked]>> wrote:
> >> Martin:
> >>
> >>
> >>
> >> .         If you ask if the pre-standardization I2RS Yang Topology models
> >> .         If you ask if the WG LC Topology models are approved to be part
> > of
> > Yes, this is my question.  And my concern is that even if your understanding
> >> From: Martin Bjorklund [mailto:[email-masked] <mailto:[email-masked]>]
> >> To: [email-masked] <mailto:[email-masked]>
> >> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> >> [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> >> [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> >> [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> >> "Susan Hares" < <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>> wrote:
> >>
> >> > Martin:
> >>
> >> >
> >>
> >> > From: i2rs [ <mailto:[email-masked] <mailto:[email-masked]>>
> >> > mailto:[email-masked] <mailto:[email-masked]>]
> >> On Behalf Of Martin
> >>
> >> > Bjorklund
> >>
> >> > To:  <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>
> >>
> >> > Cc:  <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>;
> >> <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;
> >>
> >> >  <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;  <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;
> >>
> >> >  <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>;
> >> <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>; <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>
> >>
> >> > "Susan Hares" < <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>> wrote:
> >>
> >> > > Robert and Martin:
> >>
> >> > >
> >>
> >> > > state.   I will point out that these implementation are pre-standards
> >>
> >> > > configuration data store to a Control Plane data store.   If we follow
> >>
> >> > this
> >>
> >> > > Topology models - if the right details are taken care of.   How do we
> >> make
> >>
> >> > > From: Robert Varga [ <mailto:[email-masked] <mailto:[email-masked]>> mailto:[email-masked] <mailto:[email-masked]>]
> >>
> >> > > To: Martin Bjorklund;  <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>
> >>
> >> > > Cc:  <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>;
> >> <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;
> >>
> >> > >  <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;  <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;
> >>
> >> > >  <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>;  <mailto:[email-masked] <mailto:[email-masked]>>
> >> [email-masked] <mailto:[email-masked]>
> >>
> >> >  <mailto:[email-masked] <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>
> >>
> >> >  <https://www.ietf.org/mailman/listinfo/i2rs <https://www.ietf.org/mailman/listinfo/i2rs>>
> >> https://www.ietf.org/mailman/listinfo/i2rs <https://www.ietf.org/mailman/listinfo/i2rs>
> >>
> >> >
> >>
> >
> >
> 
> 
> [email-masked]

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 09:08:32 -0500

Alia,
On 1/25/2017 8:35 AM, Alia Atlas wrote:
> Could one of you who are saying that a writable topology model can
> appear in the regular configuration data-store please explain:
>
I'm not sure, but there are a bunch of implementations/implementers out
there who can answer what they do.

> I'd prefer more technology discussion of the nuances. 

> This one has been an active topic of discussion for at least 2 years,
> so I'm hopeful that you all have well thought out answers.
>
During that time, the documents has never said anything about being
limited to I2RS/ephemeral state.  The word ephemeral didn't even show up
in the documents (the base topology one at least) until after Seoul. 
I'd like to discuss this one the TEAS list to see what the folks
depending on the model think of such a restriction and if it means a
full reset on the work there or not...

In the interest of limiting cross-posts I'll forward your mail there to
start the discussion.

Lou

> Regards,
> Alia
>
> On Wed, Jan 25, 2017 at 7:27 AM, Lou Berger <[email-masked]
> <mailto:[email-masked]>>wrote:
>
>     Sue,
>
>
>     > Cc: [email-masked] <mailto:[email-masked]>;
>     [email-masked]
>     <mailto:[email-masked]>;
>     > [email-masked]
>     <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>;
>     > [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
>     >> Cc: [email-masked] <mailto:[email-masked]>;
>     [email-masked]
>     <mailto:[email-masked]>;
>     >> [email-masked]
>     <mailto:[email-masked]>;
>     >> [email-masked] <mailto:[email-masked]>;
>     [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>;
>     >> "Susan Hares" < <mailto:[email-masked]
>     <mailto:[email-masked]>> [email-masked]
>     <mailto:[email-masked]>> wrote:
>     >>
>     >> > Martin:
>     >>
>     >> >
>     >>
>     >> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> [email-masked]
>     <mailto:[email-masked]>;
>     >>
>     >> >  <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> [email-masked]
>     <mailto:[email-masked]>; 
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> [email-masked]
>     <mailto:[email-masked]>; <mailto:[email-masked]
>     <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>
>     >>
>     >> > "Susan Hares" < <mailto:[email-masked]
>     <mailto:[email-masked]>> [email-masked]
>     <mailto:[email-masked]>> wrote:
>     >>
>     >> > > Robert and Martin:
>     >>
>     >> > >
>     >>
>     >> > > From: Robert Varga [ <mailto:[email-masked]
>     <mailto:[email-masked]>> mailto:[email-masked] <mailto:[email-masked]>]
>     >>
>     >> > > To: Martin Bjorklund;  <mailto:[email-masked]
>     <mailto:[email-masked]>> [email-masked] <mailto:[email-masked]>
>     >>
>     >> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> [email-masked]
>     <mailto:[email-masked]>;
>     >>
>     >> > >  <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> [email-masked]
>     <mailto:[email-masked]>; 
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >> > >  <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> [email-masked]
>     <mailto:[email-masked]>;  <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >> >  <https://www.ietf.org/mailman/listinfo/i2rs
>     <https://www.ietf.org/mailman/listinfo/i2rs>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 25 Jan 2017 15:52:17 +0100

> topology data that isn't yet available?

A configuration datastore never has a dependency on state data.
Validation is scoped by a datastore. A configuration datastore that is
valid before a report is going to be valid after a reboot. These are
core principles of how NETCONF and YANG work.

For the larger picture how information flows from configuration
datastores to the actual operational state, see the conceptual
datastore discussions in NETMOD.
 
/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 25 Jan 2017 10:07:45 -0500

Juergen,

> datastore discussions in NETMOD.

Thank you for confirming my understanding.

So - if one has models - such as a writable topology - where there can be
dependencies on dynamic data, then those models can't be in the
configuration
data-store as currently defined.

Regards,
Alia

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 25 Jan 2017 16:18:02 +0100

On Wed, Jan 25, 2017 at 10:07:45AM -0500, Alia Atlas wrote:
> 
> So - if one has models - such as a writable topology - where there
> can be dependencies on dynamic data, then those models can't be in
> the configuration data-store as currently defined.
>

Yes.

/js

---

From: Giles Heron <[email-masked]>
Date: Wed, 25 Jan 2017 15:19:58 +0000

> On 25 Jan 2017, at 15:18, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> Yes

but isn’t this confusing models and implementation?

if you have a case where you have a dependency on dynamic data then you can’t put that instantiation of the model in the configuration data-store.

but if your implementation never depends on dynamic data then it ought to be fine.

or again am I missing something obvious?

more to the point.  Alia - what’s the dependency on dynamic data that you’re concerned about?

Giles

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 25 Jan 2017 16:33:27 +0100

> but isn’t this confusing models and implementation?

I just confirmed that the old datastore model does not support
writable ephemeral datastores. No more no less. And there is work in
NETMOD (and NETCONF) to revise the datastore model and to make data
model reuse in different datastores even simpler.
 
> but if your implementation never depends on dynamic data then it ought to be fine.

Yes. This should be fine.

And with the revised datastore model it will also be straight forward
to have an implementation that just exposes topological data via the
operational state datastore.  And the revised datastore model also
paves the path to support datastores that can also inject ephemeral
data.

/js

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 12:52:47 -0500

Juergen: 
 
"And with the revised datastore model it will also be straight forward to have an implementation that just exposes topological data via the operational state datastore.  And the revised datastore model also paves the path to support datastores that can also inject ephemeral data."

Where do you believe the revised data store model suggest ephemeral data can be injected - (?written)? 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, January 25, 2017 10:33 AM
To: Giles Heron
Cc: [email-masked]; [email-masked]; Lou Berger; [email-masked]; Alia Atlas
Subject: Re: [i2rs] Kathleen Moriarty's No Objection on draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)

> but isn’t this confusing models and implementation?

I just confirmed that the old datastore model does not support writable ephemeral datastores. No more no less. And there is work in NETMOD (and NETCONF) to revise the datastore model and to make data model reuse in different datastores even simpler.

And with the revised datastore model it will also be straight forward to have an implementation that just exposes topological data via the operational state datastore.  And the revised datastore model also paves the path to support datastores that can also inject ephemeral data.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 25 Jan 2017 19:53:30 +0100

Sue,

the current thinking is documented in
draft-ietf-netmod-revised-datastores-00.txt.

/js

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 13:58:13 -0500

Juergen: 

Where do you think the revised data store model in that draft suggests ephemeral data stores live? 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, January 25, 2017 1:54 PM
To: Susan Hares
Cc: [email-masked]; [email-masked]; 'Alia Atlas'; 'Giles Heron'; [email-masked]; 'Lou Berger'
Subject: Re: [i2rs] Kathleen Moriarty's No Objection on draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)

Sue,

/js

On Wed, Jan 25, 2017 at 12:52:47PM -0500, Susan Hares wrote:
> > >> So - if one has models - such as a writable topology - where 
> > >> there can be dependencies on dynamic data, then those models 
> > >> can't be in the configuration data-store as currently defined.
> > >> 
> > > 
> > > Yes
> >

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 25 Jan 2017 20:05:03 +0100

Just search for ephemeral in the document and you will hit this:

   The model foresees control-plane datastores that are by definition
   not part of the persistent configuration of a device.  In some
   contexts, these have been termed ephemeral datastores since the
   information is ephemeral, i.e., lost upon reboot.  The control-plane
   datastores interact with the rest of the system through the <applied>
   or <operational-state> datastores, depending on the type of data they
   contain.  Note that the ephemeral datastore discussed in I2RS
   documents maps to a control-plane datastore in the revised datastore
   model described here.

/js

---

From: Andy Bierman <[email-masked]>
Date: Wed, 25 Jan 2017 11:12:46 -0800

>    documents maps to a control-plane datastore in the revised datastore

The modules in draft-ietf-i2rs-yang-l3-topology-08
and draft-ietf-i2rs-yang-network-topo-10
appear to contain only configuration data nodes. They are mandatory to
implement.

>From RFC 7950:

7.21.1.  The "config" Statement

   The "config" statement takes as an argument the string "true" or
   "false".  If "config" is "true", the definition represents
   configuration.  Data nodes representing configuration are part of
   configuration datastores.

   If "config" is "false", the definition represents state data.  Data
   nodes representing state data are not part of configuration
   datastores.

If these nodes are not intended to be part of configuration datastores,
then the nodes need to marked as "config false".

> /js
Andy

> > Cc: [email-masked]; [email-masked]; 'Alia
> Atlas'; 'Giles Heron'; [email-masked]; 'Lou Berger'
> > > "And with the revised datastore model it will also be straight forward
> operational state datastore.  And the revised datastore model also paves
> the path to support datastores that can also inject ephemeral data."
> > >
> > > > > On 25 Jan 2017, at 15:18, Juergen Schoenwaelder <
> writable ephemeral datastores. No more no less. And there is work in NETMOD
> (and NETCONF) to revise the datastore model and to make data model reuse in
> different datastores even simpler.
> > >
> > > > if you have a case where you have a dependency on dynamic data then
> you can’t put that instantiation of the model in the configuration
> data-store.
> > > >
> operational state datastore.  And the revised datastore model also paves
> the path to support datastores that can also inject ephemeral data.
> > >
> > > /js
> > >
> > > --

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 17:32:22 -0500

Juergen :

OK - I agree with the document section you've quoted.  Are there other ephemeral data stores?   Is <get-data datastore> and <write-data datastore> a reasonable extension of NETCONF to read/write from these datastores? 

Sue  

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, January 25, 2017 2:05 PM
To: Susan Hares
Cc: [email-masked]; [email-masked]; 'Alia Atlas'; 'Giles Heron'; [email-masked]; 'Lou Berger'
Subject: Re: [i2rs] Kathleen Moriarty's No Objection on draft-ietf-i2rs-yang-l3-topology-08: (with COMMENT)

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Jan 2017 08:48:32 +0100

It will be up to the NETCONF WG to define the name and the semantics
of the operations needed.

/js