Subject: [i2rs] Rtgdir early review of draft-ietf-i2rs-yang-l3-topology-10

From: Christian Hopps <[email-masked]>
Date: Sat, 08 Jul 2017 01:15:31 -0700

Reviewer: Christian Hopps
Review result: Has Nits

Hello,

I have been selected to do a routing directorate “early” review of this draft.

  https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/

The purpose of this review is to determine it's compatibility with the new
revised datastore model guidelines.

For more information about the Routing Directorate, please see
​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Document: draft-ietf-i2rs-yang-l3-topology-10.txt
Reviewer: Christian Hopps
Review Date: July 8, 2017
Intended Status: Standards Track

Summary:

- This document is basically ready for publication, but has nits that should be
  considered prior to being submitted to the IESG.

Comments:

- This document adapts the suggested NMDA guidelines quite nicely.

- Perhaps an informative reference to the NMDA guidelines draft would be useful.

- Appendix A: Second Paragraph, last sentence:
  - I believe that it should say:

      "instead of ietf-network and ietf-network-topology"

    it currently says:

      "instead of ietf-network and ietf-network-state"

- IS-IS example model (sorry couldn't help myself :)

  - The example IS-IS l3-node-attributes augmentation isis-node-attributes
    includes an "iso-pseudonode-id". This isn't a node attribute, but rather a
    link one (it is repeated later under link attributes).

  - The isis-wg suggests to use "IS-IS" consistently, where possible, in
    documents rather than "isis" or "ISIS".

---

From: Alexander Clemm <[email-masked]>
Date: Mon, 10 Jul 2017 18:16:55 +0000

Hello Christian,

Thank you for your review.  We will apply the suggested updates.

--- Alex

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Christian Hopps
Sent: Saturday, July 08, 2017 1:16 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [i2rs] Rtgdir early review of draft-ietf-i2rs-yang-l3-topology-10

Hello,

The purpose of this review is to determine it's compatibility with the new revised datastore model guidelines.

For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Summary:

Comments:

    it currently says:

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs