Subject: Re: [i2rs] draft-ietf-i2rs-yang-dc-fabric-network-topology - WG LC from 11/28 to 12/12/2017

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Wed, 29 Nov 2017 12:50:20 +0000

Hi Alex,

Thank you very much for the comments : ) We’ve updated them in the new version -02 as posted.

Best Regards,

Yan

发件人: i2rs [mailto:[email-masked]] 代表 Alexander Clemm
发送时间: 2017年11月29日 3:44
收件人: Susan Hares <[email-masked]>; [email-masked]
主题: Re: [i2rs] draft-ietf-i2rs-yang-dc-fabric-network-topology - WG LC from 11/28 to 12/12/2017

Hi,

I did a quick review of this.  I support publication of this yang module.  I think the draft is in good shape.

I do have a few very minor nits which should be easy to address:

-          There are a few formatting issues of the –state module, such as inconsistent indentations (sometimes 2, sometimes 4, sometimes 8 spaces) or elements at the same level indented differently.

-          Leaf “bandwith” should be renamed “bandwidth” (for correct spelling)

-          I am wondering whether identity+identityref might be a better choice than enumeration types for port-type enumeration (with regards to extensibility).  Same for bandwith (or at least include choice “other”?).   I don’t feel strongly about this but it’s a possible consideration.

-          Name of “fabric-attribute”.  This is not really a single attribute.  Just call it “fabric” (as a whole), or make it plural?  Again, just for consideration.

Thanks
--- Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, November 28, 2017 5:56 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [i2rs] draft-ietf-i2rs-yang-dc-fabric-network-topology - WG LC from 11/28 to 12/12/2017

This begins a 2 week WG LC on the I2RS draft draft-ietf-i2rs-yang-dc-fabric-network-topology from 11/28 to 12/12/2017.

https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-dc-fabric-network-topology/

The authors should indicate if they know of any IPR relating to this draft.

Please consider during your WG LC review, the following questions:

1)      Do you know of any implementations of this draft?

2)      Does this draft adhere to the Network Management Datastore architecture (NMDA)?

3)      Do you know of any technical issues with this yang module?

4)      Will the deployment of this yang module aid the management of Data Center Fabrics?

5)      Do you support publication of this yang module?

Sue Hares

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 29 Nov 2017 17:51:56 +0000

Thanks, Yan.

I looked at the update.  This looks really good now.  Support.

--- Alex

From: Zhuangyan (Yan)
Sent: Wednesday, November 29, 2017 4:50 AM
To: Alexander Clemm <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [i2rs] draft-ietf-i2rs-yang-dc-fabric-network-topology - WG LC from 11/28 to 12/12/2017

Hi Alex,

Best Regards,

Yan

发件人: i2rs [mailto:[email-masked]] 代表 Alexander Clemm
发送时间: 2017年11月29日 3:44
收件人: Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: [i2rs] draft-ietf-i2rs-yang-dc-fabric-network-topology - WG LC from 11/28 to 12/12/2017

Hi,

Thanks
--- Alex

Sue Hares