Subject: Re: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo (9/27/2017 to 10/11/2017) - WG Consensus declared by Chairs

From: "Susan Hares" <[email-masked]>
Date: Sat, 11 Nov 2017 20:13:06 -0500

Alex: 

I had hoped to celebrate IETF-100 with submitting
draft-ietf-i2rs-yang-network-topo-17 to the IESG.  However, there are still
a few things to resolve from Kent Watens review
(https://www.ietf.org/mail-archive/web/i2rs/current/msg04501.html). 

In reviewing draft-ietf-i2rs-yang-network-topo-17, I found the following
things addressed: 

1)      "ietf-network" uses prefix "nd", should be "nw" and
"ietf-network-topology" uses  prefix "lnk" should be "nt" or maybe "nwtp".

2)      the groupings "link-ref" and "tp-ref" descriptions should indicate
why they are defined but not used in these modules

3)     Both /nd:networks/network/network-id and
/nd:networks/network/link/link-id are the key fields to their respective
lists, but they are not the first nodes listed in the list.

In reviewing draft-ietf-i2rs-yang-network-topo-17, I do not find the
following things address that Ken commented on: 

1)      Kent's comment: Use cases exist in appendix A, but yang examples do
not exist.  

Fix: Short examples could be put in Appendix A with each use case) 

2)      Kent's comment: The document defines its own "datastore" term,
rather than import the term from revised-datastores.  

Question: Section 3 still gives its own datastore definition.  Is there a
reason I missed on this approach? 

Could you wrap up these two issues today and submit a -18 to the IETF
drafts?  I'd love to chat today about these two issues. 

Susan Hares

(shepherd/co-chair) 

She

---

From: Alexander Clemm <[email-masked]>
Date: Sun, 12 Nov 2017 01:40:05 +0000 (UTC)

Hi Sue, I just arrived in Singapore.

I did adopt the definition. This is addressed in -17. 

I did not put the example per earlier email exchange and at the time Kent seemed to be fine with that?

Thanks, Alex

Get Outlook for Android

On Sun, Nov 12, 2017 at 9:13 AM +0800, "Susan Hares" <[email-masked]> wrote:

Alex: 

I had hoped to celebrate IETF-100 with submitting draft-ietf-i2rs-yang-network-topo-17 to the IESG.  However, there are still a few things to resolve from Kent Watens review (https://www.ietf.org/mail-archive/web/i2rs/current/msg04501.html). 

In reviewing draft-ietf-i2rs-yang-network-topo-17, I found the following things addressed: 

1)      "ietf-network" uses prefix “nd”, should be “nw” and "ietf-network-topology" uses  prefix “lnk” should be “nt” or maybe “nwtp”.    

2)      the groupings "link-ref" and "tp-ref" descriptions should indicate why they are defined but not used in these modules

3)     Both /nd:networks/network/network-id and /nd:networks/network/link/link-id are the key fields to their respective lists, but they are not the first nodes listed in the list.

In reviewing draft-ietf-i2rs-yang-network-topo-17, I do not find the following things address that Ken commented on: 

1)      Kent’s comment: Use cases exist in appendix A, but yang examples do not exist.  

2)      Kent’s comment: The document defines its own "datastore" term, rather than import the term from revised-datastores.  

Question: Section 3 still gives its own datastore definition.  Is there a reason I missed on this approach? 

Could you wrap up these two issues today and submit a -18 to the IETF drafts?  I’d love to chat today about these two issues. 

Susan Hares

(shepherd/co-chair) 

She

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 11 Nov 2017 20:47:51 -0500

Alex: 

Welcome to Singapore.  Wow!  Today’s going to be a long day for you.  Perhaps we should talk after you take a short nap. 

#1 definition - Section 3 still defines datastore uniquely, although you do point to the revised datastores.  It would be best to make the same reference in section 3. 

#2 No examples – Please confirm by asking Kent Watsen on list regarding the examples.   Otherwise, we’ll cycle on this when we get to the IESG. 

Also – please see the comments that were unresolved from Lada’s review of the L3 topology.   

Sue Hares 

From: Alexander Clemm [mailto:[email-masked]] 
Sent: Saturday, November 11, 2017 8:40 PM
To: [email-masked]; Susan Hares
Cc: 'Kent Watsen'; [email-masked]; [email-masked]; 'Alia Atlas'
Subject: Re: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo (9/27/2017 to 10/11/2017) - WG Consensus declared by Chairs

Thanks, Alex

Get Outlook for Android <https://aka.ms/ghei36> 

Alex: 

Susan Hares

(shepherd/co-chair) 

She

---

From: Kent Watsen <[email-masked]>
Date: Mon, 13 Nov 2017 04:50:40 +0000

The general YANG Doctor opinion is that all drafts defining YANG modules should have examples, since the examples both aid in understandability and sometimes reveal modeling issues that are otherwise hard to spot.  To underscore this point further, the YANG Doctors even discussed introducing some form of automatic "coverage" analysis, whereby tooling could e.g., ensure that at least 50% of the YANG module is represented by [valid] examples.

I'm "fine" with the draft not having examples only from a "I leave it to the WG" perspective, nothing more.

Thanks,
Kent

On 11/12/17, 9:47 AM, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:

Alex:

Sue Hares

Hi Sue, I just arrived in Singapore.
I did adopt the definition. This is addressed in -17.
I did not put the example per earlier email exchange and at the time Kent seemed to be fine with that?
Thanks, Alex
Get Outlook for Android<https://urldefense.proofpoint.com/v2/url?u=https-3A__aka.ms_ghei36&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=t8pOsw3tC3mILKdk134_MbPZFNVMLeervd-i6zRDV2o&s=qeZ30IlyTpK5lxQ5undCEnBFHT9AO_lD67H_jCvl_8w&e=>

On Sun, Nov 12, 2017 at 9:13 AM +0800, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:
Alex:

I had hoped to celebrate IETF-100 with submitting draft-ietf-i2rs-yang-network-topo-17 to the IESG.  However, there are still a few things to resolve from Kent Watens review (https://www.ietf.org/mail-archive/web/i2rs/current/msg04501.html<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail-2Darchive_web_i2rs_current_msg04501.html&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=t8pOsw3tC3mILKdk134_MbPZFNVMLeervd-i6zRDV2o&s=UAV82_bxO-NUzQRpiHv9Tdv86055JtWw6Z_N4aEhiN8&e=>).

She