Subject: [Ietf-and-github] Legal notices (was: Re: A possible way of keeping WG informed of github tracked issues?

From: Martin Thomson <[email-masked]>
Date: Mon, 1 Feb 2016 11:09:00 +1100

Now with fewer fat fingers.

On 1 February 2016 at 11:08, Martin Thomson <[email-masked]> wrote:
> On 30 January 2016 at 13:57, Brian E Carpenter
> <[email-masked]> wrote:
>> Also, we need counsel's opinion on how we ensure that IETF process
>> rules apply to everything that happens on gh. Some of us have
>> put some words in the readme for the repo. Is that enough?
>
> That's a good question, probably worthy of a new thread.
>
> This is what a lot of repos have in them:

https://github.com/martinthomson/i-d-template/blob/master/template/CONTRIBUTING.md

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 1 Feb 2016 11:54:45 +1100

> On 1 Feb 2016, at 11:09 am, Martin Thomson <[email-masked]> wrote:
> 

For those who don't know - if a file named CONTRIBUTING.md is in a github repo, a prominent link to it is created in a number of places that allow people to interact with the repo; e.g.,
  https://github.com/httpwg/http-extensions/issues/new

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 1 Feb 2016 01:08:05 +0000

GitHub is wporking on support for CLA's.  The IETF CLA could be as simple as "I acknowledge the note well" if we're interested in that.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Feb 2016 15:24:44 +1300

>   https://github.com/httpwg/http-extensions/issues/new

IANAL, but my understanding is that it is generally better to point to the official
rules than to generate copies in each place or to add explanatory material
that might unintentionally modify the interpretation. So maybe we should
create a short CONTRIBUTING.md and request the IETF counsel to check it.

   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 1 Feb 2016 13:39:28 +1100

> On 1 Feb 2016, at 1:24 pm, Brian E Carpenter <[email-masked]> wrote:
> 

I think that's the function of NOTE WELL, isn't it?

Each WG might have additional information they want to add, so I don't think we could have each one be exactly the same, but maybe what we need is ( NOTE_WELL + ADDITIONAL_GITHUB_SPECIFICS? + WG_STUFF ).

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Feb 2016 16:04:44 +1300

> Each WG might have additional information they want to add, so I don't think we could have each one be exactly the same, but maybe what we need is ( NOTE_WELL + ADDITIONAL_GITHUB_SPECIFICS? + WG_ST…

Sure, but the NOTE WELL is not a universal constant, and may change from time to time, which is why I used:

This repository is for an IETF effort and falls under IETF rules: see http://www.ietf.org/about/note-well.html

    Brian