Subject: [Ietf-and-github] New Non-WG Mailing List: Ietf-and-github -- Discussion of using GitHub in IETF activities, particularly for Working Groups

From: IETF Secretariat <[email-masked]>
Date: Tue, 26 Jan 2016 08:37:08 -0800

A new IETF non-working group email list has been created.

List address: [email-masked]
Archive: https://mailarchive.ietf.org/arch/search/?email_list=ietf-and-github
To subscribe: https://www.ietf.org/mailman/listinfo/ietf-and-github

Purpose:

GitHub is being used by more IETF Working Groups for proposing and tracking changes to WG Internet-Drafts. Using GitHub for normal WG processes requires some training, and edge cases in its usage abound. This list will be used for answering questions of individual WG participants and for creating IETF-wide documentation on how to use GitHub effectively in WG processes.

For additional information, please contact the list administrators.

---

From: Benson Schliesser <[email-masked]>
Date: Fri, 29 Jan 2016 11:28:29 -0500

I've changed the To: to point to the ietf-and-github@ mailing list for this
discussion, and moved the ietf@ list to a BCC: header for this message. I
think it's more appropriate for talking about this specific issue...
-Benson

On Fri, Jan 29, 2016 at 10:44 AM, Andrew G. Malis <[email-masked]> wrote:

> The IETF’s primary collaborative tool is email. Right now it’s very easy
> to find the email archive for any WG, and to come up to speed on the WG
> discussion. This would be much more difficult if WGs used github or other
> third party tools for discussions that might otherwise have used the WG’s
> email list. Any public discussions regarding WG business should remain on
> the current email lists unless and until they are formally replaced or
> augmented so that people still only have to go to one place to stay current
> with WG discussions. I don’t mind an eventual replacement of email lists
> for WG business, as long as the change is formal, supported, and consistent
> across all WGs.
>
> And stay off of my lawn!
>
> Curmudgeonly yours,
> Andy
>
> On Fri, Jan 29, 2016 at 9:11 AM, Eliot Lear <[email-masked]> wrote:
>
>> Hi Bob,
>>
>> All the way down...
>>
>> On 1/28/16 6:02 PM, Bob Hinden wrote:
>> > Eliot,
>> >
>> >> On Jan 28, 2016, at 4:55 AM, Eliot Lear <[email-masked]> wrote:
>> >>
>> >> Jari,
>> >>
>> >> I have no conceptual problem with github being used for draft
>> >> development or being integrated in our tools process for state changes,
>> >> or archiving of discussions, but I would maintain strong objections to
>> >> any approach that would lead to bifurcation of discussion on a topic.
>> >> That is- the technology and our relationships with those providing the
>> >> service should be conducive to a single integrated conversation on a
>> topic.
>> > To say this another way, using github (or other collaboration tools) is
>> great for authors or a design team to work together to develop an Internet
>> draft.  I do this myself.  I think the dividing line is that drafts should
>> continue to be submitted via the datatracker as they are now and working
>> groups be using the datatracker to do their work.  I would be very
>> concerned if working groups started to do their work outside of the
>> datatracker.
>> >
>>
>> Yes, and. Discussion of technical issues should remain normatively
>> within a single platform.  If we want that to be github, okay. But today
>> it's email.  Doing both would at first glance sound like reaching out to
>> people who prefer different modes of communications, but at the end of
>> the day proves quite difficult for those who are actually trying to keep
>> track of multiple threads in a conversation.  Also, any platform should
>> be able to support our processes, particular those that help us address
>> abuse.
>>
>> Eliot
>>
>>
>>
>

---

From: Benson Schliesser <[email-masked]>
Date: Fri, 29 Jan 2016 11:31:25 -0500

I use Github, but not in any extensive way.

In my experience, it seems to me that some of the open source projects out
there are fairly successful at connecting Github and email lists... For
example by having emails sent for certain events that happen via git, and
so forth.

Can somebody more experienced in this area provide insight on what we can
do, how, etc, and what gaps may exist?

Thanks,
-Benson

On Fri, Jan 29, 2016 at 11:28 AM, Benson Schliesser <[email-masked]>
wrote:

> I've changed the To: to point to the ietf-and-github@ mailing list for
> this discussion, and moved the ietf@ list to a BCC: header for this
> message. I think it's more appropriate for talking about this specific
> issue...
> -Benson
>
>
>>> > To say this another way, using github (or other collaboration tools)
>>> is great for authors or a design team to work together to develop an
>>> Internet draft.  I do this myself.  I think the dividing line is that
>>> drafts should continue to be submitted via the datatracker as they are now
>>> and working groups be using the datatracker to do their work.  I would be
>>> very concerned if working groups started to do their work outside of the
>>> datatracker.
>>> >
>>>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 29 Jan 2016 18:42:44 +0000

When you create a project in github, you can set it up such that the IETF working group mailing list is "watching" the project and receives email notifications of all activity, comments, etc. within the project.

Cheers,
Charles

From: Ietf-and-github <[email-masked]<mailto:[email-masked]>> on behalf of Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Friday, January 29, 2016 at 9:31 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: John C Klensin <[email-masked]<mailto:[email-masked]>>, "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>, Bob Hinden <[email-masked]<mailto:[email-masked]>>, Dave Crocker <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ietf-and-github] New Non-WG Mailing List: Ietf-and-github -- Discussion of using GitHub in IETF activities, particularly for Working Groups

In my experience, it seems to me that some of the open source projects out there are fairly successful at connecting Github and email lists... For example by having emails sent for certain events that happen via git, and so forth.

Can somebody more experienced in this area provide insight on what we can do, how, etc, and what gaps may exist?

Thanks,
-Benson

On Fri, Jan 29, 2016 at 11:28 AM, Benson Schliesser <[email-masked]<mailto:[email-masked]>> wrote:
I've changed the To: to point to the ietf-and-github@ mailing list for this discussion, and moved the ietf@ list to a BCC: header for this message. I think it's more appropriate for talking about this specific issue...
-Benson

On Fri, Jan 29, 2016 at 10:44 AM, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
The IETF's primary collaborative tool is email. Right now it's very easy to find the email archive for any WG, and to come up to speed on the WG discussion. This would be much more difficult if WGs used github or other third party tools for discussions that might otherwise have used the WG's email list. Any public discussions regarding WG business should remain on the current email lists unless and until they are formally replaced or augmented so that people still only have to go to one place to stay current with WG discussions. I don't mind an eventual replacement of email lists for WG business, as long as the change is formal, supported, and consistent across all WGs.

And stay off of my lawn!

Curmudgeonly yours,
Andy

On Fri, Jan 29, 2016 at 9:11 AM, Eliot Lear <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bob,

All the way down...

On 1/28/16 6:02 PM, Bob Hinden wrote:
> Eliot,
>
>> On Jan 28, 2016, at 4:55 AM, Eliot Lear <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Jari,
>>
>> service should be conducive to a single integrated conversation on a topic.
> To say this another way, using github (or other collaboration tools) is great for authors or a design team to work together to develop an Internet draft.  I do this myself.  I think the dividing line is that drafts should continue to be submitted via the datatracker as they are now and working groups be using the datatracker to do their work.  I would be very concerned if working groups started to do their work outside of the datatracker.
>

Eliot