Subject: [Ietf-and-github] Fwd: [www.ietf.org/rt #225789] IESG statement on License File for Open Source Repositories

From: Brian E Carpenter <[email-masked]>
Date: Fri, 20 Jul 2018 10:33:09 +1200

FYI

-------- Forwarded Message --------
Subject: [www.ietf.org/rt #225789] IESG statement on License File for Open Source Repositories
Date: Thu, 19 Jul 2018 14:09:54 -0700
From: Cindy Morgan via RT <[email-masked]>
Reply-To: [email-masked]
To: [email-masked]

Hi Brian,

This has been added to the IESG statements on the website: <https://www.ietf.org/blog/license-file-open-source-repositories/?primary_topic=7&>

Best regards,
Cindy

On Tue Jul 17 15:00:52 2018, [email-masked] wrote:

  Hi,
  
  I was looking for the IETF statement on licensing statements for GitHub repositories and couldn't find it. I believe that the following message should be in the list of IESG statements:
  https://www.ietf.org/mail-archive/web/ietf-announce/current/msg16347.html
   
  Regards
     Brian Carpenter

---

From: Erik Kline <[email-masked]>
Date: Thu, 19 Jul 2018 18:38:50 -0400

Is there any chance that some place like https://github.com/ietf could
host a repository of official versions of critical text (contributing,
note well, ...)?  (maybe even in multiple versions?)
On Thu, 19 Jul 2018 at 18:33, Brian E Carpenter
<[email-masked]> wrote:
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 20 Jul 2018 10:43:19 +1200

> note well, ...)?  (maybe even in multiple versions?)

Personal opinion: the *official* version of an IESG statement belongs
where Cindy has just put it. But having a stable copy in a well-defined
repo seems like a Good Idea.

   Brian