Subject: [Ietf-and-github] Working group metadata discoverability and quality

From: Mark Nottingham <[email-masked]>
Date: Thu, 4 Oct 2018 12:57:51 +1000

Hello,

A request from a researcher got me thinking -- they wanted to know the most effective way to search mailing and issues lists across the IETF.

We do mailing lists pretty well, but since we're moving to GitHub, it's more difficult to easily find this information in a uniform fashion. More generally, as more and more WGs use GitHub, managing information about them is going to be more difficult.

The W3C has embraced GitHub strongly, and it might be worth taking a look at what they do in this area. For example, they define a small JSON file to contain repo metadata, so that they can automatically collect org-specific information. See:
  https://w3c.github.io/w3c.json.html

The most obvious application of this sort of technique for me is to adapt how the tools and data tracker link to various WG artefacts. For example, datatracker could use this to turn off the TRAC links for the working group, and point to the appropriate places on GitHub instead. We could even look at hooking up a repo to the materials for a group, so chairs didn't have to keep them in sync (see <https://github.com/httpwg/wg-materials/> and <https://github.com/quicwg/wg-materials/>). 

See also:
  https://w3c.github.io <-- how W3C uses GitHub generally
  https://github.com/w3c/w3c-api  <-- a HTTP API that W3C exposes

Thoughts?

--
Mark Nottingham   https://www.mnot.net/

---

From: Lars Eggert <[email-masked]>
Date: Thu, 4 Oct 2018 08:55:44 +0300

Hi,

> A request from a researcher got me thinking -- they wanted to know the most effective way to search mailing and issues lists across the IETF.

Niels & folks have been doing a hackathon project (https://datactive.github.io/bigbang/) that is doing just that - they might have an idea about tooling.

Lars

> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Oct 2018 13:43:16 +1100

That's interesting. However, I was thinking more about augmenting the data tracker with additional information, so that we could find and display relevant metadata in our systems, as well as allow third parties to find / use it.

E.g., we're continuously having discussions about how people file errata that aren't appropriate, but we don't give them good advice about how to raise issues with existing RFCs. If there were the ability to associate an issue tracker with a published RFC and it was highlighted in the tools.ietf.org/html page (and elsewhere), I think that would be very useful. The errata page could also take advantage of this information, and direct people who aren't filing "real" errata to the right place.

Cheers,

> On 4 Oct 2018, at 3:55 pm, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Oct 2018 17:41:16 +1100

Oh, you mean simple things like:

https://trac.tools.ietf.org/tools/ietfdb/ticket/2548
https://trac.tools.ietf.org/tools/ietfdb/ticket/2549
https://trac.tools.ietf.org/tools/ietfdb/ticket/2550

Along with the UX to present that information.  ?

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Oct 2018 17:46:46 +1100

Yarp.

> On 10 Oct 2018, at 5:41 pm, Martin Thomson <[email-masked]> wrote:
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Oct 2018 17:52:10 +1100

To extend this -- if there were a well-known way to find an issues list for a given RFC, and a stable URL for it (possibly provided by a redirection service, possibly hosted by the IETF), we could advertise that in RFCs themselves, so that the errata aren't crowded out by people asking questions and discussing more substantive issues.