Subject: Re: [Ietf-and-github] New version of draft-cooper-wugh-github-wg-configuration

From: Christer Holmberg <[email-masked]>
Date: Mon, 17 Dec 2018 15:52:14 +0000

Hi,

Question for clarification.

Section 3.2 says:

   "Every IETF working group repository on GitHub will have a mirror
   repository of the same name on a server maintained by the IETF
   Secretariat."

What exactly does "server maintained by the IETF" mean? Is the idea that IETF would maintain a GitHub server (GitHub Enterprise)? 

Regards,

Christer

On 17/12/2018, 17.35, "Ietf-and-github on behalf of Paul Hoffman" <[email-masked] on behalf of [email-masked]> wrote:

    Greetings again. Alissa and I updated our draft based on what we heard from BoF meeting in Bangkok. Hopefully this contributes to the discussion of the proposed charter.
    
    --Paul Hoffman
    
    A New Internet-Draft is available from the on-line Internet-Drafts directories. 

    Title : GitHub Configuration for IETF Working Groups 
    Authors : Alissa Cooper 
    Paul Hoffman 
    Filename : draft-cooper-wugh-github-wg-configuration-02.txt 
    Pages : 7 
    Date : 2018-12-17 
    
    Abstract: 
    The use of GitHub in IETF working group processes is increasing. 
    This document describes possible uses and conventions for working 
    groups which are considering starting to use GitHub. It does not 
    mandate any processes, and does not intend to change the processes 
    used by current working groups. 
    
    Discussion of this document takes place on the ietf-and-github 
    mailing list ([email-masked]), which is archived at 
    <https://mailarchive.ietf.org/arch/search?email_list=ietf-and- 
    github>. 

    The IETF datatracker status page for this draft is: 
    https://datatracker.ietf.org/doc/draft-cooper-wugh-github-wg-configuration/
    
    There are also htmlized versions available at: 
    https://tools.ietf.org/html/draft-cooper-wugh-github-wg-configuration-02
    https://datatracker.ietf.org/doc/html/draft-cooper-wugh-github-wg-configuration-02
    
    A diff from the previous version is available at: 
    https://www.ietf.org/rfcdiff?url2=draft-cooper-wugh-github-wg-configuration-02

    Please note that it may take a couple of minutes from the time of submission 
    until the htmlized version and diff are available at tools.ietf.org. 
    
    Internet-Drafts are also available by anonymous FTP at: 
    ftp://ftp.ietf.org/internet-drafts/

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 17 Dec 2018 16:14:56 +0000

>    What exactly does "server maintained by the IETF" mean? Is the idea that IETF would maintain a GitHub server (GitHub Enterprise)? 
  
It means only the GIT repository(ies), unless they are using the common terminology strangely.

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 17 Dec 2018 16:19:11 +0000

Hi,

>    It means only the GIT repository(ies), unless they are using the common terminology strangely.

So, the secretariat is basically just going to clone each repository, and then regularly fetch the content like any user?

If so, I think that should be clarified, because at least the way I read the text it seems like the secretariat is going to maintain a GitHub server.

Regards,

Christer