Subject: [Ietf-and-github] Suresh Krishnan's Yes on charter-ietf-git-00-00: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Wed, 23 Jan 2019 20:23:37 -0800

Suresh Krishnan has entered the following ballot position for
charter-ietf-git-00-00: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-git/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

If possible, I would like to see some mention in the charter regarding
mirroring of the github repositories on the IETF side.

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Jan 2019 17:58:22 +1100

> mirroring of the github repositories on the IETF side.

Is that better as input to the working group (and their interactions with the tools team), or a requirement that needs charter-level protection?

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 24 Jan 2019 08:13:31 -0600

Just chiming in on Suresh's comment thread.

On Thu, Jan 24, 2019 at 12:58 AM Martin Thomson <[email-masked]> wrote:

> Is that better as input to the working group (and their interactions with
> the tools team), or a requirement that needs charter-level protection?
>

On this specific point, I think that questions about mirroring should be in
scope for the working group, and I don't think the charter can reasonably
be read as declaring those conversations out of scope, but ISTM that
language like "The GitHub Integration and Tooling (GIT) working group will
select a set of such practices and document policies that support those
practices" is focused on what working groups might do, not what the IETF
might do on behalf of working groups. So, this could be clearer.

But just to uplevel, perhaps Suresh is asking a specific question that
might (or might not) point to a general topic for the charter.

Because Github is a resource we don't control, I suspect the community
would like to have a sense that there's a contingency plan for working
groups that are significantly wrapped Gitbub (and there are more every
year), if Github for some reason is no longer a suitable place for IETF
working groups, beyond "well, back to the e-mail lists, right?".

Do we have a sense of whether that's true? And, if it is true, do we know
who is on the hook to develop that contingency plan?

If it's the IESG, or the secretariat, or the tools team, or
I-don't-know-who-else, that's fine, but if this working group could provide
recommendations about those practices, would that be in scope, or not?

Thanks,

Spencer

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 24 Jan 2019 09:23:17 -0500

> On Jan 24, 2019, at 9:13 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> On Thu, Jan 24, 2019 at 12:58 AM Martin Thomson <[email-masked] <mailto:[email-masked]>> wrote:
> On this specific point, I think that questions about mirroring should be in scope for the working group, and I don't think the charter can reasonably be read as declaring those conversations out of scope, but ISTM that language like "The GitHub Integration and Tooling (GIT) working group will select a set of such practices and document policies that support those practices" is focused on what working groups might do, not what the IETF might do on behalf of working groups. So, this could be clearer. 

I think this is quite clear. If people disagree, suggesting a specific change would help.

> 
> But just to uplevel, perhaps Suresh is asking a specific question that might (or might not) point to a general topic for the charter. 
> 
> Because Github is a resource we don't control, I suspect the community would like to have a sense that there's a contingency plan for working groups that are significantly wrapped Gitbub (and there are more every year), if Github for some reason is no longer a suitable place for IETF working groups, beyond "well, back to the e-mail lists, right?".
> 
> Do we have a sense of whether that's true? And, if it is true, do we know who is on the hook to develop that contingency plan? 
> 
> If it's the IESG, or the secretariat, or the tools team, or I-don't-know-who-else, that's fine, but if this working group could provide recommendations about those practices, would that be in scope, or not? 

I think this is clearly in scope, already discussed in the drafts, and too much of a detail to be included in the charter language itself.

Alissa

> 
> Thanks,
> 
> Spencer
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 Jan 2019 10:54:13 +1100

On Fri, Jan 25, 2019, at 01:23, Alissa Cooper wrote:
> I think this is clearly in scope, already discussed in the drafts, and 
> too much of a detail to be included in the charter language itself.

What Alissa said.  Mirroring is covered by the tools interactions stuff.

> I think this is quite clear. If people disagree, suggesting a specific 

BTW, specific changes in the form of pull requests can be made here: https://github.com/martinthomson/ietf-git-charter

I've integrated all the changes we've discussed thus far.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 24 Jan 2019 20:03:42 -0500

> On Jan 24, 2019, at 6:54 PM, Martin Thomson <[email-masked]> wrote:

Thanks. I posted an update to the datatracker and asked the secretariat to send this for external review so the whole community will be alerted to take a look.

Alissa

---

From: Mike Bishop <[email-masked]>
Date: Fri, 25 Jan 2019 01:14:01 +0000

To me, this seems to fall under the mandate to confer with the Tools team on desired tooling support. If the working group decides that an IETF-controlled mirror of the repo is a desired feature, then it is already empowered to make that suggestion. I don't think this particular request needs to be pre-baked into the charter.

Sent from Nine<http://www.9folders.com/>
________________________________
From: Spencer Dawkins at IETF <[email-masked]>
Sent: Thursday, January 24, 2019 11:13 PM
To: Martin Thomson
Cc: [email-masked]
Subject: Re: [Ietf-and-github] Suresh Krishnan's Yes on charter-ietf-git-00-00: (with COMMENT)

On Thu, Jan 24, 2019 at 12:58 AM Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

Spencer