Subject: [Ietf-and-github] Comments related to WG Review: GitHub Integration and Tooling (git)

From: Alissa Cooper <[email-masked]>
Date: Tue, 29 Jan 2019 08:46:20 -0500

There has been some discussion on [email-masked] that relates to the GIT charter that is currently out for review. I know not everyone is subscribed to ietf@ietf, so I’m posting them here as well.

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: Re: sr.ht --- "sir hat" --- alternatives to Github
> Date: January 28, 2019 at 6:49:12 AM EST
> To: Alissa Cooper <[email-masked]>, <[email-masked]>
> Cc: Bob Hinden <[email-masked]>, "Matthew A. Miller" <[email-masked]>, IETF <[email-masked]>
> 
> The charter explicitly calls out Github, rather than the more general git.
> 
> This is, I think, depending on how you look at it, either an attempt to focus the group or a category error, rather akin to the charters for the DTN groups deciding from the outset that bundling was all that DTN was, and now github is all that git is.
> 
> Further category error examples welcomed...
> 
> "How can the IETF take advantage of Windows 10? We'll need a wg charter. No, Clippy is not in scope!"
> 
> 
> Lloyd Wood
> [email-masked]
> 
> really looking forward to Clippy for GitHub and the Office Git assistant, changing how reviewing is done.
> 
> On Sunday, January 27, 2019, 1:15 pm, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Lloyd,
> 
>> On Jan 25, 2019, at 5:49 PM, lloyd.wood=[email-masked] <mailto:lloyd.wood=[email-masked]> wrote:
>> 
>> +1 to Bob's unanswered question. and why is this new list ietf-and-github and not ietf-and-git?
> 
> Mailing lists are cheap. If people felt that creating a separate one for ietf-and-git would be worthwhile, it wouldn’t be hard to do. As it stands both GitHub and git get discussed on the existing list, and that’s not a problem IMO.
> 
> Before initiating chartering of the GIT WG [1] I asked on the ietf-and-github list if people wanted separate lists for the WG and for more general discussion. There was one comment in favor of using ietf-and-github for the WG. That is the current plan.
> 
> Alissa
> 
> [1] https://datatracker.ietf.org/doc/charter-ietf-git/ <https://datatracker.ietf.org/doc/charter-ietf-git/>
> 
>> github is but one provider, backed by a proven monopolist... and that was the choice? that's a question suitable for this general list. So, on this thread topic, what viable alternatives are there?
>> 
>> it also strikes me that setting up a mailing list to discuss use of github is not really entering into the spirit of the thing, or showing github's strengths and weaknesses. it's very much the nice face of the idea.
>> 
>> Create a textfile with the mailing list charter, commit it to github, and then have discussions in the commit comments as everyone commits added trailing spaces to that file. if you're going to embrace github in discussions, do it properly...
>> 
>> 
>> Lloyd Wood
>> [email-masked] <mailto:[email-masked]>
>> 
>> learn git? if I wanted to learn terse unmemorable commands that do arcane things, I'd learn unix.
>> 
>> On Friday, January 25, 2019, 3:44 am, Bob Hinden <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Matthew,
>> 
>> Please explain why this discussion shouldn’t be happening on the IETF list?  Seems relevant to me.
>> 
>> Bob
>> 
>> 
>> > On Jan 24, 2019, at 7:53 AM, Matthew A. Miller <[email-masked] <mailto:[email-masked]>> wrote:
>> > 
>> > All,
>> > 
>> > Please direct all further discussion on using GitHub to <
>> > [email-masked] <mailto:[email-masked]> >.
>> > 
>> > 
>> > Thank you,
>> > 
>> > -
>> > Matthew A. Miller
>> > IETF Sergeant-at-arms
>> > 
>> > On 19/01/24 08:23, Fernando Gont wrote:
>> >> On 22/1/19 20:31, Hector Santos wrote:
>> >>> My opinion.
>> >>> 
>> >>> My only concern is the perception that the IETF is now "requiring" to
>> >>> learn a new suite of 3rd party tools for a single purpose - RFC Draft
>> >>> submissions publishing.  For people doing this all the time, and
>> >>> probably also using the same tools for other parts of their career, I
>> >>> can understand it would be productive, but not for the occasional author.
>> >>> 
>> >>> After several decades, I believe an application level IETF online RFC
>> >>> publishing tool should be available.  In the past, I used XML2RFC (a
>> >>> java app) to outline, produce and publish my drafts. Isn't this
>> >>> available any more?  I would think a HTML5 version would be doable
>> >>> today, and of course, some vcs would be integrated at the backend.
>> >>> 
>> >>> I personally don't want wish to be learning git details and all the
>> >>> other scripting tools and text formats for a single purpose.  I would if
>> >>> I have to at some top level rudimentary level just to get the job, but
>> >>> it is not desirable, and certainly not a career requirement for me.
>> >> 
>> >> Don't worry: https://xkcd.com/1597/  <https://xkcd.com/1597/>(yes, there's a lot of truth to it
>> >> :-) )
>> >> 
>> >> Thanks,
>> >> 
>> > 
> 
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 29 Jan 2019 16:52:44 +0000

While the name of the mailing list is not really important per se, I also find weird to explicitly specify ‘Github’ in the charter rather than ‘Git’ or ‘Github-like’.

Especially when github.com does not have any AAAA :-(

-éric

From: iesg <[email-masked]> on behalf of Alissa Cooper <[email-masked]>
Date: Tuesday, 29 January 2019 at 14:46
To: "[email-masked]" <[email-masked]>, IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Comments related to WG Review: GitHub Integration and Tooling (git)

There has been some discussion on [email-masked]<mailto:[email-masked]> that relates to the GIT charter that is currently out for review. I know not everyone is subscribed to ietf@ietf, so I’m posting them here as well.

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: Re: sr.ht --- "sir hat" --- alternatives to Github
Date: January 28, 2019 at 6:49:12 AM EST
To: Alissa Cooper <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Cc: Bob Hinden <[email-masked]<mailto:[email-masked]>>, "Matthew A. Miller" <[email-masked]<mailto:[email-masked]>>, IETF <[email-masked]<mailto:[email-masked]>>

Lloyd Wood
[email-masked]<mailto:[email-masked]>

On Sunday, January 27, 2019, 1:15 pm, Alissa Cooper <[email-masked]<mailto:[email-masked]>> wrote:
Hi Lloyd,

On Jan 25, 2019, at 5:49 PM, lloyd.wood=[email-masked]<mailto:lloyd.wood=[email-masked]> wrote:

Alissa

[1] https://datatracker.ietf.org/doc/charter-ietf-git/

Lloyd Wood
[email-masked]<mailto:[email-masked]>

On Friday, January 25, 2019, 3:44 am, Bob Hinden <[email-masked]<mailto:[email-masked]>> wrote:
Matthew,

Bob

> On Jan 24, 2019, at 7:53 AM, Matthew A. Miller <[email-masked]<mailto:[email-masked]>> wrote:
>
> All,
>
> [email-masked]<mailto:[email-masked]> >.
>
>
> Thank you,
>
> -
> Matthew A. Miller
> IETF Sergeant-at-arms
>
>> Don't worry: https://xkcd.com/1597/ (yes, there's a lot of truth to it
>> :-) )
>>
>> Thanks,
>>
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 29 Jan 2019 13:08:21 -0800

n Tue, Jan 29, 2019 at 8:52 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> While the name of the mailing list is not really important per se, I also
> find weird to explicitly specify ‘Github’ in the charter rather than ‘Git’
> or ‘Github-like’.
>
>
Well, this stuff would work for anything that's very close to Github, but I
don't want us to spend a lot of time dealing with all the variant
Github-type thing.

> Especially when github.com does not have any AAAA :-(

This I strongly disagree with. We should be picking tools primarily on
usefulness, not on whether we think they are adopting our protocols fast
enough.

-Ekr

>
> -éric
>
>
>
> *From: *iesg <[email-masked]> on behalf of Alissa Cooper <
> [email-masked]>
> *Date: *Tuesday, 29 January 2019 at 14:46
> *To: *"[email-masked]" <[email-masked]>, IESG <
> [email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Comments related to WG Review: GitHub Integration and Tooling
> (git)
>
>
>
> There has been some discussion on [email-masked] that relates to the GIT
> charter that is currently out for review. I know not everyone is subscribed
> to ietf@ietf, so I’m posting them here as well.
>
>
>
> Begin forwarded message:
>
>
>
> *From: [email-masked]
>
> *Subject: Re: sr.ht <http://sr.ht> --- "sir hat" --- alternatives to
> Github*
>
> *Date: *January 28, 2019 at 6:49:12 AM EST
>
> *To: *Alissa Cooper <[email-masked]>, <[email-masked]>
>
> *Cc: *Bob Hinden <[email-masked]>, "Matthew A. Miller" <
> [email-masked]>, IETF <[email-masked]>
>
>
>
> This is, I think, depending on how you look at it, either an attempt to
> focus the group or a category error, rather akin to the charters for the
> DTN groups deciding from the outset that bundling was all that DTN was, and
> now github is all that git is.
>
>
>
> On Jan 25, 2019, at 5:49 PM, lloyd.wood=[email-masked]
> wrote:
>
>
>
> Mailing lists are cheap. If people felt that creating a separate one for
> ietf-and-git would be worthwhile, it wouldn’t be hard to do. As it stands
> both GitHub and git get discussed on the existing list, and that’s not a
> problem IMO.
>
>
>
> Before initiating chartering of the GIT WG [1] I asked on the
> ietf-and-github list if people wanted separate lists for the WG and for
> more general discussion. There was one comment in favor of using
> ietf-and-github for the WG. That is the current plan.
>
>
>
> Alissa
>
>
>
> github is but one provider, backed by a proven monopolist... and that was
> the choice? that's a question suitable for this general list. So, on this
> thread topic, what viable alternatives are there?
>
>
>
> it also strikes me that setting up a mailing list to discuss use of github
> is not really entering into the spirit of the thing, or showing github's
> strengths and weaknesses. it's very much the nice face of the idea.
>
>
>
> Create a textfile with the mailing list charter, commit it to github, and
> then have discussions in the commit comments as everyone commits added
> trailing spaces to that file. if you're going to embrace github in
> discussions, do it properly...
>
>
>
> Lloyd Wood
>
> [email-masked]
>
>
>
> On Friday, January 25, 2019, 3:44 am, Bob Hinden <[email-masked]>
> wrote:
>
> Matthew,
>
> > On Jan 24, 2019, at 7:53 AM, Matthew A. Miller <linuxwolf+
> [email-masked]> wrote:
> >
> > All,
> >
> > [email-masked] >.
> >
> >
> > Thank you,
> >
> > -
> > Matthew A. Miller
> > IETF Sergeant-at-arms
> >

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 30 Jan 2019 14:02:12 +0000

Eric,

Let’s state that indeed we disagree on this point...

Leading by example is efficient and I cannot imagine having a tool or a process of the IETF not using IPv6, or not using TLS or not having DNSEC...

-éric

From: Eric Rescorla <[email-masked]>
Date: Tuesday, 29 January 2019 at 22:09
To: Eric Vyncke <[email-masked]>
Cc: Alissa Cooper <[email-masked]>, "[email-masked]" <[email-masked]>, IESG <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Comments related to WG Review: GitHub Integration and Tooling (git)

Especially when github.com<http://github.com> does not have any AAAA :-(

This I strongly disagree with. We should be picking tools primarily on usefulness, not on whether we think they are adopting our protocols fast enough.

-Ekr

-éric

From: iesg <[email-masked]<mailto:[email-masked]>> on behalf of Alissa Cooper <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 29 January 2019 at 14:46
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, IESG <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Comments related to WG Review: GitHub Integration and Tooling (git)

Begin forwarded message:

Subject: Re: sr.ht<http://sr.ht> --- "sir hat" --- alternatives to Github

Lloyd Wood

Alissa

Lloyd Wood

Bob

---

From: Warren Kumari <[email-masked]>
Date: Wed, 30 Jan 2019 11:34:14 -0500

On Wed, Jan 30, 2019 at 9:02 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> Leading by example is efficient and I cannot imagine having a tool or a
> process of the IETF not using IPv6, or not using TLS or not having DNSEC...
>

dig DS webex.com
dig AAAA global-nebulaab9.webex.com
Dunno about you, but I just started a webex and the media transport was all
V4. This may be an anomaly - at some point webex was v6...

dig rrsig yangcatalog.org
dig rrsig rsync.tools.ietf.org

dig rrsig xml2rfc.tools.ietf.org

We have many tools which we use which don't have DNSSEC....

W

>
> -éric
>
>
>
> *From: *Eric Rescorla <[email-masked]>
> *Date: *Tuesday, 29 January 2019 at 22:09
> *To: *Eric Vyncke <[email-masked]>
> *Cc: *Alissa Cooper <[email-masked]>, "[email-masked]" <
> [email-masked]>, IESG <[email-masked]>, "[email-masked]"
> <[email-masked]>
> *Subject: *Re: Comments related to WG Review: GitHub Integration and
> Tooling (git)
>
>
>
>
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 30 Jan 2019 16:38:27 +0000

Isn’t “we’re not the protocol police” one of the aphorisms we like to say about ourselves, shortly after rough consensus and running code?

---

From: Ben Campbell <[email-masked]>
Date: Wed, 30 Jan 2019 11:49:19 -0600

I have to agree with Ekr on this. I can see using lack of support for some IETF technology as a deciding factor between two solutions that otherwise work for us. But we should not reject a solution over the lack of such support unless it has a practical impact on useability.

(I am agonistic as to whether this particular limitation has a practical impact.)

Ben.

> On Jan 30, 2019, at 8:02 AM, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 
> Eric,
> 
>> Especially when github.com <http://github.com/> does not have any AAAA :-(
> 
>> From: iesg <[email-masked] <mailto:[email-masked]>> on behalf of Alissa Cooper <[email-masked] <mailto:[email-masked]>>
>> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, IESG <[email-masked] <mailto:[email-masked]>>
>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> There has been some discussion on [email-masked] <mailto:[email-masked]> that relates to the GIT charter that is currently out for review. I know not everyone is subscribed to ietf@ietf, so I’m posting them here as well.
>> 
>> 
>>> Begin forwarded message:
>>> 
>>> From: [email-masked] <mailto:[email-masked]>
>>> Subject: Re: sr.ht <http://sr.ht/> --- "sir hat" --- alternatives to Github
>>> To: Alissa Cooper <[email-masked] <mailto:[email-masked]>>, <[email-masked] <mailto:[email-masked]>>
>>> Cc: Bob Hinden <[email-masked] <mailto:[email-masked]>>, "Matthew A. Miller" <[email-masked] <mailto:[email-masked]>>, IETF <[email-masked] <mailto:[email-masked]>>
>>> 
>>> On Sunday, January 27, 2019, 1:15 pm, Alissa Cooper <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> Hi Lloyd,
>>>> 
>>>>

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 30 Jan 2019 09:51:12 -0800

On January 29, 2019 at 4:09:09 PM, Eric Rescorla ([email-masked]) wrote:

Thinking out loud:  Is there a way to generalize the charter to deal with
Github-type things, while having the WG explicitly focus on Github
initially?  IOW, the deliverables would be focus on Github, with the
possibility to deal with variants once the initial work is done.

My 1c.

Alvaro.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 30 Jan 2019 18:39:06 +0000

Ben,

I was probably too fast / passionate in my reply but I agree with you: in case of a tie among solutions, the support of new IETF protocols is a tie-breaker but it should not be a blocking factor.

Warren, I liked the well-targeted choice of counter-examples ;-)

-éric

From: Ben Campbell <[email-masked]>
Date: Wednesday, 30 January 2019 at 18:49
To: Eric Vyncke <[email-masked]>
Cc: Eric Rescorla <[email-masked]>, "[email-masked]" <[email-masked]>, Alissa Cooper <[email-masked]>, IESG <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Comments related to WG Review: GitHub Integration and Tooling (git)

Ben.

On Jan 30, 2019, at 8:02 AM, Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>> wrote:

Eric,

-éric

From: Eric Rescorla <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 29 January 2019 at 22:09
To: Eric Vyncke <[email-masked]<mailto:[email-masked]>>
Cc: Alissa Cooper <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, IESG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Comments related to WG Review: GitHub Integration and Tooling (git)

Especially when github.com<http://github.com/> does not have any AAAA :-(

-Ekr

-éric

Begin forwarded message:

Subject: Re: sr.ht<http://sr.ht/> --- "sir hat" --- alternatives to Github

Lloyd Wood

Alissa

Lloyd Wood

Bob

>> Don't worry: https://xkcd.com/1597/ <https://xkcd.com/1597/> (yes, there's a lot of truth to it
>> :-) )
>>
>> Thanks,
>>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 31 Jan 2019 08:44:09 +1300

> (I am agonistic as to whether this particular limitation has a practical impact.)

Does GitHub work for a user on an IPv6-only network with NAT64/DNS64 connectivity to the IPv4 legacy Internet?

If yes, it's compatible with our dog food.

If not, does this have a practical impact on any participants?

    Brian

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 22:28:39 +0000

“…possibility to deal with variants after the initial work is done” sounds an awful lot like a recharter.

I’m inclined to think that charters don’t need to discuss what will happen after a future recharter, but there is some precedent for doing so.  In QUIC’s charter, for example:  “Upon completion of [HTTP], additional protocols may be added by updating this charter to include them.”

From: Ietf-and-github <[email-masked]> On Behalf Of Alvaro Retana
Sent: Thursday, January 31, 2019 2:51 AM
To: Eric Rescorla <[email-masked]>; Eric Vyncke (evyncke) <[email-masked]>
Cc: [email-masked]; Alissa Cooper <[email-masked]>; IESG <[email-masked]>; [email-masked]
Subject: Re: [Ietf-and-github] Comments related to WG Review: GitHub Integration and Tooling (git)

On January 29, 2019 at 4:09:09 PM, Eric Rescorla ([email-masked]<mailto:[email-masked]>) wrote:
While the name of the mailing list is not really important per se, I also find weird to explicitly specify ‘Github’ in the charter rather than ‘Git’ or ‘Github-like’.
Well, this stuff would work for anything that's very close to Github, but I don't want us to spend a lot of time dealing with all the variant Github-type thing.

Thinking out loud:  Is there a way to generalize the charter to deal with Github-type things, while having the WG explicitly focus on Github initially?  IOW, the deliverables would be focus on Github, with the possibility to deal with variants once the initial work is done.

My 1c.

Alvaro.