Subject: [Ietf-and-github] Eric Rescorla's No Objection on charter-ietf-git-00-00: (with COMMENT)

From: Eric Rescorla <[email-masked]>
Date: Wed, 23 Jan 2019 20:13:06 -0800

Eric Rescorla has entered the following ballot position for
charter-ietf-git-00-00: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-git/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I am fine with this, but it seems to leave open the question about whether
these policies would be binding if you chose to use Github -- though obviously
non-binding if you chose to use Bitbucket or something. I'm sure the answer is
"no", but maybe we should make that clear?

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Jan 2019 18:08:36 +1100

> "no", but maybe we should make that clear?

This probably needs a little unpacking.  The intent, which I think might have been poorly captured (see below) was that working groups could adopt the policies to aid them in doing work.  Adopting the policies would be discretionary.  Presumably if they wanted to change details of the policy, then that would be fine too.

In your example, it might be reasonable to say that a working group could choose to use a substantially similar service, but otherwise adopt the policies without modification.

I think that it was probably this bit that you stumbled on:

> Whether working groups choose to use GitHub to support their work will remain entirely at their discretion.

Is this clearer?

> Whether working groups choose to use GitHub or the documented policies to support their work will remain entirely at their discretion.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Jan 2019 05:08:15 -0800

On Wed, Jan 23, 2019 at 11:08 PM Martin Thomson <[email-masked]> wrote:

> This probably needs a little unpacking.  The intent, which I think might
> have been poorly captured (see below) was that working groups could adopt
> the policies to aid them in doing work.  Adopting the policies would be
> discretionary.  Presumably if they wanted to change details of the policy,
> then that would be fine too.
>
> In your example, it might be reasonable to say that a working group could
> choose to use a substantially similar service, but otherwise adopt the
> policies without modification.
>

Yes, because it implies that maybe if you used Github, you would have to
adopt these policies.

> > Whether working groups choose to use GitHub or the documented policies
> to support their work will remain entirely at their discretion.
>

SGTM

-Ekr

> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>