Subject: [Ietf-and-github] I-D Action: draft-ietf-git-github-wg-configuration-00.txt

From: [email-masked]
Date: Wed, 13 Feb 2019 19:26:41 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the GitHub Integration and Tooling WG of the IETF.

        Title           : GitHub Configuration for IETF Working Groups
        Authors         : Alissa Cooper
                          Paul Hoffman
	Filename        : draft-ietf-git-github-wg-configuration-00.txt
	Pages           : 7
	Date            : 2019-02-13

Abstract:
   The use of GitHub in IETF working group processes is increasing.
   This document describes possible uses and conventions for working
   groups which are considering starting to use GitHub.  It does not
   mandate any processes, and does not intend to change the processes
   used by current working groups.

   Discussion of this document takes place on the ietf-and-github
   mailing list ([email-masked]), which is archived at
   <https://mailarchive.ietf.org/arch/search?email_list=ietf-and-
   github>.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-git-github-wg-configuration/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-git-github-wg-configuration-00
https://datatracker.ietf.org/doc/html/draft-ietf-git-github-wg-configuration-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mike Bishop <[email-masked]>
Date: Thu, 14 Feb 2019 03:44:57 +0000

Not that I object to the specific draft at all, but I must admit I'm surprised to see that a draft can be adopted by a working group that has had only one message to the mailing list since the working group was formed....  Did I miss the call for adoption somewhere?

(Also, this draft presumably replaces draft-cooper-wugh-github-wg-configuration, but that link wasn't made in Datatracker.  One of the things the I-D Template's auto-submission can't do yet.)

-----Original Message-----
From: Ietf-and-github <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, February 13, 2019 7:27 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ietf-and-github] I-D Action: draft-ietf-git-github-wg-configuration-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Ietf-and-github mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Feb 2019 15:08:07 +1100

Let me second Mike in being surprised.

On Thu, Feb 14, 2019, at 14:44, Mike Bishop wrote:
> Not that I object to the specific draft at all, but I must admit I'm 
> surprised to see that a draft can be adopted by a working group that has 
> had only one message to the mailing list since the working group was 
> formed....  Did I miss the call for adoption somewhere?
> 
> (Also, this draft presumably replaces draft-cooper-wugh-github-wg-
> configuration, but that link wasn't made in Datatracker.  One of the 
> things the I-D Template's auto-submission can't do yet.)
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
>

---

From: Lars Eggert <[email-masked]>
Date: Thu, 14 Feb 2019 08:54:31 +0200

> Let me second Mike in being surprised.

Ditto. The optics are problematic, especially since a WG chair is a co-author.

Lars

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 14 Feb 2019 15:15:21 +0000

> Not that I object to the specific draft at all, but I must admit I'm surprised to see that a draft can be adopted by a working group that has had only one message to the mailing list since the work…

It was part of the charter discussion. The previous draft, draft-cooper-wugh-github-wg-configuration, is explicitly listed in the charter as a milestone. This -00 is identical to that draft, except with the filename changed.

> (Also, this draft presumably replaces draft-cooper-wugh-github-wg-configuration, but that link wasn't made in Datatracker.  One of the things the I-D Template's auto-submission can't do yet.)

That can be done today.

> Let me second Mike in being surprised.

Your draft, draft-thomson-github-bcp, is also listed in the charter as a milestone.

> Ditto. The optics are problematic, especially since a WG chair is a co-author.

We two co-chairs discussed this yesterday afternoon before submitting the draft to fulfill the charter. Because I will be an active co-author on one of the two chartered drafts, I will be mostly ceremonial as co-chair. I will certainly not be making any consensus calls. If I fail to edit the document in a way consistent with the WG's desire, my co-chair is encouraged to fire me as document co-author. (I wish more WG chairs would do this instead of dragging out WG conflicts, but that's a different topic.)

--Paul Hoffman

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 14 Feb 2019 17:29:31 -0500

> Your draft, draft-thomson-github-bcp, is also listed in the charter as 

Yes, it is, however, customary to confirm the adoption call.  It avoids these little surprises and gives people a chance to consider the document again in the new context.