Subject: Re: [Ietf-and-github] Comments related to WG Review: GitHub Integration and Tooling (git)

From: Alissa Cooper <[email-masked]>
Date: Mon, 4 Feb 2019 14:58:40 -0500

I made a suggested addition in response to this thread so that is clear what is and is not in scope: https://github.com/martinthomson/ietf-git-charter/pull/1/files

Thoughts?

Alissa

> On Jan 30, 2019, at 5:28 PM, Mike Bishop <[email-masked]> wrote:
> 
> “…possibility to deal with variants after the initial work is done” sounds an awful lot like a recharter.
>  
> I’m inclined to think that charters don’t need to discuss what will happen after a future recharter, but there is some precedent for doing so.  In QUIC’s charter, for example:  “Upon completion of [HTTP], additional protocols may be added by updating this charter to include them.”
>  
> From: Ietf-and-github <[email-masked] <mailto:[email-masked]>> On Behalf Of Alvaro Retana
> Sent: Thursday, January 31, 2019 2:51 AM
> To: Eric Rescorla <[email-masked] <mailto:[email-masked]>>; Eric Vyncke (evyncke) <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; Alissa Cooper <[email-masked] <mailto:[email-masked]>>; IESG <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> Subject: Re: [Ietf-and-github] Comments related to WG Review: GitHub Integration and Tooling (git)
>  
> On January 29, 2019 at 4:09:09 PM, Eric Rescorla ([email-masked] <mailto:[email-masked]>) wrote:
> While the name of the mailing list is not really important per se, I also find weird to explicitly specify ‘Github’ in the charter rather than ‘Git’ or ‘Github-like’.
> Well, this stuff would work for anything that's very close to Github, but I don't want us to spend a lot of time dealing with all the variant Github-type thing.
> Thinking out loud:  Is there a way to generalize the charter to deal with Github-type things, while having the WG explicitly focus on Github initially?  IOW, the deliverables would be focus on Github, with the possibility to deal with variants once the initial work is done.
> 
> My 1c.
> 
> Alvaro.
> 
>  
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ietf-and-github <https://www.ietf.org/mailman/listinfo/ietf-and-github>

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 4 Feb 2019 14:49:54 -0800

On February 4, 2019 at 2:58:43 PM, Alissa Cooper ([email-masked]) wrote:

I made a suggested addition in response to this thread so that is clear
what is and is not in scope:
https://github.com/martinthomson/ietf-git-charter/pull/1/files

Thoughts?

That works for me.

Thanks!

Alvaro.

Alissa

“…possibility to deal with variants after the initial work is done” sounds
an awful lot like a recharter.

I’m inclined to think that charters don’t need to discuss what will happen
after a future recharter, but there is some precedent for doing so.  In
QUIC’s charter, for example:  “Upon completion of [HTTP], additional
protocols may be added by updating this charter to include them.”

*From:* Ietf-and-github <[email-masked]> *On Behalf
Of *Alvaro
Retana
*Sent:* Thursday, January 31, 2019 2:51 AM
*To:* Eric Rescorla <[email-masked]>; Eric Vyncke (evyncke) <[email-masked]
*Cc:* [email-masked]; Alissa Cooper <[email-masked]>; IESG <
[email-masked]>; [email-masked]
*Subject:* Re: [Ietf-and-github] Comments related to WG Review: GitHub
Integration and Tooling (git)

On January 29, 2019 at 4:09:09 PM, Eric Rescorla ([email-masked]) wrote:

While the name of the mailing list is not really important per se, I also
find weird to explicitly specify ‘Github’ in the charter rather than ‘Git’
or ‘Github-like’.

Well, this stuff would work for anything that's very close to Github, but I
don't want us to spend a lot of time dealing with all the variant
Github-type thing.

Thinking out loud:  Is there a way to generalize the charter to deal with
Github-type things, while having the WG explicitly focus on Github
initially?  IOW, the deliverables would be focus on Github, with the
possibility to deal with variants once the initial work is done.

My 1c.

Alvaro.

_______________________________________________
Ietf-and-github mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf-and-github