Subject: Re: [Ietf-and-github] I-D Action: draft-thomson-git-using-github-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Fri, 15 Feb 2019 16:06:01 +1300

Hi,

Somewhere, and probably in this draft, it seems to me that we need a more
detailed discussion of how using github relates to the IETF standards
process as described in RFC2026 and RFC2418. I hope we agree that it's
only a tool, but we need to explain better how it fits in.

One specific comment for now. In section 6 "Assessing Consensus" it says:

   A working group chair SHOULD consult the working group mailing list
   for any issue that is potentially contentious.

Surely that should be a MUST? It's a very basic principle that consensus
on the mailing list is all that really counts.

Another possible issue is that unfortunately we've had to bring in rules
on how to handle disruptive behaviour on mailing lists. I assume the same
thing could happen in a github issue tracker (and the fact that it hasn't
happened yet doesn't prove that it won't happen in future). Maybe we can
simply say that the existing measures that can be applied to mailing list
participation may be extended to issue trackers. And of course github usage
falls within the scope of both the anti-harassment and Ombudsperson BCPs.

Regards
  Brian

---

From: Bret Jordan <[email-masked]>
Date: Thu, 14 Feb 2019 20:25:19 -0700

I agree.

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

> On Feb 14, 2019, at 8:06 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 14 Feb 2019 22:32:04 -0500

Thanks Brian,

> only a tool, but we need to explain better how it fits in.

Agreed.  I haven't done the analysis here, but can see how that's appropriate.

https://github.com/martinthomson/ietf-using-github/issues/6
 
> on the mailing list is all that really counts.

Yes.  I don't know how that ended up as a SHOULD now that you point it out.  I made it MUST.

https://github.com/martinthomson/ietf-using-github/commit/80ad5a22a26de688fc9a5d9f72a58d013721b7a8

> happened yet doesn't prove that it won't happen in future). 

Unfortunately, that's not the case.  That you have not seen this in action is because it was handled quietly, but there is at least one case I'm aware of.  I believe that the chairs and AD followed the same process as we might for blocking access to a mailing list, more or less.  (I'm fuzzy on the details, I had already muted the individual in question on the basis of other interactions.)  The tools here are less good, but they are probably spending some time on.

https://github.com/martinthomson/ietf-using-github/issues/5