Subject: [Ietf-and-github] Adding "beyond GitHub" text to draft-ietf-git-github-wg-configuration

From: Paul Hoffman <[email-masked]>
Date: Sun, 3 Mar 2019 16:07:32 +0000

Greetings again. Some people have stated concern that this document will make it look like WGs are expected to use GitHub, even though the document's Abstract and Introduction say the opposite. Another way help IETF participants who are reading the document understand that this is not the intention of the document would be to add another sentence at the end of the first paragraph of the Introduction indicating that there are other choices. I propose the following:

Some other working groups use or plan to use other tools such at GitLab and Bitbucket, which have different properties than GitHub.

Does that satisfy the concern? If not what additional text would help?

--Paul Hoffman

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 3 Mar 2019 13:18:49 -0500

"other code repository services" instead of "tools" but I am probably being
pedantic.

Tim

On Sun, Mar 3, 2019 at 11:07 AM Paul Hoffman <[email-masked]> wrote:

> Greetings again. Some people have stated concern that this document will
> make it look like WGs are expected to use GitHub, even though the
> document's Abstract and Introduction say the opposite. Another way help
> IETF participants who are reading the document understand that this is not
> the intention of the document would be to add another sentence at the end
> of the first paragraph of the Introduction indicating that there are other
> choices. I propose the following:
>
> Some other working groups use or plan to use other tools such at GitLab
> and Bitbucket, which have different properties than GitHub.
>
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 3 Mar 2019 18:20:32 +0000

On Mar 3, 2019, at 10:18 AM, Tim Wicinski <[email-masked]> wrote:
> 
> 
> "other code repository services" instead of "tools" but I am probably being pedantic.  

Pedantic is just fine here. Thanks!

--Paul Hoffman

---

From: Stephan Wenger <[email-masked]>
Date: Sun, 3 Mar 2019 18:21:21 +0000

… there are probably still a few WG out who reject all this newfangled stuff and stay with email.  Please don’t forget those.
Stephan

From: Ietf-and-github <[email-masked]> on behalf of Tim Wicinski <[email-masked]>
Date: Sunday, March 3, 2019 at 10:19
To: Paul Hoffman <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Ietf-and-github] Adding "beyond GitHub" text to draft-ietf-git-github-wg-configuration

Tim

On Sun, Mar 3, 2019 at 11:07 AM Paul Hoffman <[email-masked]<mailto:[email-masked]>> wrote:
Greetings again. Some people have stated concern that this document will make it look like WGs are expected to use GitHub, even though the document's Abstract and Introduction say the opposite. Another way help IETF participants who are reading the document understand that this is not the intention of the document would be to add another sentence at the end of the first paragraph of the Introduction indicating that there are other choices. I propose the following:

--Paul Hoffman
_______________________________________________
Ietf-and-github mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 3 Mar 2019 18:33:20 +0000

On Mar 3, 2019, at 10:21 AM, Stephan Wenger <[email-masked]> wrote:
> 
> … there are probably still a few WG out who reject all this newfangled stuff and stay with email.

There are many.

>  Please don’t forget those.

They are not forgotten. If you have specific text for the current draft that would make that more obvious, please suggest.

--Paul Hoffman

---

From: Bret Jordan <[email-masked]>
Date: Sun, 3 Mar 2019 11:45:42 -0700

Maybe something more simple like Github is one of many methods a WG may use.....

Bret 

Sent from my Commodore 128D

PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050

> On Mar 3, 2019, at 11:33 AM, Paul Hoffman <[email-masked]> wrote:
>

---

From: Hector Santos <[email-masked]>
Date: Mon, 04 Mar 2019 11:45:44 -0500

> Does that satisfy the concern? If not what additional text would help?

Unless the future RFC is generalized, the "promotion" (and rough 
consensus direction) will be to use GitHub. Perhaps a generalized 
"Using GIT for IETF" (IETF-GIT) baseline document would be useful 
where the "GIT I/O commonality" can be established among popular GIT 
hosting sites.   Then the specific "Using GitHUB for IETF Publishing" 
can reference the baseline IETF-GIT doc.  Similar informational RFCs 
can be written for Gitlib and  BitBucket both also referencing IETF-GIT.

Personally, pick one (GitHub) and stick with it for IETF adoption, 
less confusion, especially when the RFC will be asking folks to 
"learn" something new.  Why deviate from the (pending) norm?

-- 
HLS

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 4 Mar 2019 17:22:04 +0000

GitHub is very popular.  There are also significant and important people who have technical and/or philosophical issues about using GitHub and maybe even using Git. I don't see why this is different from any other RFC.  If you're going to use GitHub, here's how to do it.

We aren't the protocol police and I don't think we're the Git Police either.