Subject: [Ietf-and-github] GitHub usage for GIT

From: Christopher Wood <[email-masked]>
Date: Tue, 9 Apr 2019 08:56:28 -0700

In Prague, we decided to adopt the “light” usage profile GitHub for WG
documents. This has the following implications:

1. All WG documents will be hosted under the GIT organization, located
here: https://github.com/ietf-gitwg
2. WG contributors are encouraged to post issues on the documents
either on the mailing list or as issues in the GitHub issue list. The
authors will use the GitHub issues list to keep track of open and
closed issues, but all substantive discussion of the issues should be
on the mailing list. Thus, if an issue is opened on GitHub, the
document authors should copy it to the list for discussion. Similarly,
if an issue comes up first on the mailing list, the authors will open
an issue on GitHub to help track it.

We will configure some tooling to track GitHub activity in WG
documents and send weekly summaries to the list. This will help those
not following GitHub stay informed of issues or PRs filed.

And finally, as before, consensus will always take place on the list.

Thanks,
Chris and Paul

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 9 Apr 2019 13:13:01 -0400

> an issue on GitHub to help track it.

This is great; one question that may necessitate forking this thread: I've
used MT's template to good effect, but I haven't contributed to a WG that
uses continuous integration (which sounds so awesome now that I know a bit
about what that does).

Do we plan to do anything in this WG related to CI tools? I know some WGs
have a soft (or hard?) requirement to use CI tools and submit PRs, etc. via
the CI tooling. It would be great if there were good pointers on "How to
get up to speed with CI tools as used in IETF WGs". I'm going to muddle
around a bit and may be helpful contributing to an ID on this kind of stuff
after my newbie-to-CI journey.

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Christopher Wood <[email-masked]>
Date: Tue, 9 Apr 2019 18:16:13 -0700

On Tue, Apr 9, 2019 at 10:13 AM Joseph Lorenzo Hall <[email-masked]> wrote:
>
> On Tue, Apr 9, 2019 at 11:56 AM Christopher Wood <[email-masked]> wrote:
>>
> This is great; one question that may necessitate forking this thread: I've used MT's template to good effect, but I haven't contributed to a WG that uses continuous integration (which sounds so awesome now that I know a bit about what that does).
>
> Do we plan to do anything in this WG related to CI tools? I know some WGs have a soft (or hard?) requirement to use CI tools and submit PRs, etc. via the CI tooling. It would be great if there were good pointers on "How to get up to speed with CI tools as used in IETF WGs". I'm going to muddle around a bit and may be helpful contributing to an ID on this kind of stuff after my newbie-to-CI journey.

Yes, definitely. In addition to the document(s*) we're currently
working on, one desirable outcome is improved (and consolidated)
documentation for using all of the tools located here:

   https://github.com/ietf-gitwg/wg-materials/wiki/Tooling

In Prague, several WG attendees signaled an interest and willingness
to help with this effort. I'll send out more information on this topic
soon.

Best,
Chris

*draft-thomson-git-using-github is not yet adopted, though the
consensus call closes on Thursday.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Apr 2019 11:24:36 +1000

> On 10 Apr 2019, at 1:56 am, Christopher Wood <[email-masked]> wrote:
> 
> WG contributors are encouraged to post issues on the documents

Creating issues in GitHub already has a very low bar, so I'm not sure this is encouraging good behaviour; effectively, this is making the authors do work for anyone who cares to create an issue, no matter how trivial. If the volume is low this might suffice, but is this something we want to promote to other WGs?

(I was tempted to open an issue on GitHub to prove my point here, but I won't abuse the authors...yet).

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Christopher Wood <[email-masked]>
Date: Tue, 9 Apr 2019 18:29:22 -0700

> Creating issues in GitHub already has a very low bar, so I'm not sure this is encouraging good behaviour; effectively, this is making the authors do work for anyone who cares to create an issue, no…

I suspect the volume will be quite low, which is why the text is
framed as such. (Perhaps that list "will" could be a "may.") In
general, authors should use their best judgement here. If an issue
arises on the list that they don't want to lose sight of, file an
issue on the corresponding draft's repo.

> (I was tempted to open an issue on GitHub to prove my point here, but I won't abuse the authors...yet).

:-)

Best,
Chris

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 09 Apr 2019 22:51:19 -0400

On Wed, Apr 10, 2019, at 11:24, Mark Nottingham wrote:
> Creating issues in GitHub already has a very low bar, so I'm not sure 
> this is encouraging good behaviour; effectively, this is making the 
> authors do work for anyone who cares to create an issue, no matter how 
> trivial. If the volume is low this might suffice, but is this something 
> we want to promote to other WGs?

I'm fairly sure that we can rely on authors to filter out spam.  Yes, opening an issue creates work for authors, but in my experience, hitting the close button is pretty quick.  I also know how to block people who really abuse the tracker.

> won't abuse the authors...yet).

Please do open an issue.  We need to understand what recommendations we make to working group about issue creation.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Apr 2019 13:35:32 +1000

> On 10 Apr 2019, at 12:51 pm, Martin Thomson <[email-masked]> wrote:
> 

I read the text as saying that an author is expected to send email to the WG for each new issues that's raised.

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 10 Apr 2019 00:19:20 -0400

On Wed, Apr 10, 2019, at 13:35, Mark Nottingham wrote:
> I read the text as saying that an author is expected to send email to 
> the WG for each new issues that's raised.

Ahh, if you take a strict reading, that's a denial of service attack.  Generally, I prefer to have the person who opens the issue bring it to the list.  And I will not take a non-issue to the list, even if someone opens a GitHub issue.  So a looser interpretation is fine.

---

From: Sean Turner <[email-masked]>
Date: Wed, 10 Apr 2019 00:27:09 -0400

> On Apr 10, 2019, at 00:19, Martin Thomson <[email-masked]> wrote:
> 

I am hoping that we lean towards Martin’s preference here.

spt

---

From: Christopher Wood <[email-masked]>
Date: Tue, 9 Apr 2019 21:49:29 -0700

On Tue, Apr 9, 2019 at 9:27 PM Sean Turner <[email-masked]> wrote:

> > Ahh, if you take a strict reading, that's a denial of service attack.
> Generally, I prefer to have the person who opens the issue bring it to the
> list.  And I will not take a non-issue to the list, even if someone opens a
> GitHub issue.  So a looser interpretation is fine.
>

Correct — looser interpretation was the intent!

Best,
Chris

>
> spt
>
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 10 Apr 2019 16:20:47 +0000

>> Generally, I prefer to have the person who opens the issue bring it to the list.  

>    I am hoping that we lean towards Martin’s preference here.

Me too.  And we can encourage that by putting some reminder text into .github/ISSUE_TEMPLATE; see https://help.github.com/en/articles/manually-creating-a-single-issue-template-for-your-repository

---

From: Mike Bishop <[email-masked]>
Date: Thu, 11 Apr 2019 04:15:17 +0000

I would also loosen along the axis that purely editorial issues need not be brought to the list, even if they are actual issues.