Subject: [Ietf-and-github] FW: YANG Model Formatting

From: "Salz, Rich" <[email-masked]>
Date: Tue, 9 Apr 2019 15:23:36 +0000

Something to automate at some point I suppose.

From: "Acee Lindem (acee)" <[email-masked]>
Date: Monday, April 8, 2019 at 5:28 PM
To: 'WG Chairs' <[email-masked]>
Cc: Martin Bjorklund <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: YANG Model Formatting

All,

I had a YANG model RFC discussion with the Sandy Ginoza, RFC Editor, at IETF 104 and she indicated that they are using pyang to format YANG models prior to publication. It would help greatly if authors do the formatting in advance to facilitate reviews and lessen the RFC Editor task. Here are the commands in use:

pyang -f yang --keep-comments
pyang --ietf --max-line-length 69

Thanks,
Acee

---

From: Kent Watsen <[email-masked]>
Date: Tue, 9 Apr 2019 15:49:23 +0000

I plan to add it to `xiax`.

> On Apr 9, 2019, at 11:23 AM, Salz, Rich <[email-masked]> wrote:
> 
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ietf-and-github <https://www.ietf.org/mailman/listinfo/ietf-and-github>